4 Replies Latest reply on Feb 5, 2019 2:55 PM by wila

    VMware Fusion 7.1.1 + Mac OS X Yosemite 10.10.2 w/ Win8 VM - Key Mappings Not Working

    bttf Lurker

      Hello,

       

      I have a Win8 VM running on my Mac OS X (Yosemite 10.10.2) and have noticed the key mappings are wrong for several keys. I am using an English language keyboard layout. Symbols like @ and " are interchanged, and backslash is only type-able by using the Right + ALT key (not the left) in conjunction with the backslash key.

       

      After reading a few forum posts of similar issues I implemented the 'workaround' by mapping the keys in the keyboard settings. The only problem is the backslash key is unmappable by this method. For some reason only the Right Alt key works in producing the backslash and the configuration cannot simulate right or left Alt key, just simply Alt. Also there are other characters that I am unable to produce using the keyboard because I have no idea what key combination produces it (the pipe character for example).

       

      This is a PITA, please help!

       

      Thanks,

      Adnan

        • 1. Re: VMware Fusion 7.1.1 + Mac OS X Yosemite 10.10.2 w/ Win8 VM - Key Mappings Not Working
          RobXG Lurker

          I have the same issue. At least your post has given me a way to type the backslash (\) character using the right option key + \.

           

          Do you know how to type the # character? On my keyboard it's shift + 3, but that produces £ symbol on Windows and I can't find a keystroke combination that produces it.

           

          I installed SharpKeys on Windows 10 running on Fusion 8 and MacBook Pro keyboard with Mac OS 10.14.2. When I try to remap keys using the "Type Key" option, it correctly maps all the keys so I can't remap them (i.e. shift + 3 shows #, but when I type it in say Notepad, it shows as £, which is opt + 3 on Mac OS). The same happens with @ and " (which are swapped), Aggh.

           

          How is it that two applications map keystrokes differently?

          • 2. Re: VMware Fusion 7.1.1 + Mac OS X Yosemite 10.10.2 w/ Win8 VM - Key Mappings Not Working
            wila Guru
            Community WarriorsUser ModeratorsvExpert

            Hi,

             

            Sounds like your windows is currently using the British keyboard layout.

            Have you tried changing keyboard layouts within windows itself already?

             

            Eg.

            Windows menu -> Settings -> Time & Language -> Region & Language -> Select a language and it lets you add keyboard layouts there for the selected language.

             

            --

            Wil

            | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
            | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
            | More info at https://www.vimalin.com
            | Twitter @wilva
            | VMware Wiki at http://www.vi-toolkit.com
            1 person found this helpful
            • 3. Re: VMware Fusion 7.1.1 + Mac OS X Yosemite 10.10.2 w/ Win8 VM - Key Mappings Not Working
              RobXG Lurker

              Hi Wila,

               

              changing the keyboard to US fixed it, thanks!

               

              For some reason Windows decided to use English-UK for the keyboard. I don't live in either the US or UK, nor was my computer built in either of those places so I don't know why it chose that setting. I find the whole concept of determining preferences based on the language a user choses annoying, the keyboard layout has nothing to do with the language I chose. And why is the layout called "English (United States) - US"? Why not just call it "Apple MacBook Pro (standard)" or "Windows (standard)" or "Layout 42" or similar?

               

              Enough!!

               

              Thanks.

              • 4. Re: VMware Fusion 7.1.1 + Mac OS X Yosemite 10.10.2 w/ Win8 VM - Key Mappings Not Working
                wila Guru
                Community WarriorsvExpertUser Moderators

                Hi,

                 

                Agreed that Microsoft has hidden these settings well. I understand why they did it, but had to search for it myself.

                The only reason I was able to find it is because I knew it existed and had several different keyboard layouts enabled already (typing this on a keyboard with a layout for Thai script and US )

                In earlier versions of Windows -and IIRC also earlier incarnations of Windows 10- there was a separate setting for keyboard layouts.

                Oh well.. it is what it is.

                 

                --

                Wil

                | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                | More info at https://www.vimalin.com
                | Twitter @wilva
                | VMware Wiki at http://www.vi-toolkit.com