6 Replies Latest reply on Mar 11, 2015 6:02 AM by yaronbor

    Unidirectional set to true but server seems to try to connect to the agent and fails

    selkad Lurker

      I am using Hyperic server 5.7.1.

       

      In the agent.properties file, I have set:

      agent.setup.unidirectional=yes

       

      The platform comes up in the auto-discovery pane on the HQ dashboard. However in the server logs, I see this error message:

       

      19-02-2015 02:51:41,226 UTC ERROR [aiSendReport-3588669] [org.hyperic.lather.server.LatherServlet@320] error while invoking LatherDispatcher from ip=107.189.81.12, method=aiSendReport: org.hyperic.hq.common.SystemException: org.hyperic.hq.appdef.shared.AIQApprovalException: Error invoking remote method on agent Timeout occurred waiting on agent response.

      org.hyperic.hq.common.SystemException: org.hyperic.hq.appdef.shared.AIQApprovalException: Error invoking remote method on agent Timeout occurred waiting on agent response.

       

      Could someone explain why the server is trying to "invoke a method on the agent" under unidirectional mode ?

       

      When I click on Add to Inventory on the auto-discovery pane, I get this error message:

      Unable to import platform : org.hyperic.hq.appdef.shared.AIQApprovalException: Error invoking remote method on agent Timeout occurred waiting on agent response.

       

      As soon as I set unidirectional to no, my server can be added to the inventory without any issues.

       

      Thanks in advance for any hints!