10 Replies Latest reply on Feb 10, 2019 10:37 AM by JoakimLjungberg

    vmware 11 installation still a problem

    jara8462 Novice

      I originally posted a problem about uninstalling an older version in order to install version 11. Now version 11 of workstation fails to install. I now get the error "warning 1909 cannot create shortcut virtual network editor.lnk. Verify destination folder exists and that you can access it".

      Then another pops up "warning error 1909. Cannot create shortcut vmwork station.lnk Verify destination exists and that you can access it." And a third error "The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error is 2902" I have downloaded this package several times in case of corrupted previous downloads. The quoted folders did not exist as the installation failed and they were not created evidently, so the verification asked for cannot be done. I even created folders with the names given, but still the same errors occurred. Workstation 6.0.1 worked fine until I tried upgrading to version 11. Anyone have any ideas as to this problem?


        • 1. Re: vmware 11 installation still a problem
          J-Ho Novice

          What OS are you running?

          Do you have Administrative privileges to the system?

          Have you run the installer by right-clicking then selecting Run As Administrator?

          If you've checked all of those, try creating a new local user account with Admin privileges to see if it's related to your user.

          • 2. Re: vmware 11 installation still a problem
            jara8462 Novice


            I had to resolve a problem earlier concerning privileges to uninstall the older version of the program, as the newer version was saying the older version was still installed even though it wasn't. I am running win 8.1 with all updates, intel I7 quad 4820 3.7 ghz, 32 gigabytes DDR5 ram, 3 terabyte HDD.  I resolved all privileges that came up before as I stated. The present errors do not mention privileges, and does not give any hint why the directories "virtual network editor", or "VMware workstation", cannot be found and links to them made. As these are directories installed by the installer and are removed when the installation fails, there is no hint as to what causes it to fail that I can see. I have a administrative account  and added another account, does not matter as I get the same errors with both. I have tried installing by "run as administrator, and normally, with same errors. I have run "sfc /scannow" at least a half dozen times to check system files and have corrupted files repaired. If I only knew why it is erroring out I could resolve ithe problem, was hoping someone else had run into a similar problem and found a solution for it. I have also posted this on the Microsoft forum in hopes someone there might have run into the problem and found a solution for it too. I am going to go through the last log of the installer with a fine tooth comb, maybe I missed something, I appreciate any and all help given me, thank you for trying.


            • 3. Re: vmware 11 installation still a problem
              J-Ho Novice

              Have you used ProcMon before?  This could help you determine what is blocking the install.




              Run that while trying to install.  Then do a search for Access Denied.  That might help point you in the right direction.


              Not that I'm sure it would help, but have you disabled AntiVirus or Malware?

              • 4. Re: vmware 11 installation still a problem
                jara8462 Novice

                Thanks J-ho:

                I just downloaded it and ran it while attempting to install the vmware package. Cannot get the help file to open, as I need to learn how to use the program, and have to see if microsoft has it. The program does not highlight any failures of any kind and the help file is now a "must have" for me.It shows when the installation started and ended, with no explanation of any entry otherwise.


                • 5. Re: vmware 11 installation still a problem
                  J-Ho Novice

                  For the help file, open procmon.chm manually. 


                  Have you found a solution yet?  Do you have issues installing any other programs?

                  • 6. Re: vmware 11 installation still a problem
                    jara8462 Novice

                    Thanks again J-HO;

                    No, haven't found an answer yet, and haven't had any problems installing any other programs, do have an update for ITunes that won't install, haven't pursued that as yet. I searched processmon for access denied, found the entry, but could not find the reason access was denied only that creating a link failed.I did install hyper-v at a suggestion from Microsoft forum, but that doesn't do anything for my VMware problem, and would like to be able to use the program seeing how much I had to pay for it.


                    • 7. Re: vmware 11 installation still a problem
                      J-Ho Novice

                      I know this isn't a fix, but at this point, I would do a re-install of your workstation OS.

                      • 8. Re: vmware 11 installation still a problem
                        jara8462 Novice

                        Thanks J-Ho;

                        I was at that point many times. I finally got it to install, had to go to the VMware folder in start menu, use take ownership on it and on every folder as I backed out completely. Tried to install and thought it was useless as an error popped up for each failed link and then it seemed to freeze there. Thought I would have to use task manager to get out of it, but after about 2 minutes the installer completed the installation! Thanks for your help and all others that tried to do so. Why using take ownership on the folders before never worked, I'll never know, also Hyper-v is useless for what I need vm for.


                        • 9. Re: vmware 11 installation still a problem
                          KiranPoudel Lurker

                          I had the same issue. I too tried a different bunch of version of VMware which unfortunately were leading me to same error.

                          FIX THE PROBLEM

                          • Install Vmware in other hard disk partition except for the one you were failing to install (other then c:)
                          • Uncheck the create a desktop shortcut / create a start shortcut.

                          It pretty much worked in mine. Hope it works for you. Thank you

                          • 10. Re: vmware 11 installation still a problem
                            JoakimLjungberg Lurker

                            This will happen if you for example use folderredirection or onedrive sync your folders.

                            Just deselect the create shortcuts and it will install fine.