1 2 Previous Next 19 Replies Latest reply on Jun 2, 2017 7:50 AM by timboAUS Go to original post
      • 15. Re: FreeBSD 10 guest - CAM status: SCSI Status Error
        Cannoli Enthusiast

        We're seeing the same issue but I can say with certainty it is NOT a FreeBSD issue.  Working with Supermicro, LSI and VMware, we determined the LSI controller is "timing out" where all I/O comes to a complete stop on the controller.  While it was the FreeBSD VM console that alerted us to the issue during our initial build-out of the server cluster, the vmkernel log file confirmed the LSI 3108 controller that backs an 8 disk SSD RAID is timing out then resetting. We've been able to cause it to "time out" at will by powering up or resetting 5 VM's at the same time. Not only does the vmkernel log display the loss of communications to the controller, the LED activity on the drives is non-existent for ~30-40 seconds.

         

        We've tried new LSI controller firmware (even beta firmware from LSI), various VMware drivers for the controller, hardware BIOS settings for the system and the controller.  You name it, we've tried it all without success.

         

        I have an open ticket with Supermicro and VMware to solve this issue. I'll post more as I have information.

        • 16. Re: FreeBSD 10 guest - CAM status: SCSI Status Error
          LaminarCS Lurker

          I think I may have the solution.

           

          We just ran into this issue with a brand new Supermicro machine with an LS3108 based RAID and VMWare ESXi 6.0.

           

          The solution was to ditch the lsi_mr3 card and use the Avago / LSI scsi-megaraid-sas driver.  We were able to find the appropriate driver for our ESXI by going here: http://mycusthelp.info/LSI/_cs/AnswerDetail.aspx?inc=8447

           

          Be sure you download what they are labeling as the "legacy driver" and not the native driver, as that is the one with the problems.  Oracle has an excellent article with instructions on switching to the scsi-megaraid-sas driver and for turning off the lsi_mr3 driver, you can follow those, but reference the newer driver version / files you downloaded. Here are the Oracle instructions: Enable the megaraid_sas Driver - Oracle Server X5-2 HTML Documentation Collection

           

          With the new driver installed I was successfully able to run the StorCLI utility (the replacement for MegaCLI) to access the card.  I was able to view the current firmware and installed a newer firmware that I was able to find here: ftp://ftp.supermicro.com/driver/SAS/LSI/3108/Firmware/

           

          After installing the latest firmware, I did have to re-add the storage for some reason.  I also had problems with the web client and simply re-added the storage with the old Windows client.

           

          I believe the key to fixing the issue is switching to the scsi-megaraid-sas driver, although I did also upgrade the firmware before performing tests that would cause the errors previously ... so I can't confirm this 100%.

          • 17. Re: FreeBSD 10 guest - CAM status: SCSI Status Error
            SomeRandomDude Lurker

            I was experiencing the same issues; LaminarCS's instructions were almost enough but in my case I had to do one more thing.  My environment - Dell T630, Megaraid 8380E attached to 8 1TB Samsung SSD 850 Pro drives;  FreeNas 9.3 VM, and NAS4Free 10.2 VM providing iSCSI from a VMFS datastore provided by those drives I listed. 

             

            My additional problem was HEAT.  The Megaraid card was idling at 98 degrees Celsius.  I can only imagine what kind of temperatures it was reaching under load.  Even a 20% increase would put it over the suggested thermal limit.  The Dell recommended slot placement of the RAID card puts it at the top of the case where there is zero airflow.  I added a fan blowing directly onto the card, and temperatures were reduced by 46 degrees C.  This is a reduction from 208 to 125 F, which is enormous.  Once the fan was in place, the errors ceased.

             

            So, if you've tried all the suggestions in this thread and still are experiencing errors, check your airflow and temperatures.  In my case I had to:

             

            1.) Upgrade firmware of the Megaraid 8380E

            2.) Commit 16GB to my NAS Virtual Machine

            3.) Update the Megaraid driver to the newest version from VMWare

            4.) Add active cooling to keep the 8380E at a reasonable operating temperature

            • 18. Re: FreeBSD 10 guest - CAM status: SCSI Status Error
              mfitz50 Lurker

              I do not know if this will help anyone,

               

              But I did just run into a similar issue my hardware using X79 Chipset.

               

              In this case I resolved the issue using the sata-ahci driver in ESXi 6.5

               

              Hope this helps

              • 19. Re: FreeBSD 10 guest - CAM status: SCSI Status Error
                timboAUS Lurker

                I had this error.  It turned out to be the cache controller battery had failed on a HP DL380 G7

                 

                Lift the cover off your server and check the battery leds.  If you have a solid amber light, then a new battery will fix the problem

                1 2 Previous Next