8 Replies Latest reply on Aug 4, 2006 12:38 PM by krasicsobald

    Guest Customization in VI3 ends up with: unexpected customization error

    haywarn Novice

      Hi all,

        I have setup version 2.5 of ESX server as a demo to see if my company wanted to purchase the product.  When I labbed this out I had 0 issues and was able to use the VM Guest Customization wizard to create sysprep xml files to deploy templates.   Again I had 0 issues and set this up for Win2k, Win2k3 etc.

       

        We recently purchased Virtual Infrastructure 3.0.   I have setup 2 base templates, one is Windows 2003 Server the other is the same with SP1.  I have not joined the domain on these servers and both of them are set to DHCP.   I've ran through the Guest Customization wizard at least 20 times creating new customizations each time to try and troubleshoot why this feature will not work.   Every time I do a deploy virtual machine from template it errors out around 95% saying "unexpected customization error".   I haven’t done anything special in the customization wizard.

       

      Name and Company is filled out.

      I've tried every option for how to name the system, let the admin decide; make it the same name as the VM etc.

      I put in our CD key with and without the XXXX-XXXX-XXXX-XXXX or XXXXXXXXXXXXXXXXXX

      I've told it to do per seat licensing since we have MVLA

      Put in the local admin password

      Pacific Standard Time

      Nothing in the run once box

      Typical settings for Network settings (DHCP) since I've heard people have issues using the static IP address method when trying to also add the VM to the domain during the sysprep unpack process.

      I have tried both adding the system to the domain using a generic admin account that we made for adding systems to our domain.  I've also tried just saying workgroup incase that was the issue.

      I generate a new SID of course otherwise the VM would be a duplicate.

      And finally I finish.

      Again the VM gets to 95% deployed and then bombs out.

       

      I'm not new to Microsoft Sysprep.  I've been using it for years for desktop images using Drive Image, RDP by HP etc.   This isn't rocket surgery.   I can use my old sysprep files and just sysprep the VM and then clone it but I'd rather use the customization wizard.  I've tried cloning the VM using the exact same information in a sysprep.inf file and it works fine running sysprep manually within the VM.

       

      It seems like there is an issue with the customization wizard.   Is anyone else having this issue with the new Virtual Infrastructure 3.0 with ESX 3.0.  Or do you have any ideas what else I can try?

       

      Any help is appreciated!