3 Replies Latest reply on Dec 8, 2014 2:12 PM by pernika

    Problem after resizing vmdk ESXi 5.5

    pernika Novice

      Hi guys,

      i've made a mistake and now i'm in a little deep problem so any help will be appreciated. What is the problem: I have a standalone ESXi 5.5 ( 5.5.0 build 1331820) installed in the remote area (one server with one datastore). I wanted to give more GB to one of the VMs and by mistake wrote comma instead of point and the hard drive size growth till the maximum available free space on the datastore. It's not possible to downsize it from the GUI that's why i've tried and use this: http://www.vmwarearena.com/2013/03/shrink-virtual-machine-vmdk.html it worked 50/50 but now the GUI of the VM shows the proper size but the datastore is still occupied with the old size and basically I can't move it or create another one. This is the additional attached Hard Drive. I've also tried this: Hostile Coding: VMware: Shrink VMDKs by removing zeroed blocks but it didn't worked. I've tried also vmkfstools -e name.vmdk but it return: Disk chain is not consistent: The file specified is not a virtual disk (15). The Disk is Thick Provision Lazy Zeroed. I've checked some of the possible solutions but they include vCenter or Converter (I don't have enough space to create a new one) or vMotion which I don't have. I've also tried to remove/add to inventory but the vmdk stays the same (around 5 TB). I'll be very happy if there is a solution. Thanks in advance.