2 Replies Latest reply on Aug 16, 2019 12:44 PM by shanief

    High CPU usage after a few minutes of in-activity

    tarasis Lurker

      Hi

       

      A new owner of VMWare Fusion 7 here, I'm running Fusion version 7.0.1 on Yosemite 10.10.1 with Guest OS Windows 10 (Build 9879) on a Mid 2009 13" MacBook Pro.

       

      The performance compared to Virtual Box is massive and led to me taking advantage of the Black Friday offer, but I've noticed that after a few minutes of inactivity in the VM Window that the CPU usage climbs to 100% (vmware-vmx + kernel), but after I swap back to the VM and wait a short time the CPU usage drops off completely.

       

      There are no tasks running in Windows that I can see and no apps running  either. Whats happening?

       

      (Also Unity doesn't appear to work properly, there are odd empty boxes and the desktop half appears on top of my existing OS X desktop)

        • 1. Re: High CPU usage after a few minutes of in-activity
          arang Enthusiast

          This may not be your issue, but I see my Windows VM sometimes doing “background” tasks of some sort when it’s been idle for a while. These are visible when starting the Task Manager in Windows, and then choosing the Processes tab and clicking on “Show Processes from all users”. Some of these seem to be search-related, some are anti-virus (not Windows per se), some have unclear purposes (at least to me). So this may just be Windows deciding that your system is idle (after all, the virtual machine is) and taking advantage of the opportunity to run some operating system tasks when they won’t interfere with an active user. Windows seems to be very quick at pausing these tasks once it detects user activity again, which could explain why they stop once you switch back to the VM.

          • 2. Re: High CPU usage after a few minutes of in-activity
            shanief Lurker

            UPDATE: The issue returned! UGH!

             

            I decided to use Parallels Desktop 14 instead. No CPU issues AT ALL!

             

            ------------

             

            I was experiencing a similar issue with and without inactivity and landed here; The vmware-vmx process on mac was just going bonkers 250% CPU. I finally got tired of my MBP sounding like a Vacuum and looked into settings I could change.

             

            I'm assumed it was related to the unnecessary Windows 10 animations/graphics - one of the reasons I wish Microsoft had made the WIndows Classic theme available in WIndows 10.

             

            What seemed to fix the memory hogging issue for me was:

             

            1) Disabling Memory Compression  (Using Process Hacker as Admin, I noticed a "Memory Compression" process running on my Windows guest):

              PowerShell (as an admin) --->  Disable-MMAgent -mc ---> reboot

             

            2) Disabling the unnecessary graphics

            Control Panel ---> Set "View by Category" to "Small Icons" ---> System ---> Advanced System Settings --->  ("Advanced" Tab) ---> "Performance" settings --> ("Visual Effects" tab) --> Set to "Adjust to Best Performance", which should uncheck all the boxes --> Apply --> OK

             

             

             

            Now the vmware-vmx process on my mac stays around 50%!

             

            I noticed a slight change in the aesthetics after disabling the visual effects, but I can live with them.