1 2 Previous Next 22 Replies Latest reply on Dec 4, 2006 6:10 PM by jjamieson Go to original post
      • 15. Re: Access NTFS from ESX start
        bnelson Enthusiast

        If NTFS support is really that important, buy a license of ESXranger from Vizioncore. ESXranger will run on a VM on your beefy server and backup your VMs to an NTFS share on the network.

        • 16. Re: Access NTFS from ESX start
          jjamieson Enthusiast

          Just as an FYI, you CAN access NTFS (read-only) disks from the ESX3 service console, but it's not for the faint of heart

           

          It's useful for if you want to transfer large amounts of data to the ESX server on a USB drive, and you need to format the USB drive with NTFS.

           

          If you look at RColbert's post here:  http://www.vmware.com/community/message.jspa?messageID=464248#464248

           

          You'll see that he's talking about the kernel nfsd.  However, follow the same instructions, except:

           

          3) nano vmnix.config, search for CONFIG_NFSD_TCP and change the commented line to:  CONFIG_NFSD_TCP=y

           

          would read:

           

          3) nano vmnix.config, search for CONFIG_NTFS_FS and change the commented line to:  CONFIG_NTFS_FS=m

           

          and:

           

          10) If the build completed properly, you can copy the newly created nfsd.o module.

          cp ./fs/ntfs/ntfs.o into /lib/modules/2.4.21-37.0.2.ELvmnix/kernel/fs/ntfs/

           

          If the ntfs folder doesn't exist in the modules folder, create it first.

           

          I am not sure if you need to load the module manually, but if you do, use modprobe ntfs.

           

          To mount NTFS disks, use this command.  (Say your USB disk is set to /dev/sdc)

           

          mount -t ntfs /dev/sdc1 /your/mountpoint

           

          Works for me.

           

          Good luck.

          • 17. Re: Access NTFS from ESX start
            BlueDragon Enthusiast

            wep, work fine, thanks joseph.jamieson, i'm now able to :

             

            1/ plug an external usb storage device (500Go)

            2/ mount the NTFS partition from the usb storage on my service console and Read It

             

            Very nice for V2V conversion with images from GSX Windows Host

             

            Message was edited by:

                    BlueDragon

            • 18. Re: Access NTFS from ESX start
              Windzhou Novice

              Hi, Joseph

               

              I have followed the instruction, and successfully compiled the ntfs.o module (assume the compilation is successful, as it created the ntfs.o file in the location), and copied the file to /lib/modules/2.4.21-37.0.2.ELvmnix/kernel/fs/ntfs/

               

              However, when I run the modprobe ntfs, it shows the following error:

              modprobe: can't locate the module ntfs

               

              I also can't mount the ntfs as it shows fs type ntfs not support.  So before run the modprobe command,  do I need to modify any configuration file? or what else is missing here ?

               

              Thanks!

              • 19. Re: Access NTFS from ESX start
                Cokazn Novice

                I got the same error the previous person posted. I got a little further though by changing the permissions on the copied ntfs.o to 755 then rebooting the server. I performed a reboot because I could not get the modprobe ntfs command to work. Once the server rebooted I ran modprobe ntfs and receive a bunch or errors. I still cannot mount an NTFS device, the server reports NTFS is unsupported. Any help here would be greatly appreciated.

                • 20. Re: Access NTFS from ESX start
                  jasmit23 Novice

                  i've mapped an iSCSI LUN with NTFS partition on it using the VI Client.

                   

                  i can compile the module, insmod ntfs.o, without errors.

                   

                  when i try to maount the device i get this error:

                  mount: /dev/sdb1 is not a valid block device

                   

                  ????

                  • 21. Re: Access NTFS from ESX start
                    jjamieson Enthusiast

                    I do not believe that iSCSI LUN's mapped with the SW iSCSI Initiator in the VI client are visible to the Service Console.   They are loaded by VMKernel.

                     

                    There may be a way around this but I'm fairly sure that's the case.

                    • 22. Re: Access NTFS from ESX start
                      jjamieson Enthusiast

                      Windzhou, make sure you do a "depmod -a" from the command line to update the module database with the new module.  

                       

                      You could also try doing a direct module load if modprobe fails, to make sure you've got a good module:  use insmod.   You do this to the full path of the module including the .o extension, unlike modprobe where you just type the module name.   If it loads, it will appear in the list when you do an lsmod.

                       

                      Sorry for the delayed response, I didn't notice anyone replied!

                      1 2 Previous Next