1 Reply Latest reply on Jul 29, 2014 1:57 PM by Dayworker

    MY legacy logitech webcam in VM Odyssey

    bmowrey Lurker

      For all of whom this may assist-

      I've spent the last week pulling out the few remaining hairs in my melon getting this to work and im reasonably sure someone else is or has experienced it too, but there was no info anywhere about it.
      Here you go, YMMV. Please don't take this as gospel, but in some rare cases it may help. For those who want the spoiler, scroll down.

       

      ISSUE: Client has a POS system built using old tech that was never really rebuilt to account for new gear and systems, due to the fact that the original developer passed away suddenly. 

      I was the only guy who really knew the system and a few clients still run it. Alternately we could've spent 60k to upgrade unnecessarily, but all of us are cheap. After an initial test of virtualizing a POS within XP using server 2.0, it all worked incredibly, unbelievably smoothly from front to back. Now I'm fairly jaded, having spent years in this biz and something didn't feel right, in spite of the test going perfectly and the client went ahead and gladly committed several thousand to new workstations. Part of me must've known it was just too easy.

      We bought the gear and I started setting them up while virtualizing all of the workstations.

       

      Part of this system requires the client to take photos with a webcam at every transaction and the software used a few additional 3rd party packages to get the pic from the webcam to the database and back.

      Logitech pro 5000 (also the newer models failed even harder). The host ran it fine but not the xp client. Hours lapsed into days and now over a week later I have solved this particular issue and also understand why ( to a limited degree).

       

      Symptomology:

      - Host could always attach to webcam

      - webcam would attach to client and initiate install of latest drivers in client box~12.x.x.x

      - camera portion would be visible in device manager, but never completely install. Bang icon despite enumerating and naming the device correctly

      - often either the client or host would BSOD with a BAD _POOL error when accessing the cam or anything to init the bus.

      - Microphone would attach correctly and be accessible through the client. but for our purposes that didn't solve the issue

       

      Failed Solutions:

      - upgrade Logitech drivers

      - downgrade Logitech drivers

      - disable Bluetooth radio

      - disable USB 3,0 in BIOS

      - disable other cards

      - disable front USB in BIOS

      - add USB 1.1 daughtercard to box

      - Convert VMs to virtual box

      - Convert VMS to Virtual PC

      - attempt different webcam brand install with even less joy than previously experienced.

      - try workstation rev 10, 9, 8, 7,

      - Sacrifice of a fatted calf to the ghost of Merv Griffin.

       

       

      Solution:

      While the host system could use lvm100.exe, a driver set circa 2010 ( hastily and grudgingly made available for WIndows7 by the "just buy a new one" Sales Whore Department over at Logitech) , the client systems would only work if one retrograded the Logitech driver to version 8.4.8, a 2004 vintage driver. It now seems to work consistently with the occasional need to replug the webcam back into the host, whereupon the client would then see it again and assign it properly.  And its repeatable, so I feel marginally better

      Why all of this made the difference, I cant say exactly, but it did.

      I sincerely hope this helps somebody ( all 5 of you) but this fulfills my good deed obligation for at least a week. Plus its all written down so I can look at it again when it gets wiped from my short-term memory.

       

       

      Bart

        • 1. Re: MY legacy logitech webcam in VM Odyssey
          Dayworker Enthusiast

          VMserver2 knows only USB2.0. If your host has only USB3.x ports, then use an USB hub in between. The hub will act like a broker and will handle different USB speeds much better than VMware. Some USB devices work best in a Windows based host, if they are completely unconfigured (no driver installation in host os) or if you deactivate the device in the "device manager". In both cases the guest should get a better connection, without annoying driver incompatibilities between the VMware USB driver and the device driver itself. In most cases are USB devices not properly (cleanly) logged out of the host-os. In this case you will get no connection to a device and/or a message from the host os and telling you that a device was not properly logged out. After this message a device may work or not. I believe the real problem behind this is that most of the device vendors do not want to think about the product virtualization. There are to many virtualization products, to many OSes, to many devices and each device test would be more expensive. This is a NoGo in a profit orientated society...

           

           

           

           

           

           

          Logitech cams are known to me as good products with a sometimes lousy driver quality (new or extended functions result in annoying BSODs) and quantity (limited OS and/or driver support).

          -----
          Please do not forget to assign reward points, if you find an answer useful.