9 Replies Latest reply on Oct 17, 2014 5:10 AM by Tomad

    Scaled Retina resolution makes VM slow to a crawl

    JBarros Novice

      When I have "Accelerate 3D Graphics" active and "Use full resolution for Retina Display" my VM slows down to a crawl

      I have 3+ second delays sometimes! (pressing Windows Key, switching application etc)

      I set "Always use High Performance Graphics Adapter" and now with 512MB ram. I tested with less and more, always with the same results: real slow.

      Setting OSX screen resolution to native Retina resolution makes the VM faster but still jerky.

      Disabling "Use full resolution for Retina Display" makes the VM fast but very painful on the eyes.

       

      This issue comes from the latest stable Fusion release, this Tech Preview is a bit faster but still way too slow.

       

      I really hope this can be fixed!

       

      Hardware: MBP 15" Late 2013 Scaled Retina resolution (3360 x 2100)

      Host OS: OSX 10.9.4

      VMWare Fusion Tech Preview 2014 July build

      VM OS: Windows 8.1 SP1 x64

        • 1. Re: Scaled Retina resolution makes VM slow to a crawl
          ConnorFee Lurker

          I can confirm all of your points JBarros! I've tried everything you said and am seeing the exact same issues. I am however on a 13" MacBook pro and was concerned it was the underpowered video card. I'm pleased to know that is not the issue, but concerned that no one else seems to be freaking out!

           

          The issues are most noticeable to me when using MS Office 2013 applications (and yes I've already disabled 3D hardware acceleration in these products). When I type in powerpoint for example, it can lag by 0.5 to 1.5 seconds to get my text on screen. All I'm doing is changing the header text on a slide!

           

          Did you have any luck in your search?

           

           

          Hardware: MacBook Pro (Retina, 13-inch, Late 2013), 2.8 GHz Intel Core i7, Intel Iris 1536 MB

          Host OS: OSX 10.10

          VMWare Fusion Tech Preview 2014 July build

          VM OS: Windows 7 Ultimate N x32

          • 2. Re: Scaled Retina resolution makes VM slow to a crawl
            jonlehman Lurker

            I'm having the same exact problem.  I copied a windows 7 64 ultimate image that had office 2010 on it, uninstalled office, and then installed office 2013 (office 365).  The entire machine slows to a crawl, even without any office apps running.  Sometimes, it runs ok, but most of the time it will take at least several seconds to perform any action.  I disabled retina support, and that sped things up dramatically, but it is still slow compared with the exact same image with 2010 installed. 

             

            I read that Office 2013 requires DirectX 10.  Fusion 7 only supports DirectX 9.  What gives?

             

            My computer: Mid 2012 MBP 15" Retina. 8GB RAM 256GB SSD

            VM configured with 4 GB RAM, 4 cores, 60 GB HD, with about 25 GB free, Windows 64 Ultimate. 

            • 3. Re: Scaled Retina resolution makes VM slow to a crawl
              jonlehman Lurker

              Figured it out.  I tried the Disable hardware acceleration and Dont Use subpixel rendering options.  My system would work fine for a few minutes, and then slow to a crawl. 

               

              Disabling App Nap for Fusion in Finder fixed the problem, instantly. 

                   Go to Finder -->Applications

                   Right click on Fusion, go to Get Info

                   Disable App Nap

                   Enter blissful state of nirvana.  (At least that's what happened for me)

              • 4. Re: Scaled Retina resolution makes VM slow to a crawl
                JBarros Novice

                I was using Tech Preview and as soon the final version was released I tested it with similar bad results.

                 

                Following your tip: I don't have the "Prevent App Nap" option on my VMWare so I disabled it via CLI with:

                defaults write /Applications/VMware\ Fusion.app NSAppSleepDisabled -bool YES

                 

                Same results

                 

                I imported the VM to a competing product released recently to have a comparison and the results are what is to be expected: fast and fluid experience.

                I'm afraid if VMWare doesn't fix this issue very soon I'll have to move on to the competition after years of using Fusion, all the way from version 1

                • 5. Re: Scaled Retina resolution makes VM slow to a crawl
                  jonlehman Lurker

                  I should update you on my results.  This app nap 'fix' worked for a couple hours of solid use.  Then, I left my computer alone for a few minutes.  When I came back to it, I started experiencing the same problem.  I don't have time to troubleshoot this.  I've already wasted half a day on it.  Downloading Parallels and converting got me back up and running.  Sad, but that was my solution. 

                  • 6. Re: Scaled Retina resolution makes VM slow to a crawl
                    DrDavidF Lurker

                    Same issue here. Having shelled out an extortionate sum for the "upgrade", I now find myself loathing VMfusion7 and its ridiculous speed under Windows 8.1. How this could have passed serious testing is beyond me. Looks more like a rushed response to Parallels 10 than a properly tested product. This needs to be fixed INSTANTLY or VMware will be hemorrhaging customers elsewhere - me included. There is a noticeable response delay.

                    • 7. Re: Scaled Retina resolution makes VM slow to a crawl
                      JBarros Novice

                      I can say it wasn't a rushed response to Parallels.

                      Typically Tech Previews start in June or July and final releases come out in August or September and that happened again this year.

                      That I thought someone would be eyeballing this forums in search of this exact type of issues before a final release? You bet ya!

                      I had 2 support cases opened in the past and in both I had engineers calling me from another country (mind you I'm not in the US).

                      I was expecting free problem reports here would be noticed and hopefully fixed, sadly that was not the case.

                       

                      I'm currently using the trial license of Parallels and with nothing pointing to a solution to this problem, most probably my money is going their way.

                       

                      PS: are you guys using native Retina resolution or scaled like me?

                      • 8. Re: Scaled Retina resolution makes VM slow to a crawl
                        jonlehman Lurker

                        I was using the option to view the screen in Retina, but scale it (I believe that sets the font size to a certain percentage of standard)

                         

                        Parallels is working great :-)

                        • 9. Re: Scaled Retina resolution makes VM slow to a crawl
                          Tomad Lurker

                          I have the exact same issue. Is there any response from vmware?