1 2 3 4 5 Previous Next 97 Replies Latest reply on Nov 21, 2017 11:58 PM by ranxueruo Go to original post
      • 30. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
        daviersv Lurker

        Hi,

         

        i tried again,

        but now step by step upgrade, from e1000 driver version 1 upgrade to version 2, then to version 3.

        it works.... thanks ...

        • 31. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
          RonOlshavsky Novice

          Anyone know what the solution is to the "Cannot apply VIB net-e1000e, it contains a payload file of unknown type ''."  issue?

           

          Running on Windows 7, using the ESXi-Customizer and the e1000e-3.1.0.2-glr.vib file...

           

          After the decompression of the ISO, this is the log results:

           

          [Sat 09/13/2014 13:57:33.87] Setting up the host profile ...

          [Sat 09/13/2014 13:57:33.88] The original host profile XML file is "ESXi-5.5.0-20140902001-standard-1902802134" ...

          [Sat 09/13/2014 13:57:33.89] Renaming it to "ESXi-Customizer".

          [Sat 09/13/2014 13:57:33.90] Updating the host profile XML file ...

          [Sat 09/13/2014 13:57:33.91] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\unxutils\sed.exe" -e "s#<name>.*</name>#<name>ESXi-Customizer</name>#I" -i "ESXi-Customizer"

          [Sat 09/13/2014 13:57:33.93] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\unxutils\sed.exe" -e "s#<creator>.*</creator>#<creator>VMware, Inc. / ESXi-Customizer.v-front.de</creator>#I" -i "ESXi-Customizer"

          [Sat 09/13/2014 13:57:33.96] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\unxutils\sed.exe" -e "s#<modifiedtime>.*</modifiedtime>#<modifiedtime>2014-09-13T17:57:33.000000+00:00</modifiedtime>#I" -i "ESXi-Customizer"

          [Sat 09/13/2014 13:57:33.98] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\unxutils\sed.exe" -e "s#<description>.*</description>#<description>This is a VMware ESXi 5.x build customized by ESXi-Customizer 2.7.2</description>#I" -i "ESXi-Customizer"

          [Sat 09/13/2014 13:57:34.00] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\unxutils\sed.exe" -e "s#<acceptancelevel>.*</acceptancelevel>#<acceptancelevel>community</acceptancelevel>#I" -i "ESXi-Customizer"

          [Sat 09/13/2014 13:57:34.02] Checking vib file "e1000e-3.1.0.2-glr.vib" ...

          [Sat 09/13/2014 13:57:34.02] Unpacking VIB-file ...

          [Sat 09/13/2014 13:57:34.03] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\7zip\7z.exe" x -y -o"C:\Users\RonO\Documents\esxicust.tmp\vib" "D:\Ftran\Vmware\5.5_Offline_Bundle\e1000e-3.1.0.2-glr.vib"

           

          7-Zip 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18

           

          Processing archive: D:\Ftran\Vmware\5.5_Offline_Bundle\e1000e-3.1.0.2-glr.vib

           

          Extracting  descriptor.xml

          Extracting  sig.pkcs7

          Extracting  e1000e

           

          Everything is Ok

           

          Files: 3

          Size:       114255

          Compressed: 114444

          [Sat 09/13/2014 13:57:34.05] Parsing "C:\Users\RonO\Documents\esxicust.tmp\vib\descriptor.xml" ...

          set vibType=bootbank

           

          set vibName=net-e1000e

           

          set vibVersion=3.1.0.2-glr

           

          set vibVendor=GLRoman

           

          set vibPayloadName=e1000e

           

          [Sat 09/13/2014 13:57:34.23] Counting payloads in "C:\Users\RonO\Documents\esxicust.tmp\vib\descriptor.xml" of "e1000e-3.1.0.2-glr.vib" ...

          [Sat 09/13/2014 13:57:34.25] Exactly 1 payload found in "C:\Users\RonO\Documents\esxicust.tmp\vib\descriptor.xml". Good ...

          [Sat 09/13/2014 13:57:34.25] Run: "D:\Ftran\Vmware\5.5\ESXi-Customizer-v2.7.2\tools\MsgBox.exe" 266288 "Cannot apply VIB net-e1000e, it contains a payload file of unknown type ''."

          [Sat 09/13/2014 13:57:40.48] Cleaning up ...

          [Sat 09/13/2014 13:57:40.48] Run: rmdir /s /q "C:\Users\RonO\Documents\esxicust.tmp"

          [Sat 09/13/2014 13:57:40.69] This is the end.

           

          Anyone know what the solution is to the "Cannot apply VIB net-e1000e, it contains a payload file of unknown type ''."  issue?

           

          Thanks

          RonO

          • 32. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
            RonOlshavsky Novice

            GLRoman wrote:

             

            I have found some bugs with Customizer 2.7.2, and it is no longer supported.  Can you try the process that worked for Umbriel instead?

             

            https://communities.vmware.com/message/2411386#2411386

             

            I tried using the ESXi-Customizer-PS-v2.2.ps1 method, but something must be screwed somewhere on my setup, as whenever I try to do anythign with that script, even just run it to build a vanilla ISO, I get this:

             

            PS D:\ftran\vmware\5.5> ./ESXi-Customizer-PS-v2.2.ps1

             

            Script to build a customized ESXi installation ISO or Offline bundle

            using the VMware PowerCLI ImageBuilder snapin

            (Call with -help for instructions)

             

            Running with PowerShell version 3.0 and VMware vSphere PowerCLI 5.8 Release 1 build 2057893

             

            Connecting the VMware ESXi base depot ... [OK]

            Get-EsxImageProfile : The parameter 'name' cannot be an empty string.

            Parameter name: name

            At D:\ftran\vmware\5.5\ESXi-Customizer-PS-v2.2.ps1:252 char:13

            +             Get-EsxImageProfile -SoftwareDepot $baseDepot | foreach { $iplist += ...

            +             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                + CategoryInfo          : NotSpecified: (:) [Get-EsxImageProfile], ArgumentException

                + FullyQualifiedErrorId : System.ArgumentException,VMware.ImageBuilder.Commands.GetProfiles

             

             

             

            FATAL ERROR: No valid ImageProfile(s) found in input Offline bundle!

             

            And when I try to -load the vib file this is what I get:

             

             

            PS D:\ftran\vmware\5.5> ./ESXi-Customizer-PS-v2.2.ps1 -load D:\Ftran\Vmware\E1000e\e1000e-3.1.0.2-glr.vib

             

             

            Script to build a customized ESXi installation ISO or Offline bundle

            using the VMware PowerCLI ImageBuilder snapin

            (Call with -help for instructions)

             

            Running with PowerShell version 3.0 and VMware vSphere PowerCLI 5.8 Release 1 build 2057893

             

            Connecting the VMware ESXi base depot ...Add-EsxSoftwareDepot : Cannot convert length string (inRamdis) to a number

            At D:\ftran\vmware\5.5\ESXi-Customizer-PS-v2.2.ps1:199 char:22

            +     if ($baseDepot = Add-EsxSoftwareDepot $vmwDepotURL) {

            +                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                + CategoryInfo          : NotSpecified: (:) [Add-EsxSoftwareDepot], ProtocolViolationException

                + FullyQualifiedErrorId : System.Net.ProtocolViolationException,VMware.ImageBuilder.Commands.AddDepot

             

            Get-EsxImageProfile : Cannot validate argument on parameter 'SoftwareDepot'. The argument is null or empty. Supply an

            argument that is not null or empty and then try the command again.

            At D:\ftran\vmware\5.5\ESXi-Customizer-PS-v2.2.ps1:252 char:48

            +             Get-EsxImageProfile -SoftwareDepot $baseDepot | foreach { $iplist += ...

            +                                                ~~~~~~~~~~

                + CategoryInfo          : InvalidData: (:) [Get-EsxImageProfile], ParameterBindingValidationException

                + FullyQualifiedErrorId : ParameterArgumentValidationError,VMware.ImageBuilder.Commands.GetProfiles

             

             

             

            FATAL ERROR: No valid ImageProfile(s) found in input Offline bundle!

             

             

            Seems every time I try using that I get that same last message... FATAL ERROR: No valid ImageProfile(s) found in input Offline bundle!

            • 33. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
              GLRoman Novice

              @RonOlshavsky: When creating a custom ISO, you should use the offline bundle.  The VIB is used to patch an already installed host.

               

               

              Download the offline bundle and use the -obDir switch with ESXi-Customizer-PS.

              • 34. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                RonOlshavsky Novice

                GLRoman wrote:

                 

                @RonOlshavsky: When creating a custom ISO, you should use the offline bundle.  The VIB is used to patch an already installed host.

                 

                 

                Download the offline bundle and use the -obDir switch with ESXi-Customizer-PS.

                 

                Thanks for the reply...

                 

                When I try that, using the Powershell script, I get the message I posted about previously...

                 

                Example, when using the -obDir option, with the net-e1000e-3.1.0.2-glr-offline_bundle.zip file in the specified directory, I get this:

                 

                 

                PS D:\ftran\vmware\5.5> ./ESXi-Customizer-PS-v2.2.ps1 -obDir D:\Ftran\Vmware\E1000e

                 

                Script to build a customized ESXi installation ISO or Offline bundle

                using the VMware PowerCLI ImageBuilder snapin

                (Call with -help for instructions)

                 

                Running with PowerShell version 3.0 and VMware vSphere PowerCLI 5.8 Release 1 build 2057893

                 

                Connecting the VMware ESXi base depot ...Add-EsxSoftwareDepot : Cannot convert length string (.0</name) to a number

                At D:\ftran\vmware\5.5\ESXi-Customizer-PS-v2.2.ps1:199 char:22

                +     if ($baseDepot = Add-EsxSoftwareDepot $vmwDepotURL) {

                +                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                    + CategoryInfo          : NotSpecified: (:) [Add-EsxSoftwareDepot], ProtocolViolationException

                    + FullyQualifiedErrorId : System.Net.ProtocolViolationException,VMware.ImageBuilder.Commands.AddDepot

                 

                Get-EsxImageProfile : Cannot validate argument on parameter 'SoftwareDepot'. The argument is null or empty. Supply an

                argument that is not null or empty and then try the command again.

                At D:\ftran\vmware\5.5\ESXi-Customizer-PS-v2.2.ps1:252 char:48

                +             Get-EsxImageProfile -SoftwareDepot $baseDepot | foreach { $iplist += ...

                +                                                ~~~~~~~~~~

                    + CategoryInfo          : InvalidData: (:) [Get-EsxImageProfile], ParameterBindingValidationException

                    + FullyQualifiedErrorId : ParameterArgumentValidationError,VMware.ImageBuilder.Commands.GetProfiles

                 

                 

                FATAL ERROR: No valid ImageProfile(s) found in input Offline bundle!

                • 35. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                  GLRoman Novice

                  Looks like you can't even download the ESXi offline bundle.  Try this all by itself:

                   

                   

                  d:\> ESXi-Customizer-PS-v2.2.ps1 -ozip -ipname "My Lab" -ipdesc "My Test Env" -ipvendor "Me, Inc."

                   

                   

                  and see what happens.

                  • 36. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                    RonOlshavsky Novice

                    Here's the result:

                     

                    PS D:\ftran\vmware\5.5> ./ESXi-Customizer-PS-v2.2.ps1 -ozip -ipname "My Lab" -ipdesc "My Test Env" -ipvendor "Me, Inc."

                     

                     

                    Script to build a customized ESXi installation ISO or Offline bundle

                    using the VMware PowerCLI ImageBuilder snapin

                    (Call with -help for instructions)

                     

                    Running with PowerShell version 3.0 and VMware vSphere PowerCLI 5.8 Release 1 build 2057893

                     

                    Connecting the VMware ESXi base depot ... [OK]

                    Get-EsxImageProfile : The parameter 'name' cannot be an empty string.

                    Parameter name: name

                    At D:\ftran\vmware\5.5\ESXi-Customizer-PS-v2.2.ps1:252 char:13

                    +             Get-EsxImageProfile -SoftwareDepot $baseDepot | foreach { $iplist += ...

                    +             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                        + CategoryInfo          : NotSpecified: (:) [Get-EsxImageProfile], ArgumentException

                        + FullyQualifiedErrorId : System.ArgumentException,VMware.ImageBuilder.Commands.GetProfiles

                     

                     

                    FATAL ERROR: No valid ImageProfile(s) found in input Offline bundle!

                     

                    PS D:\ftran\vmware\5.5>

                    • 38. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                      RonOlshavsky Novice

                      Thanks again for the reply, and the help...

                       

                      Looks like I'm SoL at the moment, so Im gonna have to go get a 'supported' Nic card I guess...

                       

                      Anyway, thanks again for the assistance...

                      • 39. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                        liljestig Novice

                        Hi GLRoman,

                        I managed to follow kickstarter's guide on how to create a build environment, and debug the compilation:

                        vm-help.com - View topic - ESXI 5.x Drivers Part 1: Making a Build Environment

                        vm-help.com - View topic - ESXI 5.x Drivers Part 2: Preparing to compile

                        vm-help.com - View topic - ESXI 5.x Drivers Part 3: Compiling

                        vm-help.com - View topic - ESXI 5.x Drivers Part 4: Finishing the compilation

                         

                        I have got to the point of successfully compiling 80003es2lan.c, 82571.c, ethtool.c, ich8lan.c, kcompat_ethtool.c, mac.c, manage.c, nvm.c, param.c, phy.c and vmklinux_module.c, however I'm still struggling with kcompat.c, netdev.c and ptp.c, giving me the following errors:

                         

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c: In function '__kc_adapter_clean':

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c:975: error: 'struct net_device' has no member named 'quota'

                        cc1: warnings being treated as errors

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c:975: warning: type defaults to 'int' in declaration of '_y'

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c:975: error: 'struct net_device' has no member named 'quota'

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c:986: error: 'struct net_device' has no member named 'quota'

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c: In function '_kc_simple_open':

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c:1246: error: 'struct inode' has no member named 'u'

                        vmkdrivers/src_9/drivers/net/e1000e/kcompat.c:1247: error: 'struct inode' has no member named 'u'

                        cc1: warnings being treated as errors

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_alloc_rx_buffers_ps':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:802: warning: implicit declaration of function 'alloc_pages_node'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:803: warning: assignment makes pointer from integer without a cast

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_alloc_jumbo_rx_buffers':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:915: warning: assignment makes pointer from integer without a cast

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_intr_msi':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:1950: error: too few arguments to function 'netif_rx_schedule_prep'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:1955: error: too few arguments to function '__netif_rx_schedule'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_intr':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:2052: error: too few arguments to function 'netif_rx_schedule_prep'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:2057: error: too few arguments to function '__netif_rx_schedule'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_intr_msix_rx':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:2147: error: too few arguments to function 'netif_rx_schedule_prep'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:2150: error: too few arguments to function '__netif_rx_schedule'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000e_poll':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:2919: error: too few arguments to function 'netif_rx_complete'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_open':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:4917: warning: implicit declaration of function 'netif_poll_enable'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_close':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:4983: warning: implicit declaration of function 'netif_poll_disable'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_tso':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:5791: warning: implicit declaration of function 'skb_cow_head'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c: In function 'e1000_probe':

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:7672: error: 'struct net_device' has no member named 'poll'

                        vmkdrivers/src_9/drivers/net/e1000e/netdev.c:7672: error: 'struct net_device' has no member named 'weight'

                        cc1: warnings being treated as errors

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:38: warning: 'struct ptp_clock_info' declared inside parameter list

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:38: warning: its scope is only this definition or declaration, which is probably not what you want

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: In function 'e1000e_phc_adjfreq':

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:40: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:40: warning: type defaults to 'int' in declaration of '__mptr'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:40: warning: initialization from incompatible pointer type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:40: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:49: error: dereferencing pointer to incomplete type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:58: warning: implicit declaration of function 'e1000e_get_base_timinca'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:62: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:68: warning: implicit declaration of function 'div_u64'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:77: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: At top level:

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:89: warning: 'struct ptp_clock_info' declared inside parameter list

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: In function 'e1000e_phc_adjtime':

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:91: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:91: warning: type defaults to 'int' in declaration of '__mptr'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:91: warning: initialization from incompatible pointer type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:91: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:96: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:97: warning: implicit declaration of function 'timecounter_read'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:97: error: 'struct e1000_adapter' has no member named 'tc'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:99: warning: implicit declaration of function 'timecounter_init'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:99: error: 'struct e1000_adapter' has no member named 'tc'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:99: error: 'struct e1000_adapter' has no member named 'cc'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:100: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: At top level:

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:113: warning: 'struct ptp_clock_info' declared inside parameter list

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: In function 'e1000e_phc_gettime':

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:115: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:115: warning: type defaults to 'int' in declaration of '__mptr'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:115: warning: initialization from incompatible pointer type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:115: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:121: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:122: error: 'struct e1000_adapter' has no member named 'tc'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:123: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:125: warning: implicit declaration of function 'div_u64_rem'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: At top level:

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:140: warning: 'struct ptp_clock_info' declared inside parameter list

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: In function 'e1000e_phc_settime':

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:142: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:142: warning: type defaults to 'int' in declaration of '__mptr'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:142: warning: initialization from incompatible pointer type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:142: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:150: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:151: error: 'struct e1000_adapter' has no member named 'tc'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:151: error: 'struct e1000_adapter' has no member named 'cc'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:152: error: 'struct e1000_adapter' has no member named 'systim_lock'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: At top level:

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:168: warning: 'struct ptp_clock_request' declared inside parameter list

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:168: warning: 'struct ptp_clock_info' declared inside parameter list

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: In function 'e1000e_systim_overflow_work':

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:175: error: 'struct e1000_adapter' has no member named 'systim_overflow_work'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:175: warning: type defaults to 'int' in declaration of '__mptr'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:175: warning: initialization from incompatible pointer type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:175: error: 'struct e1000_adapter' has no member named 'systim_overflow_work'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:180: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:180: error: 'struct e1000_adapter' has no member named 'ptp_clock_info'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:184: error: 'struct e1000_adapter' has no member named 'systim_overflow_work'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:185: error: 'E1000_SYSTIM_OVERFLOW_PERIOD' undeclared (first use in this function)

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:185: error: (Each undeclared identifier is reported only once

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:185: error: for each function it appears in.)

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c: At top level:

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:188: error: variable 'e1000e_ptp_clock_info' has initializer but incomplete type

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:189: error: unknown field 'owner' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:189: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:189: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:190: error: unknown field 'n_alarm' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:190: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:190: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:191: error: unknown field 'n_ext_ts' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:191: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:191: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:192: error: unknown field 'n_per_out' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:192: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:192: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:193: error: unknown field 'pps' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:193: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:193: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:194: error: unknown field 'adjfreq' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:194: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:194: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:195: error: unknown field 'adjtime' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:195: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:195: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:196: error: unknown field 'gettime' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:196: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:196: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:197: error: unknown field 'settime' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:197: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:197: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:198: error: unknown field 'enable' specified in initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:198: warning: excess elements in struct initializer

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:198: warning: (near initialization for 'e1000e_ptp_clock_info')

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:209: error: expected identifier or '(' before 'do'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:209: error: expected identifier or '(' before 'while'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:263: error: expected identifier or '(' before 'do'

                        vmkdrivers/src_9/drivers/net/e1000e/ptp.c:263: error: expected identifier or '(' before 'while'

                         

                        Any tips how you did it in your build environment?

                         

                        Thanks!

                        • 40. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                          Phlogi Lurker

                          FYI: The install command was processed only after adding the following options to the command:

                           

                          esxcli software vib install --no-sig-check -f -v  /tmp/e1000e-3.1.0.2-glr.vib

                           

                          I know it's dirty, but maybe this is helpful.

                           

                          Thanks GLRoman

                          • 41. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                            RKberg Lurker

                            I just had to come say Thank You! I had been searching for what felt like an eternity for fix to get my system up and going and this did the trick.

                            • 42. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                              soarangel Lurker

                              Thx, I get it!

                              I added through PowerCLI drivers for Intel I218-V into ESXi 5.5.0 update02 distrib. After that raid-driver for Asus Z97-PRO through ESXi-Customizer.

                              I can give the ISO image if you need.

                              • 43. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                                Hamednetw Lurker

                                Hi.many thanks.finally with your guid i succeeded install vmware and customized ISO.thx.thx

                                • 44. Re: ESXi 5.5 ASUS H97M Plus, Intel I218-V "No Network Adapters" Error
                                  Sasha Odarchuk Enthusiast

                                  soarangel wrote:

                                   

                                  Thx, I get it!

                                  I added through PowerCLI drivers for Intel I218-V into ESXi 5.5.0 update02 distrib. After that raid-driver for Asus Z97-PRO through ESXi-Customizer.

                                  I can give the ISO image if you need.

                                  soarangel

                                  share pls your ESXi 5.5up2 ISO with drivers for Intel I218-V

                                  1 2 3 4 5 Previous Next