0 Replies Latest reply on Jul 1, 2014 12:46 PM by JonesCameronM

    vCenter Plug-in not registering correctly

    JonesCameronM Novice

      Hello all,

       

      I have developed a plugin and it seems to work correctly in Eclipse.  I also did the test where you create the plugin folder and put it into the local "Plugins" folder and remove the projects in your virgo server.  That also ran my plugin correctly.  I then got to registering the plugin on vCenter.

       

      I found a script from another post on here, however it did not work for me.  I then tried to add my plugin manually using the MOB.  It would register just fine in the MOB but then when I went to the vCenter Web Server I wouldn't see my UI.  If I included this line <shownInSolutionManager>true</shownInSolutionManager> in my MOB registration XML it would show up in the Solution Manager.  It would show up with a status of "Unknown".  However the actual configuration UI I created would not show up (nor would the UI I had created to show up on the VM page).

       

      I have also manually downloaded the ZIP to ensure it works fine.  After downloading it, I unzipped it to ensure the ZIP structure was correct.

       

      I then checked the vsphere_client_virgo logs and I did find the following line:

      [2014-07-01 07:55:40.677] [WARN ] data-service-pool-12931      70003676 100056 200014 com.vmware.vise.vim.data.adapters.search.impl.QueryExecutor       object with no server guid: urn:vri:VcExtension:53574BAC-881F-4455-A236-2E7AA3BFC6C8/MY.PLGN.KEY

       

      That error seems to repeat every time I tried to register my plugin.

      If I can provide any further information please let me know.  This problem has been plaguing me for a while now.

       

      Thanks,

       

      Cameron