6 Replies Latest reply on Jul 2, 2014 4:47 PM by dlhotka

    2014 Preview still has USB 3 hub issue

    dlhotka Virtuoso

      There's a longstanding issue with USB3 devices plugged into a hub - if a Windows 7 guest is running when the device/hub is plugged in, the devices are not available to the host (no matter what you choose in the dialog).  Even when Fusion is shut down the devices remain inaccessible until you either reboot the host or plug them into a different USB port on the host.

       

      Of all the issues with Fusion, this is my big pain point - I swap drives via hubs (or turn them on and off all the time).  A big request to have it fixed in the next version.

        • 1. Re: 2014 Preview still has USB 3 hub issue
          Tonyw23 Expert
          VMware Employees

          Could you collect the support bundle while reproduce the issue by click Help -> Correct Support Information. And attach it to the thread?

           

          BTW, Is it work with Fusion 6.0.3?

          • 2. Re: 2014 Preview still has USB 3 hub issue
            ErocMillsie Enthusiast

            Really...really?!?!  I've been complaining about this for months.  Come on VMware.  Workstation 10 supports USB 3.0 with Windows 7.  WTF?!?!?

            • 3. Re: 2014 Preview still has USB 3 hub issue
              dlhotka Virtuoso

              Completely different issue.  Fusion locks up USB 3.0 devices on the host if they are plugged into a hub while a guest is running.

              • 4. Re: 2014 Preview still has USB 3 hub issue
                mudaltsov Expert

                I've looked into our internal bug report about the USB 3.0 hub issue, and it seems that the problem is a combination of Fusion initially claiming USB devices (to allow choosing whether to connect to a VM or to the host), and a problem with Apple's USB 3.0 driver not issuing a proper reset command to devices connected via a hub.

                 

                There is a possible workaround if you would like to try it:

                 

                1. Suspend or shut down any running VMs and quit Fusion.

                2. Ensure that the vmware-usbarbitrator process is no longer running.

                3. Create/edit the host-global configuration file, with root privileges: (this example uses nano, but feel free to use any other editor)

                sudo nano /Library/Preferences/VMware\ Fusion/config

                4. Add the following line to disable the automatic claiming of USB devices:

                usbarb.autoconnect.claimAll = "FALSE"

                5. Save the file and quit the editor.

                 

                With this change, all USB devices should automatically connect to the host even when VMs are running. Note that it will completely disable the USB connection prompt, and will prevent devices from automatically connecting to VMs (even if the option is selected in settings). However it should still be possible to manually connect USB devices to a running VM (except possibly in cases where the reset command is not correctly issued via the hub).

                • 5. Re: 2014 Preview still has USB 3 hub issue
                  dlhotka Virtuoso

                  Actually, that's awesome - I've wanted to disable the prompt for years.  I'll give it a go!

                  • 6. Re: 2014 Preview still has USB 3 hub issue
                    dlhotka Virtuoso

                    And yes, this solves it!  Thanks much!