2 Replies Latest reply on Jun 5, 2014 7:11 PM by MacsRule

    Hardware version upgrade prompt

    MacsRule Hot Shot

      Since the benefits of this new version of Fusion at least partially depend on upgrading to Hardware Version 11, doing so is important. If I remember correctly, back when Fusion 6 was released, a virtual machine being run by V6 for the first time presented a prompt to permit the upgrade. With this technology preview, while the HW upgrade can be done manually, in an instance where I did not, a VMware Tools update was recommended and allowed but there was no prompt at any time to also upgrade the HW version. Since such an upgrade is individually necessary for every VM the user has, and doesn't come automatically with a Tools upgrade, I'd suggest restoring the HW upgrade prompt on first boot of each VM with the new version of Fusion.

        • 1. Re: Hardware version upgrade prompt
          dlhotka Virtuoso

          I do see the prompt when booting mine.  Could you have accidentally said 'no' when it popped up?

          • 2. Re: Hardware version upgrade prompt
            MacsRule Hot Shot

            Nope, it never appeared. I tried it with two Win 7 VM's and a Mavericks VM. It didn't appear at all so I had to manually do it in the Compatibility settings pane. My first try with the Tech Preview was with Yosemite and I upgraded that manually before first boot. Could that have set some kind of pattern? I was surprised that installing the updated Tools, both automatically in Windows and manually in Mac OS didn't generate some kind of warning or advisory to update the HW version too, for compatibility.

             

            BTW, the Tech Preview didn't help with additional screen size options in Mavericks either, which I kind of expected it would. The video drivers I recommended in another thread on Yosemite as a VM in Fusion did work in both Mavericks and Yosemite.

             

            Update: As part of testing the Tech Preview in Yosemite (which didn't work), when I tried to open a pre-existing VM from within Fusion, I did get the Upgrade prompt before the VM attempted to run. Approving the upgrade caused the Hardware version to change in Preferences but the VM didn't actually run.

             

            Message was edited by: MacsRule: Result of additional tests added.