2 Replies Latest reply on Jul 30, 2015 9:29 PM by Jvansym

    Provision request failed:  A server error was encountered. Error requesting machine. Machine name [servername] already exists.

    irjdunn Lurker

      VCAC 6.0.1.1


      After deploying a Windows 2012 R2 server from a basic blueprint request, it immediately fails with a "machine name already exists" error.  This is a very basic out-of-the-box request workflow with no customization other than a hostname property specified to override the prefix.


      The vCAC log viewer indicates:

      Source: Repository

      Instance Name: Repository

      Message: Error requesting machine. Inner Exception: Exception has been thrown by the target of an invocation. Base Exception: Machine name [myactualservername] already exists.

       

      VMware KB 2043297 indicates that this is caused by a pre-deployment check of AD, DNS, or WINS.  To resolve, verify that the machine name does not exist in AD, DNS, or WINS.

       

      My question is, are there any other logs I can check to find out what is causing this failure to trigger?  Is it AD, DNS or WINS?  I do not have WINS implemented in this environment, AD does not have a computer account with this server's name, and I have tried with or without DNS entries with the same result.  (We tend to pre-provision DNS A and PTR records in our IPAM solution prior to deploying the VM with other requests working just fine).  It seems to me that vCAC has a record of this machine name, but not any of the components mentioned in the KB article.  Has anyone ran into this? 

       

      Thank you,

       

      James

        • 1. Re: Provision request failed:  A server error was encountered. Error requesting machine. Machine name [servername] already exists.
          beefy147 Enthusiast

          We have the same problem in vRA 6.2.1

           

          The machine is not in AD,DNS,WINS and is not in vCenter

           

          We ran an inventory in vRA on the cluster/s in question to bring it up to date with the vCenter inventory and it still fails saying the machine exists

           

          what else can be checked?

          • 2. Re: Provision request failed:  A server error was encountered. Error requesting machine. Machine name [servername] already exists.
            Jvansym Lurker

            I was having the exact same issue. I deleted the computer objects out of AD, out of DNS, and out of VC and it was still giving me the error that the machine name already existed. As a final attempt i ended up doing another full data collection on the compute node that was holding the machines before they were deleted (i had originally run a full data collection right after i deleted it from VC but it was still in DNS and AD). After the second data collection finished i was then able to provision the machine with the same name again without it giving me the error. The key here seemed to be that i had to remove it from AD,VC, and DNS first, wait for the DNS and AD changes to replicate and then perform the inventory. Not sure if that's your issue but hopefully it will help.

             

            Edit: Also, just in case someone else runs across this, if you provisioned the machine previously through VCAC and just deleted it from virtual center it will not automatically remove the machine from the VCAC inventory. Even if the VM is deleted in vCenter you will need to go into VCAC and find the machine and select "Destroy" to actually get rid of it.