3 Replies Latest reply on May 23, 2014 1:43 PM by rbedem

    "Fatal error: 10 (Out of resources)" - ESXi 5.5 U1 with ASUS Z87-DELUXE Motherboard - VSAN Home Lab

    rbedem Lurker

      Looking for assistance with building my 3 Node VSAN Home Lab.  This discussion entry has a lot of detail to assist anyone else in the same boat as me (now or future).


      The Objective:


      Operate a home lab with ESXi 5.5U1 where the primary storage is VSAN.  Requirement: 3 Hosts with at least 2 Cores and 8GB RAM, and at least one SSD and one SATA drive per host.


      The Problem:


      When I try to install ESXi 5.5 U1 on my Host (ASUS build details below), I get the message "Error loading /tools.t00 Fatal Error: 10 (Out of Resources)" during the install process. Install process is one USB Flash drive to another.

      When I install ESXi 5.1 U1 on the same system, everything works perfectly.  Install process is one USB Flash drive to another.

      Have not tried ESXi 5.5 yet.


      What have I done so far?  Too many things to mention, but here is where I made some progress.

      Customised the ESXi installer images to support the following (as per ESXi 5.1U, Z87-PRO, Adaptec ASR-6805E , VMware Front Experience: How to make your unsupported SATA AHCI Controller work with ESXi 5.5 and http://www.derekseaman.com/2013/08/building-haswell-esxi-server-vsan.html):


      Configured the following "Advanced" BIOS settings (F7 option):

      • Reset the BIOS to factory defaults (F5 option)
      • Advanced, CPU Configuration - "Intel Virtualisation Technology" ENABLED
      • Boot, CSM, Boot Devices - Legacy only (UEFI disabled)
      • Boot, SVM, Secure Boot - "Other OS"


      What BIOS settings/configurations had no impact/weird behaviour?


      • When I plug the SATA and SSD drives into the "Brown" coloured Intel SATA controller ports, ESXi cannot see the drives at all, regardless of what VIB files I add to the ISO image.  So I have only had it working with the yellow ASMedia controller ports.
      • I disconnected the SATA and SSD drives, disabled the Intel and ASMedia controllers.  This did not help.
      • I disabled the desktop hardware that has no benefit to ESXi (Advanced, Onboard Devices Configuration) - Audio, Bluetooth, On-board Wireless, Intel SATA controllers etc.  This did not help.
      • Thinking that Thunderbolt could be a problem, I tried to disable the Thunderbolt adapters (Advanced, Onboard Devices Configuration) and then I had problems with booting the ESXi ISO image.
      • I even added this Mac Mini Thunderbolt driver http://www.virtuallyghetto.com/2013/09/running-esxi-55-on-apple-mac-mini.html to the ESXi ISO image, with no success.


      What do I plan to do?


      • Upgrade the Z87-DELUXE Firmware (BIOS updater tool does not work, reports "Security Check Violation", will probably have to install Windows 7 to use the updater tool).
      • Try installing ESXi 5.5 and then use VUM to upgrade to Update 1.
      • Continue to build the entire environment with ESXi 5.1 U1 to burn-in and continue troubleshooting ESXi 5.5 U1 on a single host.


      What is the ESXi Host hardware configuration?


      • ASUS Z87-DELUXE-DUAL Motherboard (embedded RealTek & Intel I217V NICs, Thunderbolt adapters, "Brown" Intel and "Yellow" ASMedia SATA connectors)
      • ASUS Z87-DELUXE-DUAL BIOS Information 1008 x64, EC Version MBEO-Z87-0224, ME Version 9.0.21345, Build Date 05/17/2013
      • Intel Haswell i7-4770 LGA1150 Processor
      • 2 x Corsair Vengeance DDR3 8GB RAM
      • 1 x Corsair Force 3 240GB SSD Drive
      • 1 x Western Digitial Green 2TB SATA Drive
      • 2 x Corsair 32GB USB Flash Drives (one for ESXi ISO image prepped with UNetbootin - Homepage and Downloads and the other is the ESXi boot disk)
      • No PCI-e adapters (using on-board storage and network controllers)


      Once I get it working, I will update this thread and provide a detailed write-up at http://www.vcdx133.com/

      NPX#8, 3xVCDX#133, http://vcdx133.com