5 Replies Latest reply on Jul 11, 2014 7:04 AM by RubenEGraff

    Vami will not keep host name.....

    RubenEGraff Novice

      I have and Ubuntu 10.04 Studio Appliance.  When you open the Web interface and set the Host name it takes it.  Log out and back in and it is clearly reflected.  Reboot the server and the host name reverts to localhost.localdom.

       

      See the attached file for screen shots

       

      I have found a work around as it seems the vShield data security appliance has the same issue .  KB article 2009519

        • 1. Re: Vami will not keep host name.....
          RubenEGraff Novice

          http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2009519

           

          Here is the link to the work around.

           

          I need to get this fixed so the web interface option will work .

          • 2. Re: Vami will not keep host name.....
            samdoyle Enthusiast
            VMware Employees

            Hi,

            For Studio 2.6, I believe the only way to get this working if you do not have the vami.hostname property set in ESX is to do the following:

             

            1.) Manually or through the ui create a working /opt/vmware/etc/vami/ovfEnv.xml file.

            2.) Once satisfied, edit /opt/vmware/share/vami/subsequentboot and comment out the line

            if [ -x /opt/vmware/share/vami/vami_ovf_process ]; then

               /opt/vmware/share/vami/vami_ovf_process --printovfenv > /opt/vmware/etc/vami/ovfEnv.xml

            fi

            This overwrites the ovfEnv.xml with the current ovf properties with the values configured through the client on every boot. What comes from the file is used to configure the networking.

             

            Please note though, this means that any properties you configure through the client as explained in the KB article will not be detected further on.

             

            S.D.

            • 3. Re: Vami will not keep host name.....
              RubenEGraff Novice

              Sorry but been out of the loop last week or so.  I deployed a new appliance and opened it through the UI.  Note I did not apply the work around to this VM.

               

              1. My vm has the ovfEnv.xml file.

              2.  I commented out the if loop in the subsequentboot file. 

              3.  From the Web interface I set the local domain name to eva.vami.com.  This is reflected in the etc/hosts file

               

              Hosts file Capture.PNG

               

              on reboot, the host name reverts back to localhost and the lines added to the hosts file are removed and changed back to localhost.localdom

               

              Hosts file Capture.PNG

               

              The host name is still not sticking.  Is there some process on boot that writes out this file that can be commented out on only run on first boot?

              • 4. Re: Vami will not keep host name.....
                samdoyle Enthusiast
                VMware Employees

                If you have made your changes you can remove

                /opt/vmware/etc/vami/flags/vami_sethost{name,network}

                 

                If you want to disable this in your build profile you can also set the following properties to false:

                 

                <vadk:SetHostname>false</vadk:SetHostname>

                  <vadk:SetNetwork>false</vadk:SetNetwork>

                • 5. Re: Vami will not keep host name.....
                  RubenEGraff Novice

                  Setting the SetHostname and SetNetwork to false in the XML worked.  I was still able to use the web interface to change the values, and on reboot, the host name stuck .

                   

                  Is there a way to set the default hostname to something besides localhost.localdom. 

                   

                  I couldn't find anywhere in the XML that that was set.