1 Reply Latest reply on May 1, 2020 1:44 AM by WeMakeTheNetWork

    enable network serial port in ESXi 5.x - license issue?

    esx4ciscouser Lurker

      I have a standalone (free) esxi 5.1 server that I use to test Cisco VM's. This week I was working with CSR1000v - a virtual router - and the preferred way to connect to it is to add a serial port to the VM, and configure it to use "network serial", configuring the vm as server and a telnet://x.x.x.x:yyyy and enabling the firewall to pass it. Nothing I did seemed to work. Then I changed the license to "demo" and it worked as advertised. I am not using the "virtual serial concentrator" - just the native "network serial" option.

       

      What license would I need to buy to enable this to work? It's just one host, so I don't need any advanced features such as vmotion, distributed vswitch, etc. Just the ability to use a network-based serial port.

        • 1. Re: enable network serial port in ESXi 5.x - license issue?
          WeMakeTheNetWork Lurker

          if you're on the free license, FREE license does not allow you to use the serial port connected over network!

          Can't find this information nowhere on VMWare website or otherwise. If you find a link states this, please reply to this.

          So the solution: You need to go back to the evaluation license for valid for 60 days.

           

          However, clearing the license from Web Client was not enough. Because it didn't go back to Eval license. It stayed kind of empty. (In 6.7 go to Host > Manage < Licensing > Remove License)

          So I tried to enter the Eval licsense. Eval license is all zeroes. However, web client doesn't register the license to 00000 for some reason. It seems like it accepts it but do not register.

           

          I had to do this:

          Connect via SSH. Then:

          vim-cmd vimsvc/license --show

          vim-cmd vimsvc/license --set=00000-00000-00000-00000-00000
          vim-cmd vimsvc/license --show

           

          then you can connect with serial over console.