8 Replies Latest reply on Mar 29, 2014 11:04 AM by wahidayat

    ESX host can't ping default gateway!

    wahidayat Lurker

      Hi Experts,

                      I have connected ESX hosts to the cisco switch both via iLO and other ports.

       

      Cisco Switch Config;

       

      int gig 1/0/21 and gig 1/0/13 and gig 1/0/14 are configured as an access ports since they are carrying/tagging only one vLan 306.

       

      From Cisco switch, I can ping the iLo ip address, but I can't ping the management IP address and vice versa.

       

      Managment IP

       

      10.197.204.10

      255.255.255.0

       

      10.197.204.1

       

      vlan 306

       

      Attached is the screen shot showing the diagram.

       

       

      your help will be appreciated.

       

       

      Regards

        • 1. Re: ESX host can't ping default gateway!
          a.p. Guru
          Community WarriorsUser ModeratorsvExpert

          Welcome to the Community,

           

          please provide details about the vSwitch/port group configuration for the Management network. From what you write the physical configuration seems to be ok, but I think you might have a configuration issue on the Managenemt Network (e.g. VLAN-ID set to 306 instead of 0/None)

           

          André

          • 2. Re: ESX host can't ping default gateway!
            wahidayat Lurker

            Cisco switch Config;

             

            interface GigabitEthernet1/0/21

            switchport access vlan 306

            switchport mode access

             

             

            interface GigabitEthernet1/0/13

            switchport access vlan 306

            switchport mode access

             

             

            interface GigabitEthernet1/0/14

            switchport access vlan 306

            switchport mode access

             

             

            ==============================

             

            All I did is configured ESX Management blow;

             

            10.197.204.10

            255.255.255.0

             

            10.197.204.1

             

            vlan 306

             

            selected Nic 0 and Nic 4 and Vlan is 306.

             

             

            Question: Do I need any more configuration apart from the above ? If yes, how ?

             

             

            Thanks

            • 3. Re: ESX host can't ping default gateway!
              a.p. Guru
              Community WarriorsUser ModeratorsvExpert

              >>> selected Nic 0 and Nic 4 and Vlan is 306.

              It looks like you did too much already

              With Access ports on the physical switch, you don't want to configure the VLAN-ID on the virtual port group. Setting the VLAN-ID back to zero/none on the Management Network should do the trick.

               

              André

              • 4. Re: ESX host can't ping default gateway!
                wahidayat Lurker

                Sorry, I did not get your point. Did you mean to configure port-channel/aggregated port/bundled one and make it as none negotiated one and only allow vlan 306 ... If that what you mean, then I tried already that one, but it did not work either. Apart from what I configured above, is there any other additional configuration, that I need to do or ?

                 

                 

                 

                Thanks

                • 5. Re: ESX host can't ping default gateway!
                  a.p. Guru
                  User ModeratorsvExpertCommunity Warriors

                  No, you can certainly use access ports if you like. What I meant is that when using access ports on the physical side, you must not set a VLAN-ID on the ESXi host side.

                  As a side note, you should add spanning-tree portfast to the switch port's configuration.

                   

                  André

                  • 6. Re: ESX host can't ping default gateway!
                    wahidayat Lurker

                    I left the vlan option blank on the esx configuration, but still no joy

                    • 7. Re: ESX host can't ping default gateway!
                      a.p. Guru
                      User ModeratorsvExpertCommunity Warriors

                      Not sure what it is, but it's got to be something simple we are missing

                      Let's go through each configuration step for the two ESXi network connections (iLO already works, so we don't touch it).

                       

                      Check the physical switch port configuration for interface GigabitEthernet1/0/13 as well as 1/0/14.

                      switchport access vlan 306

                      switchport mode access

                      spanning-tree portfast

                       

                      Only connect the network cable for vmnic0 to the host and make sure vmnic0 shows up as "Connected" in the DCUI

                       

                      Double check that the VLAN-ID is blank.

                       

                      Then ensure the IP settings are correct (i.e no typos, ...) and restart the Management Network from the main menu.

                       

                      André

                      • 8. Re: ESX host can't ping default gateway!
                        wahidayat Lurker

                        By removing the Vlan number, it worked, it was double tagging ... cisco switching was confused... Thanks for your help.