0 Replies Latest reply on Mar 25, 2014 5:44 AM by lrmurali

    vMotion with NPIV+ RDM results in failure of v-port creation while swapping VMs between hosts

    lrmurali Novice

      Hi,

      I have configured 2 VMs ( 1 from each host) in vCenter with NPIV and RDM disk.

      Below are the configurations details

       

      VM1 (SUSE OS) carved out from Host1 ( ESXi 5.1)

      VM2 (SUSE OS) carved out from Host2 ( ESXi 5.1)

      Both VMs are assigned with FC NPIV ( 1 WWN + 1 WWPN)

      Both hosts are having  Brocade HBA card .

      HBA and switch supports NPIV.

      Zoning is done with WWPN, storage and switch.

      RDM disk presented to both VMs by sharing the same LUN path.

      Shared single LUN with both VMs and 'multi-writer' flag is enabled

       

      With above setup we were able to see v-ports of VMs on both hosts SCSI config file (/proc/scsi/bfa/6)

      Since both VMs are booted and vport are created we assume NPIV setup is proper.

       

      Experiment 1:

      -----------------

      With above setup tried migrate of VM1 from Host1 to Host2. It worked fine and we were able to see VM1 vPort is moved

      to Host2 /proc/scsi/bfa/6 list. As part of this moved back VM1 from Host2 to Host1. This also worked fine and vPort is successfully

      created on Host1.

       

      Experiment 2 : [Failure Scenario:]

      ============

      With same setup we have tried to do the swapping of VMs( means VM1 is moved from Host1 to Host2 and after that VM2 is moved

      from Host2 to Host1. Due to this both ports are deleted from /proc/scsi/bfa/6 file and vmkernel.log failed to create vPort on Host1.

      Above operation is failing to create vPort during rescan with below error:

       

      2014-03-14T12:56:20.441Z cpu0:5035)WARNING: ScsiNpiv: 1348: Created vport for world 5036, vmhba2, rv 0

      2014-03-14T12:56:20.441Z cpu0:5035)ScsiNpiv: 1149: NPIV vport rescan complete, [0:1] (0x4100090cfe40) [0x41000a008b20] status=0xbad0003

      2014-03-14T12:56:20.441Z cpu0:5035)WARNING: ScsiNpiv: 1806: Failed to Create vport for world 5036, vmhba2, rescan failed, status=bad0001

      2014-03-14T12:56:20.442Z cpu0:5035)LinScsiLLD: scsi_remove_host:857: Removed Host Adapter vmhba38


      Could you please let me know why only swapping of VMs is fails to created vPort with above error?

      Is swapping of VMs with vMotion is supported? ( with NPIV + RDM )

      We suspect there could be some setup/configuration issue( zoning or LUN  presentation). However we were not able to figure out why the vports are disappeared from hosts scsi file?


      Any pointer to resolve this problem will be greatly appreciated.


      Please let me know if you need any other information.


      Thanks in advance.

      LRM