2 Replies Latest reply on Mar 17, 2014 8:44 AM by jmattson

    More 32-bit VM running on 64-bit host problems

    mlheese Lurker

      I'm sure this question has been asked many times but I can't find an answer that fits for me.

       

      We have VM's with RHEL 6.2 (32-bit) that were all created using VMWare Player v4.0.4 build-744019 on a 32-bit Windows 7 machine.

       

      Now, we've upgraded all our PC's to use 64-bit Windows 7 (not my decision).

      We installed the same version of VMWare Player (4.0.4) on the 64-bit machines that we had before.

      When we try to run the RHEL 6.2 (32-bit) VM's we've been using, they now throw an error saying something about Long Mode not supported.  Following this, the VM won't load at all and just sits there cycling trying to boot non-stop.

       

      The paravirtualization setting does not appear anywhere in VMWare v4.0.4 that we can find, so I'm not sure how to enable/disable that with this version.

      We tried the fix adding the disable_longmode parameter to the .VMX file and this did nothing.

       

      We no longer have our old 32-bit machines, so we're stuck trying to find a 32-bit machine just to get our code off these VMs or find a way to make these work on our new 64-bit machines.

      I tried creating a brand new VM of RHEL (32-bit) on my 64-bit machine with VMWare v4.0.4 and it works fine, so I'm not sure why the old ones don't?

       

      I'd be grateful to anyone that can provide a useful suggestion.  Tracking down an old 32-bit machine just to download source code off a dozen VMs would be a last resort for me.

       

      Thanks