1 2 3 Previous Next 32 Replies Latest reply on May 3, 2016 7:26 PM by dsalnikov Go to original post
      • 15. Re: vmware 5.5 u1 - iScsi adapter crashes the system
        Michael.Rudloff Enthusiast
        vExpert

        Same here, ISCSI initiator crashes the system (using rollup iso). Using Supermicro Hardware.

        • 16. Re: vmware 5.5 u1 - iScsi adapter crashes the system
          dpg2vgs Novice

          Another "me too" on this one. All of our equipment (Dell PowerEdge x20 servers, PowerConnect 70xx switches, and EqualLogic PS6xxx storage running 7.02 firmware) is on the HCL. I spent a fair bit of time with VMware support over the last three days troubleshooting with our spare server and a test volume. The hostd process is usually completely shot, as noted by pasikappext.

           

          I found this thread and tried the non-rollup ISO with our usual iSCSI setup script (leveraging Dell's MEM 1.2 TR1091 configuration script, but not installing the module) and had instant success. Subsequent reboot and power-pull tests on the host worked fine, the iSCSI volumes mounted with a Round Robin policy and the test VMs fired-up as they should. Performance seems typical although I haven't run the IOmeter benchmarks yet.

           

          I think VMware ought to pull the rollup ISO or clearly indicate that it may not work on all HCL systems and the referenced ISO is preferred.

           

          Thanks for starting this thread, Martin. Good luck with the non-rollup ISO and the 1955.

          1 person found this helpful
          • 17. Re: vmware 5.5 u1 - iScsi adapter crashes the system
            AlexanderCapaldi Novice

            i have just updated 3/4 of my esx 5.5 hosts to update 1, via the vsphere update manager, and when i got to the iscsi hba properties it works.

            Hardware: Supermicro H8QME-2+ 128GB ram

             

            what sequence of events cause yours to crash?

            • 18. Re: vmware 5.5 u1 - iScsi adapter crashes the system
              dpg2vgs Novice

              A reboot or power-cycle after the update and the setup of the iSCSI interface would do it, if, and only if, your installation was a fresh installation from the “rollup” ISO.

               

              If you used the update manager you may not have a problem. Just try a reboot and see what happens.

              • 19. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                Michael.Rudloff Enthusiast
                vExpert

                I can't even get the iscsi initiator installed on a fresh installation. Bear in mind, the Rollup ISO does state anyway that it is not to be used for upgrades. Regardless, if I install the Rollup ISO on any server we have, HCL or not HCL validated, the hostd process is trashed as soon as the iscsi initiator is enabled.

                • 20. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                  pasikappext Lurker

                  Fresh ESXi 5.5U1 installations from "VMware-ESXi-5.5U1-RollupISO.iso" are buggy, enabling sw iSCSI there, and rebooting, crashes hostd on every reboot rendering the hosts unmanageable.

                  Using "VMware-VMvisor-Installer-5.5.0.update01-1623387.x86_64.iso" instead works OK.

                  • 21. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                    AlexanderCapaldi Novice

                    esx5.5.0.u1.png

                    lets compare your esxi 5.5.0 u1 os build numbers, i managed to update all my servers via the vsphere update manager without any issues, iscsi initiator still intact.

                    • 22. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                      mcorpolo Lurker

                      I'm seeing the same issue as well.  Building new DL360 Gen 8 servers, built from a 5.5 disk then used Update Manager to patch up.  During setup and scan for iSCSI the machine hangs with the previously mentioned symptoms of not even being able to use F2/F12 at console of server to reboot.

                       

                      Power cycled the server and on boot it takes FOREVER.  Gave up, unzoned the iSCSI initiators at my array, and the server then quickly finished booting.

                       

                      Will attempt a fresh install, again, this time from a 5.5u1 fresh media.

                      • 23. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                        M.Meuwese Novice

                        Hello All,

                         

                        Thank you for all the effort and replies on this post. Today is then finally the day that i have time to try this 1 more time with the recommended CD image. Once completed i will post my findings whereas i suspect all will do just fine.

                         

                        Regards,

                         

                        Martin Meuwese

                        • 24. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                          peetz Master
                          User ModeratorsvExpert

                          Hi all,

                           

                          I could reproduce the issue by installing a nested ESXi host with the 5.5 U1 Driver Rollup ISO.

                          Creating a Software iSCSI adapter will crash the hostd daemon and make the host unmanageable.

                           

                          I was able to track down the issue to the scsi-teradimm VIB that is included in this ISO.

                          Once you have removed it by running

                           

                          esxcli vib remove -n scsi-teradimm

                           

                          in an ESXi shell and reboot the host, the issue will no longer appear.

                           

                          Andreas

                          • 25. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                            dabrams971 Lurker

                            Hi all,

                            I too spent a few days on this problem, it's defenetly not an HCL problem (tested with HCL and non HCL hardware. I totaly agree with Peetz, I was intrigued by the teradimm adapter which I had never seen before, removing it does resolve the problem. Also installing with the non Rollup ISO, I no longer see teradimm in the storage adapters and everything works perfectlly.

                            • 26. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                              peetz Master
                              User ModeratorsvExpert

                              Today VMware has finally addressed the issue by publishing http://kb.vmware.com/kb/2075171

                              It looks like I was wrong with pointing to the scsi-teradimm VIB ...

                               

                              Please note: It looks like VMware will not replace the ISO download with a fixed version. Why, VMware?!?

                              • 27. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                                vTagion Enthusiast

                                wish I would have seen this sooner...

                                • 28. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                                  ShoHRock Novice

                                  Hostd service was crashing when VMware default ESXi ISO was being used. kernel logs: 2014-06-09T13:34:48.548Z cpu4:44586)User: 2888: wantCoreDump : hostd -enabled : 1 2014-06-09T13:34:48.657Z cpu4:44586)UserDump: 1820: Dumping cartel 44586 (from world 44586) to file /var/core/hostd-zdump.003 ... 2014-06-09T13:34:56.405Z cpu5:44586)UserDump: 1944: Userworld coredump complete. Using Dell custom image fixed the issue. This is not the first time using Dell Custom image has helped overcome such issues. Looks like Dell H/w likes Dell Custom image more then VMware default.

                                  • 29. Re: vmware 5.5 u1 - iScsi adapter crashes the system
                                    PeteKowalsky Enthusiast

                                    When I painted myself into this awful corner, this was the ticket out:


                                    # esxcli vib remove -n ima-be2iscsi

                                    Connect to localhost failed: Connection failure

                                     

                                    ^-- seems to be due to hostd not running, which is the entire issue here.  Catch-22.  What to do?

                                     

                                    DO THIS INSTEAD:

                                     

                                    # localcli software vib remove --vibname ima-be2iscsi

                                    Removal Result:

                                       Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

                                       Reboot Required: true

                                       VIBs Installed:

                                       VIBs Removed: VMware_bootbank_scsi-blahblahblah.550.0.0.1331820

                                       VIBs Skipped:

                                    # reboot

                                     

                                    DONE!

                                     

                                    LESSON LEARNED: NEVER update a host with the Driver Rollup ISO.  ALWAYS USE THE FULL INSTALLER TO UPDATE HOSTS.  Use the driver rollup disc to do fresh installs only.