8 Replies Latest reply on Feb 27, 2018 1:10 PM by Proudx

    ESXi 5.5 prevents HDD spin down

    hugo012 Lurker

      Hello!

       

      First, sorry for my bad english!

       

      I have a problem with my ESXi 5.5. I am running a VM as NAS with Openmediavault.

       

      I am using four HDDs which the host accesses as physical RDMs. (http://www.vm-help.com/esx40i/SATA_RDMs.php)

       

      S.M.A.R.T-monitoring in the VM works fine and i can e.g. spin down the HDDs manually with "hdparm -y /dev/sd[bcde]".


      But i want an automatic spin down after 2 hours of idle. But it appears that the ESXi accesses the HDDs every 30 min, because the automatic spin down only works with an idle time less then 30 min.

       

      Do you have any ideas how i can turn off this disk access or increase it at over 120 min?

       

      Thank you very much!

       

        • 1. Re: ESXi 5.5 prevents HDD spin down
          john23 Expert

          Afalk, you can control parameters from vsish node in ESXi, but it is not recommended to change the parameter without VMware expert.

           

          Check scsi node in vsish.

           

          -A

          • 2. Re: ESXi 5.5 prevents HDD spin down
            hugo012 Lurker

            Can you tell me which parameters exactly i have to edit?

            • 3. Re: ESXi 5.5 prevents HDD spin down
              d8b Novice

              Hi

               

              did you find a solution to your problem?

               

              I've got a somewhat similar problem

              I also have attached two HDDs to a VM as physical RDMs (used the same instructions you linked to), which runs on an ESXi 5.5 host. I already tried different OS (Win2003,2008,FreeBSD,...) but none of them automatically spun down the HDDs. They only spin down, when I trigger it manually. (with HDDScan, hdparm)

               

              Your drives spun down automatically when your setting was below 30 min?

               

              And anyone an idea what prevents the guest os to spin down the HDDs automatically (even if the delay is set to 5 min)?

               

              I would be grateful for any help... thank you.

              • 4. Re: ESXi 5.5 prevents HDD spin down
                FREAKJAM Lurker

                Same here, I also tried a few different distro's (FreeNAS, NAs4Free, OMV), but i'm only able to spindown manually. (with hdparm -y).

                Anyone able to fix this?

                • 5. Re: ESXi 5.5 prevents HDD spin down
                  d8b Novice

                  Hi all

                   

                  finally I have a solution:

                  VMware ESXi: HDD Standby (spin down) mit physical RDM unter Windows | blog.bistron.eu (german)

                   

                  The automatic spin down in Windows can be activated by a registry entry (EnableIdlePowerManagement) at the virtual storage controller.

                  But I still do not know what to do on Linux systems...

                   

                  The problem - this thread was originally about -, that the ESXi Hosts accesses and spins up the disks every 30 minutes, seems to be caused by the smartd deamon which was introduced with ESXi 5.1. If you stop and disable smartd on the ESXi host the disks stay spun down.

                  • 6. Re: ESXi 5.5 prevents HDD spin down
                    hugo012 Lurker

                    That really looks like the final solution. I have to thank you so much!

                     

                    Unfortunately I can not test it at the moment, because I'm not home during the semester break. I could do it via Teamviewer or RDP, but then i can't hear whether the disks are spun down...


                    Enabling automatic spin down under Linux is no problem for me, i can do it with Openmediavault's simple web interface and manually with "hdparm -S time /dev/sdb" or "spindown_time = time" in hdparm.conf.


                    When I'm home again, I'll mark this problem as solved.

                    • 7. Re: ESXi 5.5 prevents HDD spin down
                      hugo012 Lurker
                      I know this was very long semester break. 


                      But finally I just have to say that this was exactly the right solution.

                      Too bad that VMware doesn't informed us about the new smartd deamon or even better provided a configuration option in the vSphere Client.

                      • 8. Re: ESXi 5.5 prevents HDD spin down
                        Proudx Lurker

                        I stopped the smartd process /etc/rc.init/smartd stop but my rdm drives keep waking.  Is there anything else that has to be done to ensure smartd is not waking?