1 Reply Latest reply on Dec 2, 2013 6:18 AM by WoodyZ

    VMPlayer won't start - Vmblock and Vmci problems?

    fkereki229 Novice

      Hi!

       

      I use OpenSUSE, and I just updated to version 13.1, which uses kernel 3.12.  I rebuilt all the vmplayer modules, and vmplayer does start, but if you try to load and run a virtual machine, you get:

       

      > cat /tmp/vmware-fkereki/vmware-modconfig-6358.log

      2013-12-02T11:25:19.386-03:00| vthread-3| I120: Log for VMware Workstation pid=6358 version=10.0.1 build=build-1379776 option=Release

      2013-12-02T11:25:19.386-03:00| vthread-3| I120: The process is 64-bit.

      2013-12-02T11:25:19.386-03:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8

      2013-12-02T11:25:19.386-03:00| vthread-3| I120: Host is Linux 3.12.0-1.ge8fa6b4-desktop openSUSE 13.1 (Bottle) (x86_64)

      2013-12-02T11:25:19.330-03:00| vthread-3| I120: Msg_Reset:

      2013-12-02T11:25:19.330-03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.

      2013-12-02T11:25:19.330-03:00| vthread-3| I120: ----------------------------------------

      2013-12-02T11:25:19.330-03:00| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.

      2013-12-02T11:25:19.353-03:00| vthread-3| I120: Msg_Reset:

      2013-12-02T11:25:19.353-03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/home/fkereki/.vmware/config": No such file or directory.

      2013-12-02T11:25:19.353-03:00| vthread-3| I120: ----------------------------------------

      2013-12-02T11:25:19.353-03:00| vthread-3| I120: PREF Optional preferences file not found at /home/fkereki/.vmware/config. Using default values.

      2013-12-02T11:25:19.386-03:00| vthread-3| W110: Logging to /tmp/vmware-fkereki/vmware-modconfig-6358.log

      2013-12-02T11:25:19.445-03:00| vthread-3| I120: System distribution is SuSE

      2013-12-02T11:25:19.445-03:00| vthread-3| I120: System version is 13.1

      2013-12-02T11:25:19.445-03:00| vthread-3| I120: Obtaining info using the running kernel.

      2013-12-02T11:25:19.457-03:00| vthread-3| I120: Created new pathsHash.

      2013-12-02T11:25:19.457-03:00| vthread-3| I120: Setting header path for 3.12.0-1.ge8fa6b4-desktop to "/lib/modules/3.12.0-1.ge8fa6b4-desktop/build/include".

      2013-12-02T11:25:19.457-03:00| vthread-3| I120: Validating path "/lib/modules/3.12.0-1.ge8fa6b4-desktop/build/include" for kernel release "3.12.0-1.ge8fa6b4-desktop".

      2013-12-02T11:25:19.492-03:00| vthread-3| I120: Failed to find /lib/modules/3.12.0-1.ge8fa6b4-desktop/build/include/linux/version.h

      2013-12-02T11:25:19.492-03:00| vthread-3| I120: /lib/modules/3.12.0-1.ge8fa6b4-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.

      2013-12-02T11:25:19.516-03:00| vthread-3| I120: using /usr/bin/gcc-4.7 for preprocess check

      2013-12-02T11:25:20.139-03:00| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.12.0-1.ge8fa6b4-desktop".

      2013-12-02T11:25:20.165-03:00| vthread-3| I120: The header path "/lib/modules/3.12.0-1.ge8fa6b4-desktop/build/include" for the kernel "3.12.0-1.ge8fa6b4-desktop" is valid.  Whoohoo!

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Reading in info for the vmmon module.

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Reading in info for the vmnet module.

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Reading in info for the vmblock module.

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Reading in info for the vmci module.

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Reading in info for the vsock module.

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Setting vsock to depend on vmci.

      2013-12-02T11:25:20.368-03:00| vthread-3| I120: Invoking modinfo on "vmmon".

      2013-12-02T11:25:20.373-03:00| vthread-3| I120: "/sbin/modinfo" exited with status 0.

      2013-12-02T11:25:20.373-03:00| vthread-3| I120: Invoking modinfo on "vmnet".

      2013-12-02T11:25:20.377-03:00| vthread-3| I120: "/sbin/modinfo" exited with status 0.

      2013-12-02T11:25:20.377-03:00| vthread-3| I120: Invoking modinfo on "vmblock".

      2013-12-02T11:25:20.381-03:00| vthread-3| I120: "/sbin/modinfo" exited with status 256.

      2013-12-02T11:25:20.381-03:00| vthread-3| I120: Invoking modinfo on "vmci".

      2013-12-02T11:25:20.386-03:00| vthread-3| I120: "/sbin/modinfo" exited with status 256.

      2013-12-02T11:25:20.386-03:00| vthread-3| I120: Invoking modinfo on "vsock".

      2013-12-02T11:25:20.391-03:00| vthread-3| I120: "/sbin/modinfo" exited with status 0.

       

      If I check the status of the running services, I get

       

      # /etc/init.d/vmware status

      Module vmmon loaded

      Module vmnet loaded

       

      which seems to confirm that there is a problem with vmblock and vmci... any ideas?

       

      Thanks, and best regards,

      Federico Kereki

        • 1. Re: VMPlayer won't start - Vmblock and Vmci problems?
          WoodyZ Guru

          I'd assume that the product is not yet officially supported when using the 3.12 kernel and this typically requires applying a third-party patch, if available, or waiting until it's supported.  The other option is to use a supported kernel.

           

          BTW  In the future... DO NOT copy and paste the entire contents of the .log or .vmx files into the body of a reply!  Use the "Use advanced editor" link in the upper right corner of the normal reply window to bring up the Advanced Editor where you'll be able to attach files via the Choose File button or Browse button (depending on the Browser) above the Post Message button!

           

          Posting only the lines you highlighted in red is all that needed to be posted to bring attention to the issue, then attach the file for the rest!