3 Replies Latest reply on Nov 22, 2013 8:58 AM by Fillips

    Worksation Server: SSH Handshake failed

    miallen Novice

      I am testing VMWare Workstation on a headless CentOS 6.1. I used:

       

        # sh <package> --custom --console

       

      to install and AFAICT it all worked. I designated the Workstation Server port to be 8443 instead of the default 443.

       

      When I try to visit the web interface in chrome with URL http://1.2.3.4:8443 chrome reports "No data received" and /var/log/vmware/hostd.log records:

       

        2013-11-15T23:39:54.421-05:00 [7F597D5DC720 warning 'Proxysvc'] SSL Handshake failed for stream <SSL(<io_obj p:0x00007f5970000c50, h:42, <TCP '1.2.3.4:8443'>, <TCP '1.2.3.5:50010'>>)>: N7Vmacore3Ssl12SSLExceptionE(SSL Exception: error:140000DB:SSL routines:SSL routines:short read)

       

      Why is this failing?

       

      Do I need to install another package or configure a certificate or something?

       

      Is there something about any of this in the "VMware Workstation 10 Documentation Center"?

       

      Mike

        • 1. Re: Worksation Server: SSH Handshake failed
          miallen Novice

          Can VMware Workstation run on Linux without X windows?

           

          With VMware server you can use a conventional browser to access the host and setup new VMs. I get the feeling this is actually not possible with VMware Workstation?

           

          So I have to install Linux with X windows?

          • 2. Re: Worksation Server: SSH Handshake failed
            YiLing98 Novice

            Hi

             

            Welcome to the communities.

             

            If you are getting error about that component then please install and proceed without waiting more.

             

             

            If I have lost confidence in myself, I have the universe against me. http://imagicon.info/cat/5-59/vbsmile.png
            • 3. Re: Worksation Server: SSH Handshake failed
              Hot Shot

              Resolution

              These alarms occur even if the host is working correctly.

              To work around this issue, increase the value of handshakeTimeoutMs:

              1. Connect to your ESXi/ESX host via a remote Kernel-based Virtual Machine (KVM) or Secure Shell (SSH) session or directly as root.
              2. Open the /etc/vmware/hostd/config.xml file in a text editor.
              3. Enter <handshakeTimeoutMs> 120000 </handshakeTimeoutMs> between the <ssl> tags in the vmacore section. This parameter is in milliseconds. For example, 120000 millseconds = 2 minutes.

                <vmacore>
                <threadPool>
                <MaxFdsPerThread>2048</MaxFdsPerThread>
                </threadPool>
                <ssl>
                <handshakeTimeoutMs> 120000 </handshakeTimeoutMs>
                <useCompression>true</useCompression>
                </ssl>
                <vmdb>
                <maxConnectionCount>8</maxConnectionCount>
                </vmdb>
                <loadPlugins> true </loadPlugins>
                </vmacore>

              4. Save and close the file.
              5. Restart the Management agents. For more information, see Restarting the Management agents on an ESXi or ESX host (1003490).
              6. To confirm that the tags have taken effect, check the /var/log/vmware/hostd.log file for this message:

                [2010-03-15 09:49:32.788 F66D76D0 info 'App'] Vmacore::InitSSL: doVersionCheck = false, handshakeTimeoutUs = 120000000