5 Replies Latest reply on Sep 4, 2013 6:45 AM by RDPetruska

    Can't Connect CD

    IReallTryhard Enthusiast

      Hi,

       

      If I start XP in Player and the USB CD is not connected I get an "ide:1 not available, do you want to connect this next time..." message so I click "Yes"

       

      Once XP is up and running, I plug in the CD and then right click the icon at the top and click "Connect" but I again get the "ide:1 not available..." error.

       

      In order for the CD to be connected, I have to turn off the Player with the "Suspend" option, wait until the snapshot is saved then restart Player.

       

      Is this a bug or is this something I am doing wrong?

       

      What do I need to do to be able to connect to the CD once in XP and Player?

       

      By the way, if I plug anything else in the USB hub of the host, XP notices it right away so it is something to do with the CD and Player.

       

      Thanks

        • 1. Re: Can't Connect CD
          RDPetruska Guru
          User ModeratorsvExpert

          Change the VM settings - change the optical device from "Auto detect" to the actual drive letter of the host's USB CD drive.

          • 2. Re: Can't Connect CD
            IReallTryhard Enthusiast

            Thanks for the reply, but there is no way to do that as far as I can see.

             

            The "Connection" option drop down box for "use physical drive" only has "Auto Detect" and the "Advanced..." options are all grayed out.

             

            RDP, when you reply to a message it would be more helpful if you gave a short description of how to do what you are suggesting. If the people asking were smart enough to know how to do stuff from a cryptic comment, they would not be asking.

            • 3. Re: Can't Connect CD
              RDPetruska Guru
              User ModeratorsvExpert

              First, with Player not running (or at least the VM not loaded up and opened), plug in your USB CD-ROM device.  Make sure your host assigns a drive letter for it.

              Then, Open the VM in Player - to Edit.  Edit the CD-ROM device setting.  Change the physical device from "auto-detect" to whatever drive letter your host gave it.  Save the settings.  Run the VM.

              • 4. Re: Can't Connect CD
                IReallTryhard Enthusiast

                Thanks for the reply and instructions but the CD may not always be the same drive letter. I may have a flash drive or two plugged into the USB-hub. I rarely use the CD so it would pretty much always be the last drive attached with no guarantee it was "E:" or whatever.

                 

                I need to be using AutoDetect, but for that I have to do as I mentioned in my 3rd paragraph in the OP, the Player needs to be shut down, then restarted. Seems like a bug to me that it doesn't do a rescan for available drives when in the "Manage - virtual machine settings" and I click "Connect"

                 

                After all, "Auto-detect" is showing and it doesn't. Well, not until I restart the entire Player.

                • 5. Re: Can't Connect CD
                  RDPetruska Guru
                  vExpertUser Moderators

                  I'm just saying that ever since auto-detect was an option, it has never worked as one would expect it to.  Most of us users recommend NOT using it!