1 2 Previous Next 19 Replies Latest reply on Jul 29, 2015 8:28 AM by dcell59

    VMware Workstation unrecoverable error

    Demuz Novice

      Hello,

       

      I'm having serious problems with VMware Workstation (version 9.02) and single Windows 8 virtual machine. VMware Workstation is installed to x64 Windows 8 host. This single VM randomly crashes with the following error message:

      http://i.imgur.com/BqF1r2Q.png

       

      I have other virtual machines too but I dont have problems with them. I first thought this was a physical disk error and I moved this virtual machine to another disk but it didn't help. I have reinstalled VMware Tools and even created a completely new virtual machine and cloned this problematic machine with Acronis Backup&Restore to this. This caused the machine to crash with same error but in every boot so things got even worse.

       

      Any ideas what to do with this?

       

      I have attached a log file.

       

      Message was edited by: Demuz

        • 2. Re: VMware Workstation unrecoverable error
          Demuz Novice

          I updated to VMware Workstation 10 and reinstalled the whole problematic virtual machine from the scratch, but it still crashed randomly few times per day with same error.

           

          But now things look good so far.

           

          Yesterday I changed one setting. I unchecked "Accelerate 3D Graphics" from VM settings (under display settings). After this the virtual machine has crashed 0 times and I have been using it a whole day! I have Nvidia display adapter with the latest Win 8.1 x64 drivers installed to host machine. I think Nvidia drivers has something to do with this vm crashing, maybe..

           

          I started to suspect Nvidia display driver after seeing this nvd3dumpx.dll shows up multiple times in logfile (this is from VMware Workstation logfile ater the crash):

           

          2013-10-07T18:14:03.625+03:00| vthread-14| I120: backtrace[00] frame 0x1004ee48 IP 0x7ff8c64db9af params 0 0x1 0 0 ??? [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x006da9af]

          2013-10-07T18:14:03.626+03:00| vthread-14| I120: backtrace[01] frame 0x1004eea0 IP 0x7ff8c655ee5c params 0xf2c680 0 0 0x116d5ee0 ??? [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x0075de5c]

          2013-10-07T18:14:03.627+03:00| vthread-14| I120: backtrace[02] frame 0x1004f6c0 IP 0x7ff8c649c5f8 params 0 0x1 0x7ff800000000 0 ??? [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x0069b5f8]

          2013-10-07T18:14:03.627+03:00| vthread-14| I120: backtrace[03] frame 0x1004f6f0 IP 0x7ff8c649860d params 0 0xf2f280 0 0 ??? [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x0069760d]

          2013-10-07T18:14:03.628+03:00| vthread-14| I120: backtrace[04] frame 0x1004f720 IP 0x7ff8c64b7f43 params 0 0xf2f280 0 0 ??? [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x006b6f43]

          2013-10-07T18:14:03.628+03:00| vthread-14| I120: backtrace[05] frame 0x1004f750 IP 0x7ff8c673c2cf params 0x7ff800000000 0 0 0 QueryOglResource + 0x1d5c2f [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x0093b2cf]

          2013-10-07T18:14:03.628+03:00| vthread-14| I120: backtrace[06] frame 0x1004f780 IP 0x7ff8c673c51a params 0 0 0 0 QueryOglResource + 0x1d5e7a [C:\Windows\SYSTEM32\nvd3dumx.dll base 0x7ff8c5e00000 0x0001:0x0093b51a]

          2013-10-07T18:14:03.630+03:00| vthread-14| I120: backtrace[07] frame 0x1004f788 IP 0x7ff8df941611 params 0 0 0 0 BaseThreadInitThunk + 0x000d [C:\Windows\system32\KERNEL32.DLL base 0x7ff8df940000 0x0001:0x00000611]

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: backtrace[08] frame 0x1004f7b8 IP 0x7ff8e08664ad params 0 0 0 0 RtlUserThreadStart + 0x001d [C:\Windows\SYSTEM32\ntdll.dll base 0x7ff8e07f0000 0x0001:0x000754ad]

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: Msg_Post: Error

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: [msg.log.error.unrecoverable] VMware Workstation unrecoverable error: (vthread-14)

          2013-10-07T18:14:03.633+03:00| vthread-14| I120+ Exception 0xc0000005 (access violation) has occurred.

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: [msg.panic.haveLog] A log file is available in "F:\VMware\Virtual Machines\vmware.log". 

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: [msg.panic.requestSupport.withoutLog] You can request support. 

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: [msg.panic.requestSupport.vmSupport.windowsOrLinux]

          2013-10-07T18:14:03.633+03:00| vthread-14| I120+ To collect data to submit to VMware support, choose "Collect Support Data" from the Help menu.

          2013-10-07T18:14:03.633+03:00| vthread-14| I120+ You can also run the "vm-support" script in the Workstation folder directly.

          2013-10-07T18:14:03.633+03:00| vthread-14| I120: [msg.panic.response] We will respond on the basis of your support entitlement.

          • 3. Re: VMware Workstation unrecoverable error
            MichelleMae Lurker

            Demuz:

             

            I too have been getting this same error message and am very happy I came about this possible fix.

             

            The setting for 'Accelerated 3D Graphics" is greyed out and I can't change it.  Do you know what I should do?

             

            Are still having any issues with this error message?

            • 4. Re: VMware Workstation unrecoverable error
              markzvilius Lurker

              Thank you, unchecking "Accelerate 3D Graphics" seems to have resolved my problem with similar symptoms.

               

              Mark Z.

              • 5. Re: VMware Workstation unrecoverable error
                G.T. Novice

                I had this issue a few times with VMWare Workstation 10.0.1, NVidia GTX 670, SSD Drive, It was happening when I was compiling code in a VM stored inside the SSD, I tried all possible way to resolve it, updated drivers, etc, spent a month then give up

                Switch to HyperV, missing the accelerated graphics but everything else is much better.

                • 6. Re: VMware Workstation unrecoverable error
                  RobDellSC Lurker

                  I ran into a similar error to yours however I managed to replicate the problem using a different configuration. I figured I would post about it just in case someone else is running into a similar issue and is wondering.

                   

                  My VM is using VMware Player 6.0.2 with Windows 7. I recently upgraded my office to 2013 from 2010. This must have changed how the graphics acceleration makes calls to the Nvidia graphics libraries because my machine began to crash every time I would use Office. The error was the following:

                   

                  error.jpg

                  unrecoverable error: (vthread-16)

                  Exception 0xc0000005 (access violation)

                   

                  Changing to a non accelerated version of the VM as per the resolution on this thread seemed to work. Also, I rolled back the VM from a backup to the version pre Office 2013 install and it worked properly again. My hunch is Windows 8 or Office 2013 trigger calls to routines in the nvidia graphics drivers that Office 2010 and Windows 7 don't touch. Those calls must conflict with the rendering calls in VMware and BAM you get a crash. Would be really interested to know if anyone else is running Windows 8 and/or Office 2013 successfully in VMplayer and on specifically on what version of the nvidia graphics drivers.

                   

                  Hopefully VMware or Nvidia will fix this issue. I was about to purchase VMware Workstation 10 just so I could have some support to attempt to feedback the problem into VMware but alas I have to purchase 10 copies of the software to buy a support contract. Yep... not going to happen for my home office.

                  • 7. Re: VMware Workstation unrecoverable error
                    edgarcb Lurker

                    I resolved my problem totally with this answer, i was using windows 7 Ent x64 in the guest and a nvidia GTX670 on my host( which is enough problematic by itself). The problems began when I updated my office 2010 to office 365.

                    Thank you.

                    • 8. Re: VMware Workstation unrecoverable error
                      zaphod2 Novice

                      Hello,

                       

                      unfortunately there is no more Win7 "Aero Design" after disabling Accelerated Graphics.

                       

                      Has anybody found a nvidia Driver which works?

                      (Quadro FX880m)

                       

                      Yours

                      • 9. Re: VMware Workstation unrecoverable error
                        zaphod2 Novice

                        For the HP 8540w a very old Nvidia Driver Version helped: 189.33

                        • 10. Re: VMware Workstation unrecoverable error
                          QLee Lurker

                          it seems to be fixed on nvidia 340.43 beta driver, ran for a whole day without any problem

                          • 11. Re: VMware Workstation unrecoverable error
                            G.T. Novice

                            I will install the r 340.43 right now, I went back to VMWare and it crashed again today I hope the new driver resolves it

                            • 12. Re: VMware Workstation unrecoverable error
                              G.T. Novice

                              The issue just happened again with R 340.43 beta, the driver did not resolve it.

                               

                              I am not sure why VMWare is taking a year to look in to this defect, and it is still not resolved.

                              • 13. Re: VMware Workstation unrecoverable error
                                TimothyHuckabay Novice

                                I am also experiencing this same access violation within a Windows 7 Ultimate 64-bit VM under Workstation 10.0.3.  For me, it occurred when I tried to open an Excel spreadsheet right after installing and activating MS Office 2013 Professional inside the VM.  On my host system, which is also running Windows 7 Ultimate 64-bit, I likewise have "Accelerate 3D graphics" enalbed, and my host system also has nVidia graphics, though I am running nVidia's latest driver (i.e., 340.52).  Rather than disabling 3D acceleration to try to resolve this, I am switching to Office 2010 Professional.  VMware needs to test and correct this scenario, working with Microsoft and nVidia as necessary; it is completely unacceptable to me as a VMware products user to ever have my VM crash like this; moreover, I've been using VMWare Workstation since the release of version 2, and this is the first time I've encountered such a crash.

                                • 14. Re: VMware Workstation unrecoverable error
                                  scottymojoe Lurker

                                  I too have this issue. I know it is VMware + Office 2013 + NVidia as it only happens when I run Office 2013 on multi monitors. Multi monitors forces the laptop to use the NVidia GPU. When using a single monitor, the Intel GPU is used and no crashes occur. Disabling 3D acceleration does indeed fix the issue, however this is not a solution for me. I believe I found a better solution - disable hardware acceleration inside Office:

                                   

                                  http://www.askvg.com/disable-hardware-graphics-acceleration-and-fix-blurred-font-and-cursor-hanging-problems-in-microsoft-office-2013/

                                   

                                  This post addresses a different but related issue, and I've been running now for a couple hours and  no crashes.

                                  1 2 Previous Next