2 Replies Latest reply on Jun 10, 2013 1:07 AM by StuartB201110141

    Agent error 301 problems

    StuartB201110141 Novice

      Hi  Everyone,

       

      I am hoping someone can help me. I am experimenting with VCAC 5.1 and have setup everyone on one large VM without HTTPS.

       

      When I come to installing the agents I have been hitting the same problem for a couple of days.   I am trying to get it to talk to my Vcenter. On the endpoint I have made sure the format is vcenter.domain/sdk as well. Below is a copy of the agent log. I have made sure my URLs are correct and resolve in DNS, I have double checked everything and now just don't know where to look. Any help would be appreciated.

       

      [09/06/2013 15:31:37] [Info]: Process running in x64 mode

      [09/06/2013 15:31:37] [Info]: Created VRM Core Agent Service

      [09/06/2013 15:31:37] [Info]: Starting VRM Core Agent Service

      [09/06/2013 15:31:37] [Info]: Version: 5.1.1.56

      [09/06/2013 15:31:37] [Info]: Retrieving VRMCommunication Definition

      [09/06/2013 15:31:37] [Info]: VRMCommunication : DynamicOps.Vrm.Agent.Core.Communication.VRMCommunication

      [09/06/2013 15:31:37] [Info]: Retrieving WorkitemCache Type Definition

      [09/06/2013 15:31:37] [Info]: WorkitemCache Type : DynamicOps.Vrm.Agent.Common.Utils.WorkitemSerializer

      [09/06/2013 15:31:37] [Debug]: Retrieving Agent Type Definition

      [09/06/2013 15:31:37] [Debug]: Agent Type : DynamicOps.Vrm.Agent.vSphere.VSphereAgentService

      [09/06/2013 15:31:37] [Info]: Checking Agent Configuration Sanity

      [09/06/2013 15:31:37] [Info]: VRM AgentName: Vcenter1

      [09/06/2013 15:31:37] [Info]: VRM Url: http://localhost/VMPS2

      [09/06/2013 15:31:37] [Info]: Workitem CacheFile: C:\Program Files (x86)\DynamicOps\DCAC Agents\Vcenter1\temp\WorkItems.bin

      [09/06/2013 15:31:37] [Info]: Workitem Max Threads: 10

      [09/06/2013 15:31:37] [Info]: Workitem Thread Interval: 00:00:15

      [09/06/2013 15:31:37] [Info]: Workitem Retrieval Count: 3

      [09/06/2013 15:31:37] [Info]: PingTimer Interval: 00:01:00

      [09/06/2013 15:31:37] [Info]: StateTimer Interval: 01:00:00

      [09/06/2013 15:31:37] [Info]: Active Queue Size: 10

      [09/06/2013 15:31:37] [Info]: TES disabled

      [09/06/2013 15:31:37] [Info]: Starting WorkItemService

      [09/06/2013 15:31:37] [Debug]: Started WorkItemService

      [09/06/2013 15:31:37] [Info]: Starting CheckTargetAliveService

      [09/06/2013 15:31:37] [Debug]: Started CheckTargetAliveService

      [09/06/2013 15:31:37] [Info]: Starting HostStateReportService

      [09/06/2013 15:31:37] [Info]: HostStateReportService has been disabled in the configuration!

      [09/06/2013 15:31:37] [Info]: Starting PingService

      [09/06/2013 15:31:37] [Debug]: Started PingService

      [09/06/2013 15:32:37] [Debug]:     Starting Ping Report

      [09/06/2013 15:32:37] [Info]: Connecting to VC using endpoint Vcenter1 with user name test\administrator.

      [09/06/2013 15:32:39] [Debug]: This exception was caught:

      System.Net.WebException: The request failed with the error message:

      --

      <HTML><BODY><H1>301 Moved Permanently</H1></BODY></HTML>

      --.

         at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

         at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

         at VMware.vSphere.VimService.RetrieveServiceContent(ManagedObjectReference _this)

         at DynamicOps.Vrm.Agent.vSphere.VSphereSession.Connect(String username, String password) in c:\Builds\62\VRM\Mesopotamia-Babylon-release-build\Source\src\legacy\agents\DynamicOps.Vrm.Agent.vSphere\VSphereSession.cs:line 121

         at DynamicOps.Vrm.Agent.vSphere.VSphereHypervisorServiceProvider.GetComputeResources(ManagementEndpoint managementEndpoint) in c:\Builds\62\VRM\Mesopotamia-Babylon-release-build\Source\src\legacy\agents\DynamicOps.Vrm.Agent.vSphere\VSphereHypervisorServiceProvider.cs:line 789

         at DynamicOps.Vrm.Agent.vSphere.VSphereAgentService.GetHostClusterList() in c:\Builds\62\VRM\Mesopotamia-Babylon-release-build\Source\src\legacy\agents\DynamicOps.Vrm.Agent.vSphere\VSphereAgentService.cs:line 547

         at DynamicOps.Vrm.Agent.Core.VRMCoreAgent.SendPingReport() in c:\Builds\62\VRM\Mesopotamia-Babylon-release-build\Source\src\legacy\agents\DynamicOps.Vrm.Agent.Core\VRMCoreAgent.cs:line 102

         at DynamicOps.Vrm.Agent.Core.CoreAgentBase.SendPingReportLoop(Object sender, ElapsedEventArgs e) in c:\Builds\62\VRM\Mesopotamia-Babylon-release-build\Source\src\legacy\agents\DynamicOps.Vrm.Agent.Core\CoreAgentBase.cs:line 872

      [09/06/2013 15:32:39] [Error]: <?xml version="1.0" encoding="utf-16"?>

      <boolean>false</boolean>