4 Replies Latest reply: Jun 27, 2013 11:28 PM by HenriG RSS

    MSI Failed Problem - Again!

    mfelker Expert

      I guess there's a first time for everything so I findally ran into the MSI failed error on Windows 8.

       

      Not sure whether the installation log hs been uploaded but I'm attaching it (zipped of course!).  If anybody (problem from VMware I guess can make heads or tails of it I'd app[reciate it.

       

      Naturally I executed the exe as an adiminstrator and I am an adiministrator myself.  To search Google for solutions to this problem would lead to hundreds of hits I'm sure.

        • 1. Re: MSI Failed Problem - Again!
          mfelker Expert

          Replying to myself here because I can find the usual "edit" option for some reason.  Install the TP failed the same way.   I post the total of the vmsetup log in which the string error (ERROR) occurs.  If VMwar ewants the whole thing let me know.

          ---------------------------------------------------------------------------------------

          20130525030640:ERROR** CBootstrapCmd::RunOperation: Operation 'InstallMSI' failed!

          20130525030640:INFO    wWinMain:Checking exceptions [26]

          20130525030640:INFO    wWinMain:Handle error

          20130525030640:INFO    HandleError: Handling error: [26] lang [1033]

          20130525030640:ERROR** HandleError: Encountered fatal error id: 26

          20130525030640:ERROR** HandleError:   Message: [The MSI 'c:\temp\vmware_1369465478\vmwareworkstation_x64.msi' failed.]

          20130525030640:ERROR** DisplayErrorMain: Displaying error message

          20130525030640:ERROR** DisplayError  Error [The MSI 'c:\temp\vmware_1369465478\vmwareworkstation_x64.msi' failed.]

          20130525030640:ERROR** ================================================================================

          20130525030640:ERROR**   Rolling Back - ops:31

          20130525030640:ERROR** --------------------------------------------------------------------------------

          ---------------------------------------------------------------------------------------------

          Now I'm not a enginner for VMware but from the above it appears they don't know the reason for the failure themselves (unless perhaps somebody knows what fatal error id:26 means!).  I hope I'm wrong though.

           

          I'll installVirtualbox and then enable Hyper-V or whatever.  Basically I just will use WS on Linux

          • 2. Re: MSI Failed Problem - Again!
            WoodyZ Guru

            mfelker wrote: Replying to myself here because I can find the usual "edit" option for some reason.

             

            To edit the OP select Edit from under Actions on the top right side of the OP as shown in the image below with the big red arrow pointing to Edit.

             

            For subsequent replies the Edit link is at the near center bottom edge of the of the reply

            Actions_Edit.png

            Install the TP failed the same way.

             

            If this issue is with the VMware Workstation Technology Preview then you should be posting it in the VMware Workstation Technology Preview 2013 Community not here.

            • 3. Re: MSI Failed Problem - Again!
              mfelker Expert

              OK.  I see it now.  Thanks

               

              Unfortunately for the "MSI failed" problem no editing seems to help

              • 4. Re: MSI Failed Problem - Again!
                HenriG Lurker

                I too had some fun trying to install VMWare Workstation and VMWare Player on Win8. 

                 

                I ran into the same problem, and then came across this:

                 

                Understanding Error 1603: Fatal Error During Installation | Symantec Connect Community

                 

                The first thing I tried was to enable 8dot3 file name length (as specified in the article), and the install worked.