1 2 3 4 Previous Next 59 Replies Latest reply on Jun 29, 2015 12:01 PM by wila Go to original post
      • 45. Re: clipboard syncing erratically doesn't work
        beej666 Novice

        hi harry,

         

        thanks for your reply.  were you able to reproduce the issue in older versions?

         

        does internal ticket 1079086 say the issue has been fixed in Fusion 6.0.4?

         

        i don't have a license for Fusion 6, so it isn't easy for me to test it.

         

        cheers,

        marc

        • 46. Re: clipboard syncing erratically doesn't work
          wila Guru
          vExpertCommunity WarriorsUser Moderators

          Hi Marc,

           

          Not fixed.

           

          I run Fusion 6.0.4 down here and the clipboard problem is still there when running multiple Full Screen VMs.

          If you swipe to the other VM and use CTRL+V to paste you get the previous contents of the clipboard

          If you CLICK into the other VM before pasting then the contents is correct.

          As a result I pretty much ALWAYS end up pasting the wrong value, undo then paste the correct data.

           

          From the looks of it, the difference is that in the first case the VM actually does not have the focus, OS X has the focus and the new contents is only synced upon the VM getting the focus. One would expect the clipboard to get the new value on exiting the old VM not on arrival.

          --

          Wil

          | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
          | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
          | More info at https://www.vimalin.com
          | Twitter @wilva
          | VMware Wiki at http://www.vi-toolkit.com
          • 47. Re: clipboard syncing erratically doesn't work
            hyan Enthusiast
            VMware Employees

            Hi Marc,

             

            Yes, I was able to reproduce this issue with older version, and I tired Fuion 6.0.4 according to Wil's comments today, also reproduced. Sorry for confusing you.

            From the ticket 1079086, I don't see any code change was submitted, but our developers are still resolving it and the date of "fix by" is next release day. So, if all goes well, you will see the change in the next version.

             

            BTW, Thanks Wil~!

             

            Harry

            • 48. Re: clipboard syncing erratically doesn't work
              wila Guru
              vExpertUser ModeratorsCommunity Warriors

              Hello hyan,

               

              You're most welcome.

              Reliably reproducing a problem is the critical first step in being able to solve it.

              Glad to hear my steps were sufficient for that.

               

              --

              Wil

              | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
              | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
              | More info at https://www.vimalin.com
              | Twitter @wilva
              | VMware Wiki at http://www.vi-toolkit.com
              • 49. Re: clipboard syncing erratically doesn't work
                beej666 Novice

                hi hyan,

                 

                i see that Fusion 7 has been released.  does it include a fix for this issue?

                 

                thanks,

                marc

                • 50. Re: clipboard syncing erratically doesn't work
                  wila Guru
                  User ModeratorsvExpertCommunity Warriors

                  I'm not hyan but using copy & paste down here between VMs when using Fusion 7 I still see this happening so I'd wager to say "not fixed".

                  However I sometimes also see it behave properly, it certainly appears to be less erratic as in Fusion 6, seems that it works OK now about half the times.

                  --

                  Wil

                  | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                  | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                  | More info at https://www.vimalin.com
                  | Twitter @wilva
                  | VMware Wiki at http://www.vi-toolkit.com
                  • 51. Re: clipboard syncing erratically doesn't work
                    hyan Enthusiast
                    VMware Employees

                    Hi beej666,

                     

                    Sorry for late reply, I've still not gotten this progress from developers, but I will keep tracking this issue, and reply you if it was fixed.

                    But, just like Wila said, this issue is lower priority, so maybe developers defer it to future release.

                     

                    Harry

                    • 52. Re: clipboard syncing erratically doesn't work
                      beej666 Novice

                      hi harry,

                       

                      i appreciate you getting back to me, but  you have to understand how insanely frustrating this is from my perspective.  you're my only contact at vmware and you can't seem to get the answers i crave.  perhaps you'd be willing to get your manager to contact me?

                       

                      thanks!

                      marc

                      • 53. Re: clipboard syncing erratically doesn't work
                        JessieZhang Enthusiast
                        VMware Employees

                        Hi beej666,

                         

                        I know this clipboard out of sync issue have been bothering you and other customers for quite a long time and would like to thank your for keep staying with Fusion. With the information provided by you and other customers on this thread, we just found a reliable way to reproduce this issue, while the VM is in unity mode, copying text from host application to guest OS application for a couple of times causes the clipboard content out of sync between host and VM. Please confirm if that are the operations you did when you found the copy paste between host and guest stops working.

                         

                        We already provided the reproduction steps to our development team and believe that the reliable reproduction steps can make it easier for development team to debug the issue and speed up the solution of it.

                         

                        We will keep you updated once there is any progress.

                         

                         

                        Thanks for your patience

                        • 54. Re: clipboard syncing erratically doesn't work
                          beej666 Novice

                          hi jessie,

                           

                          are you harry's manager?

                           

                          in either case, thanks for taking the time to reply.  i'm a quite confused by your "we just found a reliable way to reproduce this issue" comment.  on 9/16/13, a former vmware engineer, steve hartwell, wrote "we've finally been able to reproduce your issue" and i was under the impression that this was actively being worked and tracked under internal ticket 1079086.  are you trying to start from scratch or have you already taken a look at that ticket?

                           

                          anyway, i see the problem regularly in Single Window mode.  the symptoms are that if i switch to the VM from another OSX app via keyboard shutcut and immediately paste, i get stale clipboard contents.  if i do any keyboard input after switching to the VM before pasting and wait a little, i'll get the correct keyboard contents.

                           

                          at this point, i think the most fruitful course of action would be to have a conversation with the product manager in charge of prioritizing bugfixes.  is that something you can facilitate?

                           

                          thanks,

                          marc

                          • 55. Re: clipboard syncing erratically doesn't work
                            beej666 Novice

                            just an update for the peanut gallery:

                             

                            i've been in touch with Fusion tech support and the update i received today is that it is known that this issue (internal ticket 1079086) is still unfixed in Fusion 7.1.0 and it is actively being worked on.  i asked why it wasn't listed in the Known Issues section at VMware Fusion 7 and VMware Fusion 7 Professional Release Notes and was told it would be going forward.  believe it when you see it

                            • 56. Re: clipboard syncing erratically doesn't work
                              jmuheim Lurker

                              I'm having the very same problem with VMWare Fusion 7 and Windows XP Professional.

                               

                              It may in fact have something to do with Unity mode, as it seems to happen more often when it is activated, though not exclusively (I didn't read the full thread here, so maybe this is not news).

                              • 57. Re: clipboard syncing erratically doesn't work
                                beej666 Novice

                                of course this issue wasn't fixed in 7.1.1 and of course it wasn't mentioned in the Known Issues at VMware Fusion 7.1.1 Release Notes.

                                 

                                i just got off the phone with the tech support supervisor who made the promise that it would be listed in Known Issues going forward and he had no good reason for why it wasn't.  it is known that the fix for this problem hasn't been released and i was again promised that it would be released in the next version.  sounds familiar right?

                                 

                                now you all know what i know.

                                 

                                marc

                                1 person found this helpful
                                • 58. Re: clipboard syncing erratically doesn't work
                                  beej666 Novice

                                  dear peanut gallery,

                                   

                                  i'm now working with a new support supervisor who claims to attend regular meetings with the development team.  the latest from him is that this terribly annoying bug isn't planned to be fixed in Fusion 8 and they have no concrete plans to fix it beyond that.

                                   

                                  i'd be very appreciative if others experiencing this issue would let the company know how annoying it is to you in the hopes of their bumping the priority of the bug.

                                   

                                  once again, the internal ticket number is 1079086.

                                   

                                  please report back here with any new info.

                                   

                                  thanks!

                                  marc

                                  1 person found this helpful
                                  • 59. Re: clipboard syncing erratically doesn't work
                                    wila Guru
                                    Community WarriorsvExpertUser Moderators

                                    Hey Marc,

                                     

                                    Thanks for your persistence, I was sure that I had agreed with you on this issue in this thread, but when I read back to what I wrote here... I'm not finding that.

                                     

                                    In any case I bump into the exact same issue many times during a day. You can work around it, by using Ctrl+Z and then paste again, but it is quite annoying.

                                     

                                    As I currently also still have support, I have also filed a SR and referenced this thread.

                                     

                                    edit: The support engineer I spoke to on the phone mentioned to me that this bug is currently under active development. There's no statement on when it will be fixed (which is normal policy).

                                    --

                                    Wil

                                    | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                                    | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                                    | More info at https://www.vimalin.com
                                    | Twitter @wilva
                                    | VMware Wiki at http://www.vi-toolkit.com
                                    1 2 3 4 Previous Next