6 Replies Latest reply on Jul 10, 2015 8:47 AM by digidwain1

    10Gbe NICs

    mikekemp1234567 Novice

      Hi All,

      Just installed ESX5i on a DELL R320 with 10GbE PCI NIC connected to SFP+ switch.

      ESX has correctly picked the NIC and speeds 10000 full etc. but the VM's are showing 1GB and being connected to Intel(R) PRO/1000MT Network Connection.


      Should I be worried?  This is the first machine on the backbone so I can't test a physical transfer between machines at the moment.


        • 1. Re: 10Gbe NICs
          weinstein5 Guru

          Welcome to the COmmunity - What you are seeing is correct the virtual NIC currently will show up as a 1 GB within the guest OS - 

          • 2. Re: 10Gbe NICs
            mikekemp1234567 Novice

            Thanks David - that's put my mind at rest.

            • 3. Re: 10Gbe NICs
              Josh26 Master

              If you set your vNIC to the "vmxnet3" type, it will show as 10GbE to the guest OS.


              Note as above, this is just cosmetic though.

              • 4. Re: 10Gbe NICs
                mikekemp1234567 Novice

                Hi Josh,

                I can't find where to change this - can you let me know perhaps?

                Many thanks for your reply.


                • 5. Re: 10Gbe NICs
                  mikekemp1234567 Novice

                  I've sorted this now.

                  Many thanks for your help.

                  • 6. Re: 10Gbe NICs
                    digidwain1 Novice

                    I have this setup as a vmxnet3 nic but my througput NEVER reaches 1 gig on my 10 gig NIC - I have both Broadcom quad 10 GB Nics on some of my hosts and I have INTEL NICs on other hosts (10 gig)  NONE of my vmware hosts will go above 1/5 GB throughput.  I tried Jumbo frames, I tried turning off promiscous mode, I tried disabling TSO, I ensured I was running only IPV4, I tried reading through endless blog and q/a's about the subject - but VMWARE is strangely silent - and if anyone ever figured this out - they are not talking.  I can honestly say I am VERY frustrated.  I will open a support ticket to VMware on this issue but - I SHOULD be  able to find a definitive solution somewhere.  REALLY frustrating.  It shouldn't be rocket science to have quad 10 gig physical NICs and VMWNET3 vms that can actually perform at better than 1 gb speeds - prior to tweaking around, I wasnt even getting 100 meg!  a 300 gig test robocopy lasted nearly 4 hours!!!  It was actually SLOWER than my 1 GIG pre update test!


                    Really?  Is this drama necessary?   If vmware support gets an answer - POST IT SOMEWHERE!!!!!!!!!!   How hard is that?