2 Replies Latest reply on Apr 22, 2013 6:30 PM by Leica

    Promiscuous mode in VMware Fusion / Workstation

    Leica Novice

      I am currently running ESXi as a guest in VMware Fusion. It runs great surprisingly!

       

      Every time the guest (ESXi) is started a message pops up asking for my user password, saying that a guest is trying to monitor all network traffic.

       

      Is there a way to set up the networking so that promiscuous mode is always enabled? So that it doesn't ask for my password each time?

       

      Can you also set promiscuous mode in VMware Workstation? In ESXi it is possible and easy to do so... I am wondering how to do the same in Fusion/Workstation.

       

      Thanks.

        • 1. Re: Promiscuous mode in VMware Fusion / Workstation
          Champion

          Leica wrote:


          Is there a way to set up the networking so that promiscuous mode is always enabled? So that it doesn't ask for my password each time?

           

          A feature request for this was opened against Fusion in September 2010.  Unfortunately, it looks like it is still open.

           

          For the adventurous, it looks like there is a workaround here: VMware Fusion requires that you type your password.  <-- On startup.

           

          Disclaimer: I think I have seen a Mac somewhere, once...maybe.

          Can you also set promiscuous mode in VMware Workstation? In ESXi it is possible and easy to do so... I am wondering how to do the same in Fusion/Workstation.

          Workstation on Windows allows promiscuous mode without batting an eyelash.  Workstation on Linux can be configured to allow promiscuous mode per the instructions in http://kb.vmware.com/kb/287.

          • 2. Re: Promiscuous mode in VMware Fusion / Workstation
            Leica Novice

            Thanks for answering my question. Shame that Fusion doesn't have that feature yet.

             

            And yes it seems in Workstation for PC promiscuous mode is permanently switched on. And that there is no way to switch it off! I wonder how this effects security?

             

            Surely both Fusion and Workstation should have a feature, like ESXi to enable or disable it.

             

            Thanks again.

             

            P.S. Thanks for the link about the “fix”. When I feel adventurous I will give it a shot!