1 2 3 45 Previous Next 666 Replies Latest reply: Oct 29, 2013 3:29 PM by Mike_Laverick Branched to a new discussion. RSS

Ultimate Deployment Appliance

VMTN Admin Master VMware Employees
Currently Being Moderated

http://www.vmware.com/vmtn/appliances/directory/232

 

Deploy your favorite OS by pressing F12, bring your own ISO's, we'll do the rest

  • 1. Re: Ultimate Deployment Appliance
    Brompot Lurker
    Currently Being Moderated

    Truely excelent appliance. We deploy too few to set up our own server, but enough that this saves us bunches of time.

  • 2. Re: Ultimate Deployment Appliance
    _the_dude_ Enthusiast
    Currently Being Moderated

    I currently have the following OS's working in my development appliance:

     

    \* Ubuntu Linux 6.06 LTS

    \* Suse Linux 10.1

    \* Solaris 10 x86

    \* BartPE (Live CD over PXE)

    \* Damn Small Linux (Live CD over PXE)

     

    I'll be making a new web-interface script (uda.pl) available soon... (or maybe a little later )

     

    Message was edited by:

            thedude_

     

    Message was edited by:

            thedude_

  • 3. Re: Ultimate Deployment Appliance
    felipel Lurker
    Currently Being Moderated

    useful to play around with...but is it going to be useful in the real world ?

  • 4. Re: Ultimate Deployment Appliance
    Frantic Novice
    Currently Being Moderated

    Hello !

     

    I'm still trying this appliance which seems to be very usefull, but when I try to make a remote windows 2000 professional installation, it doesn't work. It stops at blue screen "installing Windows 2000".

    And if I try a remote Windows XP professional, it says : "NTDETECT failed" and reboot.

     

    Can you help me please ?

     

    Thanks

  • 5. Re: Ultimate Deployment Appliance
    _the_dude_ Enthusiast
    Currently Being Moderated

    Windows 2000 problem

    \----


    \* Remote installs of windows are currently only tested in other virtual machines (this is due to the fact that the virtual machine network card is detected correctly) I'm still trying to find a good solution to make all drivers included with the windows distributions available throug the UDA.

     

    \* You can see what happens in the logfile of the tftp daemon. It is /var/log/messages

     

    \* Please make sure that the ISO file is mounted correctly and that it is accessible through samba from your host operating system.
    <UDA-IP-Address>\REMINST (when prompted for username and password try 'guest' with no password.

     

    Windows XP professional problem

    \----


    \* The NTDETECT fails is probably because the virtual machine tries to get the kernel files from a different location. Make sure the DHCP daemon is configured correctly for your network. (check /var/log/messages for DHCP logging) Also edit the configuration file of the template and make sure the IP adress mentioned in it (twice) is the IP adress of the UDA

     

    \* Also check the tftpd log (/var/log/messages) and the logfile of the binlserver (/var/log/binlsvr.log) (this service responds to requests about which network driver is needed for the network card ID of the client to setup.

     

    \* Make sure the template boot files are generated correctly

    ->  /var/public/tftproot/pxelinux.0

     

    Please feel free to ask more questions and report problems.

  • 6. Re: Ultimate Deployment Appliance
    _the_dude_ Enthusiast
    Currently Being Moderated

    Frantic: Any luck yet?

    By the way: The NTDETECT failed may also be because a (non-bootable) floppy or CDROM is still mounted in your virtual machine.

  • 7. Re: Ultimate Deployment Appliance
    Frantic Novice
    Currently Being Moderated

    Well I've just tried to install windows XP pro and 2000 pro but no way !

    I used the VM image as you leave it. I changed my network settings with an IP address like 10.0.0.x but it doesn't work with any OS.

    I disabled every devices except HDD and Network card, but I've got the same results.

    Well I don't know what to do ... It seems like network doesn't work (no activities when I look at the VM icon). However, the DHCP works fine. I tried with a "real" computer and I've got the same result.

     

    I was looking at /var/log/messages but there are no errors.

     

    Maybe I'm cursed !? lol

     

    Can it be because I used French versions ?! Well I think not ....

     

    Message was edited by:

            Frantic

  • 8. Re: Ultimate Deployment Appliance
    _the_dude_ Enthusiast
    Currently Being Moderated

    \

    • If you don't see any error mesages please try adding -v -v -v to the program parameters in the /etc/init.d/tftpd file and restarting (/etc/init.d/tftpd restart)

     

    Please check the following things:

    \* /etc/dhcp.conf has the correct (UDA) ip address in it

    \* /etc/tftpd.map exists and tftpd is running (ps -ef | grep tftp)

    \* /etc/devlist.cache exists and binl is running ( ps -ef | grep binl)

    \* /etc/sysconfig/network-scripts/ifcfg-eth0 has the correct ip address in it and the interface is up (ifconfig -a)

    \* /var/public/tftproot/WINXP exisits and the iso file is mounted there (see if the /var/public/tftproot/WINXP/i386 directory exits and try to copy a file or two to your /tmp directory.)

    \* See if you can access this directory though samba (net use *
    .sif is downloaded (winnt.sif)

    The sif file is where all the settings are (make sure that the ipadresses mentioned are the UDA ip adress)

     

    Message was edited by:

            thedude_

  • 9. Re: Ultimate Deployment Appliance
    pulse Novice
    Currently Being Moderated

    Hi there,

     

    I'm trying to deploy Win XP Pro to a laptop with no cdrom drive or fdd. Toshiba, in all their wisdom, replaced my HD and handed it back blank and I can't be bothered taking it back.

     

    Soooo..

     

    I've not changed any default settings. I've set my windows server PC to have an IP of 10.0.0.10/255.0.0.0.

     

    I've logged into the web interface as admin.

     

    I've added my mount point, 10.0.0.10/winxp

    I've clicked mount, and it's successfully mounted

     

    I click on OS

    I click configure next to 'winxp'

    It comes up with share name 'winxp'

    The ISO drop down is always blank, but if I look at /var/public/smbmount/winxp on the console, sure enough the drive is mounted and the ISO, winxp.iso is clearly in there. I have full write permissions (verified by 'touch').

     

    I think "stuff it", and mount the ISO by hand -

    mount -t iso9660 -o loop /var/public/smbmount/winxp/winxp.iso /var/public/tftproot/WINXP

    It successfully mounts.

     

    I save everything, and boot the laptop. It comes up with:

     

    For help press

     

    Current Templates:

     

      ID     Description

    ---------


    +

    winxp Windows XP

    boot:

     

    I type in 'winxp' - get back "Could not find kernel image: winxp"

    I type in 'WINXP' - get back "Invalid or corrupt kernel image."

     

    I'm stuck. Any advice you can give me please? Is this because I manually mounted the ISO? Why can't it see the ISO listed?

     

    Any help you can give me is appreciated, I REALLY want to get this laptop working again..

     

    Thanks

    -p

  • 10. Re: Ultimate Deployment Appliance
    pulse Novice
    Currently Being Moderated

    Also, when creating the template, it gives me:

     

    Creating Template WINXP (xp33453) of type winxp

    Checking template WINXP id length

    OK

    Creating STARTROM

    ERROR

     

    Adding the template to the templatelist

    OK

    Writing tftp welcome screen

    OK

     

    \-- /var/public/tftproot doesn't have any \** files.. Any help you can give is greatly appreciated.

  • 11. Re: Ultimate Deployment Appliance
    _the_dude_ Enthusiast
    Currently Being Moderated

    Hi pulse,

     

    First of all: the version that was release initially doesn't support another physical machine (read: your laptop) since it can handle only VMware specific network cards. The good news is: I think I have a working version at home that will support other NIC's as well. As soon as I've tested it I will release it... (I hope before august 1st)

     

    Now for you specific problem:

    I think I've had the same problem some time ago, and this is due to a bug in the script. It shows all but one iso file in the shared directory. (and since you probably you only have one iso file in that directory, it shows none) You can test it the following way: touch a new file bogus.iso in the shared directory.

     

    When you now go to the configure option again, you should see one iso file (since you now have two). you will probably see the winxp.iso file in there now... (if you see only the bogus.iso try making a second copy of your winxp.iso file in the same directory (with a different name of course), it will show you at least one then...)

     

    If this works for you you can go ahead and fix the script:

    /var/public/cgi-bin/uda.pl

    Search for the word javascript

    A few lines below it it reads:

     

    for ($i=0;$i<$#allisos;$i++)

     

    change it to (insert an '=' symbol)

     

    for ($i=0;$i<=$#allisos;$i++)

     

    When the configure option has run successfully (it mounts the iso and imports the generic bootfiles for winxp), the create template (copying and modifying the bootfiles slightly for the template you create) will also run better...

     

    Good luck and let me know if it worked!

  • 12. Re: Ultimate Deployment Appliance
    pulse Novice
    Currently Being Moderated

    Hi again,

     

    Thanks for the prompt reply. Unfortunately, this hasn't worked.

     

    I tried duplicating the ISO in the directory, which I can see via console (ie 2 ISOs) but it still doesn't pick any of them up. I had a look in the uda.pl script, and the line already had an '=' in it, so I take it this is a sufficiently late enough version of UDA to have had this bug fixed? I downloaded it 2 nights ago.

     

    So unfortunately, I'm still stuck Any more thoughts?

     

    Thanks for your help

    -p

  • 13. Re: Ultimate Deployment Appliance
    pulse Novice
    Currently Being Moderated

    I tried cutting out the middle man, I edited /var/public/conf/os.conf to include my ISO filename manually. It showed it in the OS screen, I clicked mount and it mounted successfully.

     

    Job done, I thought.

     

    Went to create a template, and got the same output as above, with startrom failing. It still hasn't created any template files.

     

    D'oh!

  • 14. Re: Ultimate Deployment Appliance
    Frantic Novice
    Currently Being Moderated

    Sorry I wasn't here these lasts days.

    I checked what you told me but everything is OK.

    I really don't know why it is not working ...

    But in the directory WINXP_EXTRA I don't have NTLDR just setupldr.ex_

1 2 3 45 Previous Next

More Like This

  • Retrieving data ...

Share This Page