8 Replies Latest reply on Sep 1, 2014 4:59 AM by Wh33ly

    .scexe on SSH toESX5i

    JustyC Enthusiast

      We are trying to update local disk firmware on a 5i host to recify a boot error message.  The server hardware is HP Proliant DL585.  There is a upgdate from HP called cp019264.scexe.  We are trying to run this using SSH.  We used WinSCP and copied the scexe to tmp on the host.  We logon as root, do a /cd and then ./cp019264.scexe.  We get a error message stating file not found.  DIR doesn't seem towork, but WINSCP shows the file is there.  This method was used with ESX 4.  Is there any other permissions we need to open up or a way to get this to run ?  Thanks.

        • 1. Re: .scexe on SSH toESX5i
          JWinSC Lurker

          For what its worth I'm having the same issue.

          Before running chmod 777 against the file in question I did get Permission denied.

          After granting permission I get the "not found" error.

           

          HP has been stumped why this is.

          • 2. Re: .scexe on SSH toESX5i
            Josh26 Master

            You shouldn't expect that a Linux application will run from the ESXi technical support mode. HP should have been able to point this out. There's a reason SSH is disabled on ESXi. There's a reason you get a big warning alert on you server when you manually go and enable it.

             

            It's inconvenient, but the only method of doing such an update is to make a bootable CD using HP's Firmware maintenance CD. The Gen8 servers provided a much better method of doing such updates.

            • 3. Re: .scexe on SSH toESX5i
              JWinSC Lurker

              Other updates were successfully applied using this method (as directed by HP support, Level 1 & Level 2) - so it only stood to reason this would work as well.

               

              There are many functions only available via SSH to ESXi console (HP Array configuration) - more often than not going on site to boot to an HP SPP DVD is not feasible (yes, I understand that one COULD virtually mount an ISO as the boot media and remote in via iLO, Advanced)

              • 4. Re: .scexe on SSH toESX5i
                Josh26 Master

                HP support have directed me in the past to run Windows executables on Linux servers. Their advice is often incorrect.

                 

                I appreciate that using iLO and booting a DVD is cumbersome, but it is also the only appropriate solution here.

                • 5. Re: .scexe on SSH toESX5i
                  JamesMul Lurker

                  So far this worked for me .

                   

                  browse to location run the following it worked for me on smart array 400/i .cpxxxxx*scexe

                   

                  Enable SSH or Drop the file in VSHPERE using the Datastore browser

                   

                  or

                   

                  Copy over (winscp)scp to Datastore or /tmp
                  Browse to location

                   

                  e.g

                  cd /

                  cd tmp/

                  You will be denied until - you change the file permissions to executable.

                  /chmod +x cpXXXXX.scexe

                  /./cpXXXXXX.scexe

                  once completed reboot the host server

                  check the Download insight Manager and check the firmware smart array version information e.g 7.22

                   

                  Ref: HP MSA 2040 Controller GL101R001 Firmware Release Notes [pdf]

                   

                  Ref : Support mentioned - Esx 5 on page 4

                  Ref : How to on page 9

                  • 6. Re: .scexe on SSH toESX5i
                    squidward2001 Lurker

                    Hi JamesMul

                     

                    Thanks for your post this solved my problem perfectly. Saved me a long onsite trip!!!

                     

                    Many Thanks

                    • 7. Re: .scexe on SSH toESX5i
                      Craig_B Lurker

                      I ran into a similar problem. I used WINSCP to copy the file to /tmp and changed it to executable.  Running ./cpxxxxx.scexe failed with a :not found error.  Running sh ./cpxxxxxx.scexe ran the file OK.

                      • 8. Re: .scexe on SSH toESX5i
                        Wh33ly Hot Shot

                        I had the same problem as stated above:

                        1st = permission denied , used CHMOD to edit permissions

                        2nd = file not found error...

                         

                        Problem was that I downloaded the wrong scexe file (the one used for Linux), I downloaded the VMware version after that, that one worked flawless (after adding permissions of course)