5 Replies Latest reply on Nov 26, 2014 12:37 PM by n!md@

    VmomiError during ssolscli.cmd updateService

    firestartah Master
    vExpertCommunity Warriors



      I'm experiencing a very strange error when I run the ssolscli.cmd updateService command to bing the trusted SSL ceritifcate to my Secure Token Service. i run the command and get the following error:


      D:\Program Files\VMware\Infrastructure\SSOServer\ssolscli> ./ssolscli.cmd updateService -d https://xxxxxxxxxx:7444/lookupservice/sdk -u admin@System-Domain -p xxxxxxxx -si D:\certs\sts_id -ip D:\certs\sts.properties


      Intializing registration provider...
      Getting SSL certificates for https://xxxxxxxxxx:7444/lookupservice/sdk
      Getting SSL certificates for https://xxxxxxxxxxx:7444/sso-adminserver/sdk
      com.vmware.vim.vmomi.core.exception.MarshallException: com.ctc.wstx.exc.WstxIOException: Invalid null character in text
      to output
      Return code is: VmomiError


      The other two services are binded without an error and I have rechecked and recreated my sts.properties file numerous time and have tried to change the STSService to the ipaddress and still I get the error.


      My sts.properties file is:

      friendlyName=STS for Single Sign On
      description=The Security Token Service of the Single Sign On server.



      Has anyone experienced this before? If i run ssolscli.cmd listServices https://XXXXXXXX:7444/lookupservice/sdk it gives me all the correct information



        • 1. Re: VmomiError during ssolscli.cmd updateService
          firestartah Master
          vExpertCommunity Warriors

          I have a ticket open with VMware support around this error. Once I get a response I will update this and submit it for a kb if it warrants

          • 2. Re: VmomiError during ssolscli.cmd updateService
            anujtyagi Novice

            Hi Firestartah,


            Did you manage to fix this issue.


            I am seeing exactly the same error with my setup while replacing certificates.


            Kind Rgds,

            • 3. Re: VmomiError during ssolscli.cmd updateService
              n!md@ Lurker

              I see that there hasn't been any activity on this subject in a while but I am having the same issue and was wondering if anyone had found a solution. I too have a ticket open with support and they are not coming up with anything any kind of fast. I am hoping that firestarah will see this and remember what fixed the issue and post it here.

              • 4. Re: VmomiError during ssolscli.cmd updateService
                firestartah Master
                Community WarriorsvExpert



                A colleague found the solution:


                Got with the customer and tried to unregister services by changing the order of switches on the commands same error.  Cleared out the DelService file and put the ID back into it same error.

                Opened up a new admin command prompt, listed out the services again, marked the ID needed to be deleted ran a notepad c:\oldid.txt to create a new file and placed the service ID in that and ran the command and it worked.

                Tried another service using the old files bur renamed it to delservice.txt and got the error again.  Tried again, but renamed the file to delser.txt, error result.   Tried with another file the customer had  created called Del_Service.txt and got the error.

                Not sure what was with the formatting of the two files the customer was using, but just creating a new file and putting in the IDs resolved the issue."



                • 5. Re: VmomiError during ssolscli.cmd updateService
                  n!md@ Lurker



                  Thanks for posting that. Unfortunately that didn't work for me. I think my problems all started with not paying attention to the version of openssl that was installed with vCenter. I assumed it was the correct version, I made sure to use version 0.9.8 and followed the attached document that was given to me by a VMWare support tech, Craig J Becker. I walked through that document and it all worked. Thanks Gregg and Craig.