2 Replies Latest reply on Jan 28, 2013 4:57 AM by MarAndreas

    "The virtual machine is busy" error

    MarAndreas Hot Shot

      I've been getting this problem lately:

       

      When trying to start a VM, VMware Player just sits there, doing nothing; the VM does not boot.

      Trying to close the VMware Player window brings up the error message "The virtual machine is busy" - this error message can not be closed.

       

      Task Manager shows the vmplayer.exe process is using as much CPU as it can get, and the vmware-vmx process has not started.

      Killing the vmplayer process closes the windows, but does not solve the problem - trying to start the VM again has the same result as above.

      Killing both vmplayer and vmware-usbarbitrator64 does help, although the VM seems to boot slower than usual.

       

      Host is Windows 7 Ultimate 64bit

      Guest is Windows XP Professional SP3

      Player version is 5.0.1 build-894247

        • 1. Re: "The virtual machine is busy" error
          MarAndreas Hot Shot

          Oooohh.... kay....

          Unplugging all USB devices seems to work just as well as killing the usbarbitrator process.

          Tried if I could narrow it down to one specific USB device, and found that the situation is improved (but not quite fixed) by removing...

          ...an empty cable.

          • 2. Re: "The virtual machine is busy" error
            MarAndreas Hot Shot

            My probably last update on the issue:

            The problem does not occur when starting a VM from the library, instead of opening the vmx directly.

             

            Sometimes VMware Player will be "Not Responding" for a while, but eventually the Library shows up, and everything works fine from there.

             

            I believe the underlying cause is the same (and USB-related), but since this form of it is only occassionally annoying, I can live with it.