3 Replies Latest reply on Aug 18, 2019 4:27 AM by nokiahelp

    "No battery is detected" in Win7 Guest (Win8 host / DELL E6420)

    ColinWillies Lurker
      • Has anyone else seen this?
        • The "Report battery Information to guest" option is selected in the VM options for this VM.
        • Battery information is correctly displayed in same VM when move to a different Win 8 host on an older DELL D630.
        • This issue is reproduced reliably on several different VM's.
        • The latest available DELL chipset drivers are installed on both machines.
      • Does anyone have a solution / workaround?

       

      Tks

       

      Colin

        • 1. Re: "No battery is detected" in Win7 Guest (Win8 host / DELL E6420)
          ColinWillies Lurker

          Nothing like answering yourself as proof of early onset dementia... :-)

           

          This is now fixed this on my main VM and I will verify later today if the same fix has resolved for the others (I strongly suspect it has)...

           

          1. In the host machine I uninstalled all devices under batteries in device manager choosing not to reboot after each removal.
          2. I rebooted the host once.
          3. I ran VMWare player as admininstrator.
          4. I powered on the Windows 7 x64 guest.
          5. The battery information is now correctly reported in the guest.

           

          I will also check what happens if I restart the host and run VMWare Player as a normal user and report back here but I have work to take care of first...

           

          Note: Abhijeet Nadgouda from VMWare Support, while he did not have the solution at the time, provided an exemplary initial intake for this query and my commendation has been communicated to his management! :-)

          • 2. Re: "No battery is detected" in Win7 Guest (Win8 host / DELL E6420)
            ColinWillies Lurker

            Update:

            1. The issue returns after the the next reboot following the automatic reinstallation of the devices previously removed from batteries in device manager.
            2. There is no link between this issue and administrative privileges.
            3. This does not appear to be a pure VMWARE issue.
            4. Current workaround is to try and remember to remove the battery devices before each host reboot...
            5. I expect the next chipset driver update and / or BIOS update for the host hardware will resolve this - I will keep a look out for it and will report back here once it has been released and I have tested it...
            • 3. Re: "No battery is detected" in Win7 Guest (Win8 host / DELL E6420)
              nokiahelp Lurker

              I know I shouldn't reply a 6 years old post, but because it's the first and only result on google when searching for this problem, I'll make an exception

               

              I have the same problem as described, "No battery is detected" in Win7 all Guest (Win8.1 / DELL E6430), and after spending several days on trying to find a permanent solution I finally succeed:

               

              Some laptops (like E6420 and E6430) can use 3 battery at the same time: one in the usual battery slot, one in the DVD drive bay, and one in the docking port. This result in 3 battery detectable in Windows. Thus under the "Batteries" section in device manager there are 3 devices named "Microsoft ACPI-Compliant Control Method Battery", each one is related to one battery port, and because I only have one battery (showed as battery #1 in taskbar notification area), I logically disabled the last two "Microsoft ACPI-Compliant Control Method Battery" in device manager. The problem is now "solved"!

               

              However, I found that: Everything is working when on Win7 host (no need to tamper the device manager), but it's not the case on Win8.1 and Win10 hosts. I tested on clean install with VMware Workstation 15.1.0 and only 3 drivers (latest versions) installed: Intel MEC driver (chipset), Free Fall Data Protection (chipset / protect hdd from damage caused by drops), NVIDIA driver (display).

              Furthermore I have the latest BIOS version, and configured in legacy or UEFI mode doesn't change anything.

               

              I believe that the problem is related to Windows, but an option in VMware to choose which battery to report info could be a solution too.

               

              Hope this will help someone and sorry for the unearthing