8 Replies Latest reply on Nov 23, 2014 12:10 PM by Mageia_user

    Disable Workstation toolbar in Fullscreen mode

    WhiteKnight Hot Shot

      Pleeeeeease, can someone at VMware finally go and create an option to never show the Workstation toolbar in Fullscreen mode?

       

      This bloody toolbar is making me NUTS when working with maximized application windows in the guest!

       

      What is necessary for you to do me the favour of implementing this tiny little improvement? I've been requesting this since version 7.

       

      It shouldn't be more effort than just 10 lines of code worth (estimated). Just a configuration setting and an if-clause, skipping the scrolling-in of the toolbar - that's it!

       

      Please, make an effort and add this option to Workstation 9 with the next service release.

        • 1. Re: Disable Workstation toolbar in Fullscreen mode
          AlanaA Enthusiast

          Going to Edit -> Preferences -> Display and unchecking "Show toolbar edge when unpinned in full screen" doesn't work well for your requirements?

           

          On my Ubuntu 12.04 host, the toolbar doesn't show at all. Not even the usual sliver/edge. It doesn't pop out when I place the mouse at the top of the screen either.

          • 2. Re: Disable Workstation toolbar in Fullscreen mode
            WhiteKnight Hot Shot

            Nope, unfortunately it doesn't, as the following short video clip I made demonstrates:

             

             

             

             

            Whenever the mouse pointer reaches the upper corner of the screen, the hypervisor toolbar scrolls into the screen and inhibits working in the VM.

            • 3. Re: Disable Workstation toolbar in Fullscreen mode
              AlanaA Enthusiast

              That doesn't happen to me. It's as if the guest is completely isolated until I press Ctrl+Alt.

               

              Either it's a bug in the Linux version or a bug in the Windows version of Workstation. Too bad I don't know which scenario is intended by VMware. Good thing the way it works under Linux is what I want. I don't have any Windows hosts to test but I assume I'll experience the same thing as you.

              • 4. Re: Disable Workstation toolbar in Fullscreen mode
                WhiteKnight Hot Shot

                I just bought a new DELL Precision M6700, a notebook worth the price of a small car. Whenever the mouse pointer reaches the border of a VM screen, i.e. when the Workstation Toolbar drops down in Fullscreen mode, or when the mouse is automatically grabbed/ungrabbed in Windowed mode, the mouse pointer hangs for a second.

                 

                This is so utterly annoying !!!!!

                 

                Where can I report this and have a fix provided by VMware?

                • 5. Re: Disable Workstation toolbar in Fullscreen mode
                  AlanaA Enthusiast

                  This has been happening to me for the past few major version of Workstation. If I click any mouse button at the VM screen edge or move the mouse to any screen edge while a mouse button is held down, the mouse seems to hang and becomes unresponsive. This happens both in full screen and in windowed mode but only in Linux guests. Windows 7 guests seem to not have the mouse freeze/hang issue at least with an Ubuntu host.

                   

                  This is always reproducible. For example, in an Ubuntu guest, grab and drag a window around. When the mouse pointer hits a screen edge, the window stops getting dragged for about 1-3 seconds even though you're moving the mouse still. Same happens when highlighting text and the mouse touches a screen edge. Clicking an indicator icon at the screen edge shows the same issue too.

                   

                  I actually reported this during my 30 day support period with Workstation 10.0.1. All I got was that this is because of the mouse ungrab/grab event and is expected behavior and I should file a feature request to fix this "expected" behavior. I don't even know why there are ungrab events at the left, right and bottom screen edges while in full screen.

                   

                  Host:

                       64-Bit (X)Ubuntu 12.04.3 LTS

                  Guests:

                       64-Bit (X)Ubuntu 12.04.3 LTS

                       64-Bit (X)Ubuntu 13.10

                       64-Bit Windows 7 Pro

                  • 6. Re: Disable Workstation toolbar in Fullscreen mode
                    WhiteKnight Hot Shot

                    Well, if that's expected behaviour then it wasn't until WS 10.0.0... I've never before experienced this odd behaviour in any previous version of Workstation.

                    • 7. Re: Disable Workstation toolbar in Fullscreen mode
                      AlanaA Enthusiast

                      I didn't experience this on Windows hosts with Workstation 8 and 9 (it was only brief use though) but it existed on Linux hosts for a while. I guess VMware is working on feature (read: bug) parity between Linux and Windows hosts . I'm glad that they haven't brought the unable to make the toolbar completely disappear in full screen "feature" from Windows to Linux hosts.

                       

                      I felt the expected behavior reply from the support tech was mostly due to him just wanting to close out my support request and just directed me to submit a feature request. At least feature requests supposedly go directly to engineers.

                      • 8. Re: Disable Workstation toolbar in Fullscreen mode
                        Mageia_user Lurker

                        1) Enter Full Screen mode: Ctr+Alt+Enter (or go to View -> Full Screen);

                        2) Hit Ctrl+Alt (release control from the current VM);

                        3) In the top toolbar go to View -> Exclusive Mode and then push Enter Exclusive Mode.

                          (to release control form VM in Exclusive Mode hit Ctrl+Alt)