1 2 Previous Next 24 Replies Latest reply on Feb 15, 2014 3:30 PM by devzero

    vDP simply does not work

    SCX Enthusiast

      I have almost had it with this product (or at least this release).

      I did a very simple Backup of my VM, and tried to do a restore.  The VM is running Ubuntu (if that makes any difference)?, and its VMDK files are around 40GB total.

       

      So far, the  vmdk files of the "Restore" are 80GB+ and growing, with the restore progress meter at 92% and no signs of stopping.

       

      What use is a backup/restore product if you can't trust it?

       

      Off to log another support request...

        • 1. Re: vDP simply does not work
          LoneCrowe Novice

          Have to agree so far all sorts of problems.  Install didn't go right the first or second time, when I followed the directions explicitly etc.  Had to run the vdp-configure several times,  reboot server and it would ask to run it again.  Once I got it going it was fast in the initial backups that was for sure,  but now it uses 100Mbit of traffic while basically idle and not doing backups at all which is absurd.  Now I can't get into VDP at all via  very shoddy and slow web client. 

           

          I'm sure some of the features are much improved if I could get to actually use them.

           

          This was "as usual for Vmware" one step forward and 2 back.

          • 2. Re: vDP simply does not work
            danfowler Novice

            Hi SCX,

             

            I wanted to get a little more info from you, is your original VM that you have backed up and are trying to restore thin provisioned?  If so what is the provisioned size?

            • 3. Re: vDP simply does not work
              SCX Enthusiast

              Hi, yes, there are 2 disks, both thin provisioned, disk one (holding the OS) is 40GB, and disk two is 200GB

               

              I currently have an open support ticket about this.

              • 4. Re: vDP simply does not work
                SCX Enthusiast

                I am thinking that the appliance just does not work with thin provisioned disks.

                It's not an Operating System related issue - I'm having the same problem with Ubuntu and Windows 2008R2.

                • 5. Re: vDP simply does not work
                  futureauto Lurker

                  I don't have anything to add that will help (I literally just got my first backups to complete after a month of trying yesterday and haven't done a restore test yet), just an interesting side note about the 92% mark.  One thing I've learned about my own troublesome workings with VDP and vmware support is that the progress indicators don't know how to handle more than one virtual disk in either backups or restores.  The first virtual disk always seems to complete at 92% without additional updates when it starts working on the second disk.

                  • 6. Re: vDP simply does not work
                    FM-DK Enthusiast
                    vExpert

                    I join the choir:

                     

                    vDP simply does not work !

                     

                    Of all VMware products released the last 7 years, I think this is the worst. Even  vDR v. 1.0 was easier to get to work

                     

                    I have tried to get the 2 TB appliance to work and have read documentation, release notes, community forum and articles on the 'net. I ran into allmost all the problems mentioned: No special characters en vCenter, Datacenter or cluster name or everything will fail, W2KR8R2 backups does not work unless you tweak advanced settings, a silly thing like that you can not enter @ in notification email address unless you copy paste it in, logfiles is not in Windows-readable .zip-format, registration with vCenter fails with appliance no. 2 and so on

                     

                    But the worst is: It is impossible to vDP to take backup of several VM's several times in a row without problems. I have not been able to get a backupjob to run consistently at any time. I have a job with 10 VM's defined. Sometimes it will succceed with 2 VM's and fail with 8 (And no explaination given unless you travel through MB's of logfiles), sometimes it will backup 2 or 3 other VM's but never more than 4 successes.

                     

                    The hardware I am running this is on is allmost state-of-the-art, every bit on the compatability list and with tons of free ressources.

                     

                    I have now abandoned this piece of crap and implemented a very cheap 3rd party solution which works flawlessly.

                     

                    Regards

                    André

                    • 7. Re: vDP simply does not work
                      SCX Enthusiast

                      André, would you mind sharing with us what 3rd party solution you went for? I need to try something else at this point, but all I'm seeing is software that costs $$$. Veeam is good, but I don't like how you need to install "agents" all over the place, and it's overkill for our needs.

                      • 8. Re: vDP simply does not work
                        FM-DK Enthusiast
                        vExpert

                        Hi again

                         

                        Is it possible to send a PM in this system ? Else make a temporary emailaddress and publish it here and I will email the details.

                         

                        As a VMware consultant I am not allowed to advertise in this forum about 3rd party products. But I am allowed to email you personally

                         

                        Regards

                        André

                        • 9. Re: vDP simply does not work
                          SCX Enthusiast

                          Yes, just click on a person's username under their image, then click "Send Private Message" from the menu on the right.

                          • 10. Re: vDP simply does not work
                            LoneCrowe Novice

                            Send me the message too

                            • 11. Re: vDP simply does not work
                              freaky2000 Novice

                              I'm joining the choir singing "VDP sucks BIG time lalalala" too.

                               

                              Quite frequently many jobs are stalled at 92%. Some days (usually when nothing has been added for days) it finishes all jobs in less than 1.5 hours. My backup window has been increased to 12 hours now. Logging is horrible.

                               

                              Btw, 7-zip, which is free (7-zip.org) extracts the zips fine. Windows doesn't seem to be able to handle this ZIP variant (yes, ZIP does change over time - Windows frequently doesn't catch up tho'). No messages in vCenter though - why would it...

                               

                              Not to mention the horrible crap with the disk.enableUUID. But no worries, we figured out how to change all 50 VM's fast ourselves. Why would you publish that in your KB. It's much nicer to leave it to your customers to figure it out, or have them shutdown tons of VM's manually, switching the setting and powering them up again. After all, who doesn't add 80 hours of work to set shit right after an upgrade. Oh, did I say 80? I'm sorry, I'm neglecting the fact it has to be reversed again after the next fuck up, err update.

                               

                              It's quite obvious management is pushing stuff out to fast to compete with HyperV 3.0. Guess what... this misery just gets us there faster. Nice going.

                               

                              Btw, the manual mentions that when jobs hang on 92%, it's out of storage. I have 48% free on the 1.0TB VDP appliance (according to the reporting), which is far from 1.0TB btw (More like 1.6TB... 60% increase?? really?...) and it's thick provisioned. Then again, should I really trust the value reporting returns? Since hardly anything of the product is reliable, it's not very likely that part is.

                               

                              I'd really like to tune down the number of concurrent jobs. Anyone know if that's possible? On the odd occasion things do go right, it finishes a lot of jobs in 0.5-1.5 hours. If I can make it run only 2 or 4 jobs at once I suspect I'll have a lot less issues.

                              • 12. Re: vDP simply does not work
                                GECADMIN Lurker

                                Could anyone who got the PM regarding a cheap 3rd Party solution please pass it on.  I will take any recommendations - Thank You.

                                • 13. Re: vDP simply does not work
                                  SCX Enthusiast

                                  I have come to the conclusion that "cheap" and "3rd party solutions" are not compatibile. Fair enough, I don't mind paying for software as long as it works and is well supported. The number of hours I have wasted on vDP times my hourly rate is already well past the cost of buying good software in the first place.

                                   

                                  I have been looking at vmProtect 8 from Acronis, which is around $500 per CPU "socket". There are a few minor niggles, but so far, it seems to work well and is a heck of a lot faster that vdp, and uses far less resources. The install was an absolute joy compared to vDP, and It can also be installed as an appliance, which is nice.

                                  You can configure local or network disks for backup storage (none of this pre-configured size nonsense). The user interface is "OK" - it's fairly simplistic, but seems to get the job done. They have a 14 day trial.

                                   

                                  I looked at VEEAM, but it seems overkill for our needs.

                                  For the record, I have no affiliation with any backup software company, I'm just trying to find something that works.

                                  • 14. Re: vDP simply does not work
                                    sm00ter Novice

                                    Just curiously....

                                     

                                    Do you have VM's nested under vAPP/s?

                                     

                                    I am having quite the same issues with constant failing backups:

                                     

                                    VDP: Backup Job .... failed to backup client xxxxx.  Execution Error:  E30927:An attempt was made to backup a virtual machine client which no longer exists in vSphere...

                                     

                                    Or inconsistant successful backups!

                                     

                                    I have been working with VMware support for about a month now, and they keep pushing towards a permissions issue, so I changed the vDP permissions to utilize my personal account (as I can do anything in vSphere), and I still had the issues.

                                     

                                    Just for fun though, I started removing layers of complexity in the cluster to see where vDP gains the ability to "work".  First I removed the VM's from the vAPP, and to just the base of the cluster, and the backups were successful!!

                                     

                                    Then I put them back into a Resource Pool, and tried the backup...successful!!

                                     

                                    Once they are added to the vAPP... NO DICE!

                                     

                                    Now, this is not a "solution" but it does help in the troubleshooting process, hopefully they can figure this issue out quicker, given the fact that the "issue" has been narrowed down.

                                     

                                    Check your layers, and see if minimizing them results in successful/consistant vDP backups!!

                                     

                                    Just an idea...

                                     

                                    Thanks,

                                     

                                    sm00ter

                                    1 2 Previous Next