1 Reply Latest reply on Oct 2, 2012 9:22 PM by Reidmere

    Problem with programs connecting behind bridged DMZ

    Reidmere Lurker

      Oddly complex question, but if it wasn't, I'd have figured it out after having tried to fix it for 6 hours.... -_-

       

      Anyhow, I'm trying to run a server on the virtual machine. The VM is on a bridged connection to the router, and registered on the router to be in a DMZ.

      I am trying to have [program 2] loop out to the WAN (internet) IP address, and connect to my WAN address to [program 1] at the specified port.

      [Program 1] recognizes [program 2], and it successfully connects, but it's registering as a connection for 192.168.1.1 (my router's IP).

      In other words, it looks like it's not actually going to the internet, and just hitting the router and getting directed back without being registered as WAN.
      When using VMWare, can you directly DMZ the bridged IP, or does the firewall protecting the host computer hold back the signal?

       

       

      I'm using VMWare version 7.1.4, because it worked for another program, and don't know what version I can update to for free.
      Any help would be appreciated, especially ASAP, because I was supposed to have this up last night! @_@ lol

        • 1. Re: Problem with programs connecting behind bridged DMZ
          Reidmere Lurker

          Ok, apparently the reason it was malfunctioning is because my router can't go up to *.202, which is what I had my server set at... XD

           

          But could someone please answer my question about if DMZ'ing a VM bridged to the network actually opens it, or if the machine it's running on can still block it with firewalls?

          Edit: I messed with my firewall, changed my server to DMZ, and port forwarded the ports I needed, and it does connect, but still does the 192.168.1.1 thing.
          This is obviously a problem with it connecting to the network, so any ideas please?