5 Replies Latest reply on Oct 11, 2013 6:55 AM by ZebS

    MSI error 110 - files not found in c:\windows\installers but streaming entry points work ok

    Mr_D Novice

      I'm packaging an app called SAS 9.3

       

      When I've come to install from the MSI I get an error stating 'internal error 110...msiname'. Launching via entry points is fine.

       

      When installing msi with a verbose log generated it states..

       

       

      MSI (s) (20:FC) [15:23:23:124]: Note: 1: 1310 2: 131 3: C:\Windows\Installer\4c1ab3.msi
      MSI (c) (A0:A4) [15:23:23:280]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg
      The system cannot open the device or file specified.
      MSI (s) (20:C8) [15:41:25:937]: I/O on thread 2356 could not be cancelled. Error: 1168
      MSI (s) (20:C8) [15:41:25:937]: I/O on thread 532 could not be cancelled. Error: 1168
      MSI (s) (20:C8) [15:41:25:937]: I/O on thread 2760 could not be cancelled. Error: 1168
      MSI (s) (20:C8) [15:41:25:937]: I/O on thread 3068 could not be cancelled. Error: 1168
      MSI (s) (20:C8) [15:41:25:937]: I/O on thread 3628 could not be cancelled. Error: 1168
      MSI (s) (20:FC) [15:41:25:937]: MainEngineThread is returning 110

      ...

      Note: 1: 2755 2: 110 3: C:\Users\PACKAG~1\AppData\Local\Temp\SAS-9.3-TA-61-R01-B01.tmp.msi

      DEBUG: Error 2755:  Server returned unexpected error 110 attempting to install package C:\Users\PACKAG~1\AppData\Local\Temp\SAS-9.3-TA-61-R01-B01.tmp.msi.

      MSI (c) (A0:A4) [15:41:29:759]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

       

      An internal error has occurred: (110   C:\Users\PACKAG~1\AppData\Local\Temp\SAS-9.3-TA-61-R01-B01.tmp.msi               ). 

      MSI (c) (A0:BC) [15:41:30:647]: Product: SAS 9.3 R01 (VMware ThinApp) -- An internal error has occurred: (110   C:\Users\PACKAG~1\AppData\Local\Temp\SAS-9.3-TA-61-R01-B01.tmp.msi               ).

       

       

       

      There are indeed a series of msi's that exist in c:\windows\installer and they have been included in the Thinapp, but it seems these files are dynamically named and so 4c1ab3.msi does not exist! For example I just tried to install the msi again on the same machine and the log now states this..(everytime I try to install it tries to locate a different msi name)

       

      MSI (s) (78:E4) [16:02:36:655]: Note: 1: 1310 2: 131 3: C:\Windows\Installer\88982c.msi

      MSI (c) (44:FC) [16:02:36:718]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

      The system cannot open the device or file specified.

       

      Any pointers welcome...this isn't specific to just this app, I had the same problem with Adobe CS6 and that was convieniently solved by excluding Acrobat from the package. I don't have the option to remove anything else from this package. I should perhaps mention that it is a 4.1GB MSI and a 4.2GB DAT in case it's relevant, but I'm using msiexec v5 on Windows 7 SP1.