1 Reply Latest reply on Sep 5, 2012 4:01 AM by AndyCR

    upgrade to esx 3.02 - lost all LUNS

    AndyCR Lurker

      Hi all, I'm an ESX newbie so please forgive any dumb questions/terms....

       

      I had an esx 3.0.1 host blue screen on me last week after a sudden power outage and I couldn't recover it. So I upgraded it to 3.0.2 which went well, rebooted, checked all the vlans and config was still there, all fine, except....

       

      now there are no LUNS showing in Storage.

       

      A pair of hba's are still available in Storage adaptors (QLA2432's) - both come back on rescan so I believe they're up and functioning. 

      However, each of them shows in the details screen show "Targets: 0"

       

      The hba's connect through a fibre switch into a san and that's all working correctly as the other ESX hosts can still see the storage.

       

      I've tried re-adding storage by lun name/wildcard match etc but nothing is seen, presumably as the hba's are not seeing the SAN at all.

       

      I don't believe it's a driver issue as I've checked another 3.0.2 host with the same hba's and they're both using same drivers.

       

      Only other clue I have is that all 3 lights on back of hba's are blinking (1,2,4) - 1 is blinking red, 2 and 4 are blinking green.

       

      No other obvious errors at boot of the esx host.

       

      Any suggestions as to where to start?

       

      Many thanks

       

      Andy

        • 1. Re: upgrade to esx 3.02 - lost all LUNS
          AndyCR Lurker

          A bit more on this one... the hba's are actually qle2460 (misreported by esx). I've upgraded the firmware but still not seeing the LUNS. It looks like I may need a driver upgrade - am currently running qla2300_707 drivers but reading through compatibility lists it appears it may need the qla2x00_707 driver instead.

           

          I can't find that driver to download anywhere - can anyone help?

           

          Thanks

           

          Andy