6 Replies Latest reply on Sep 28, 2006 12:51 PM by mbeaudreault@foley.com

    Destination host unreachable; cannot pass traffic through interface.

    simonhamiltonwilkes Enthusiast

      We have 1 HP dl385 running Windows 2003 R2 64 Bit Server Service Pack1 (up to date with patches).  We have 3 guest vm servers running Windows 2003 Standard SP1 and they are all up to date with patches as well. 2 of the 3 host are running fine. One of the three can not see the network i.e., can’t send or receive any packets on either the virtual or physical networks. This VM has been running for 3 months with no problem. We had to roll back to a snapshot  (owning to a Microsoft Exchange issue, nothing to do with the Virtual Machine itself) that was taken when the system was in a know good state. When we first got the snapshot up we were able to get the interface up by disabling and enabling it. We have verified that the network settings are identical to the other servers that are running properly. Now we cannot get the network interface up at all. Any help would be appreciated.

      Thank you in advance.

        • 1. Re: Destination host unreachable; cannot pass traffic through interface.
          rcardona2k Champion

          Try resetting the TCP/IP stack with:

          netsh interface ip reset resetlog.txt[/pre]

          If that doesn't work delete the virtual network interface and let Windows re-discover it through PnP.  In the Device Manager if there are any hidden virtual network adapters (Use Show Hidden devices), delete those too.

           

          After the NIC is re-discovered, re-install the VMware Tools.

          • 2. Re: Destination host unreachable; cannot pass traffic through interface.
            simonhamiltonwilkes Enthusiast

            Thanks for your help and we're still stuck -- so anyone, please post any ideas you have.

             

            we ran the netsh command and it reset the interface (the log is at the bottom)

             

            when we looked at hidden devices, these were present but none were able to uninstall:

                 Direct Parallel

                 VMWare Accelerated AMD PCNet Adapter (DID NOT TRY TO DELETE)

                 WAN Miniport (IP)

                 WAN Miniport (L2TP)

                 WAN Miniport (PPOE)

                 WAN Miniport (PPTP)

            \- The error was "failed to uninstall the device. the device may be required to boot up the computer"

             

             

            The NIC was autodiscovered and installed .. then vmtools again -- still no network. We can ping our network address, 127.0.0.1, and even "localhost" ... but nothing else. We can release the IP, but then it won't renew. It will only get an IP on bootup -- The weird thing is that the icmp doesn't time out, it replies with "Destination Host Unreachable" as if the network parameters are bad (but its DHCP and the other hosts are fine)

             

             

            \******* RESETLOG *********

             

            reset   SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\15\RegLocation

                        old REG_MULTI_SZ =

                            SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDomain

                            SYSTEM\CurrentControlSet\Services\TcpIp\Parameters\DhcpDomain

             

            added   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_\{69450E36-EAAC-4D84-B8A1-99248D1F92AB}\NetbiosOptions

            added   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_\{F868FA3C-FF00-47E7-BD3B-521635EDED92}\NetbiosOptions

            deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{69450E36-EAAC-4D84-B8A1-99248D1F92AB}\DontAddDefaultGateway

            added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\DisableDynamicUpdate

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\IpAutoconfigurationAddress

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\IpAutoconfigurationMask

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\IpAutoconfigurationSeed

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\RawIpAllowedProtocols

                        old REG_MULTI_SZ =

                            0

             

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\TcpAllowedPorts

                        old REG_MULTI_SZ =

                            0

             

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AB6E2564-1328-4AB8-8392-9D1876C9EDF7}\UdpAllowedPorts

                        old REG_MULTI_SZ =

                            0

             

            added   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\DisableDynamicUpdate

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\IpAutoconfigurationAddress

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\IpAutoconfigurationMask

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\IpAutoconfigurationSeed

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\RawIpAllowedProtocols

                        old REG_MULTI_SZ =

                            0

             

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\TcpAllowedPorts

                        old REG_MULTI_SZ =

                            0

             

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{CC9B2491-2BEE-478B-BB79-FD117CBD4B5F}\UdpAllowedPorts

                        old REG_MULTI_SZ =

                            0

             

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{F868FA3C-FF00-47E7-BD3B-521635EDED92}\DontAddDefaultGateway

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpTimedWaitDelay

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpWindowSize

            deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution

            reset   SYSTEM\CurrentControlSet\Services\Tcpip\Performance\Object List

                        old REG_SZ = 502 510 546 548 582 638 658 1530 1532 1534

             

             

            • 3. Re: Destination host unreachable; cannot pass traffic through interface.
              simonhamiltonwilkes Enthusiast

              resolved --

               

              used msconfig to shut off everything and re-enable it one by one to find the culprit. ipsec has now been disabled and network happiness is abundant.

               

              i'm so happy that i wasted 2 days on troubleshooting VM networking ...

              • 4. Re: Destination host unreachable; cannot pass traffic through interface.
                rcardona2k Champion

                Congratulations but I'd say you were troubleshooting OS networking[/i] as the same thing can happen with a physical machine.

                • 5. Re: Destination host unreachable; cannot pass traffic through interface.
                  simonhamiltonwilkes Enthusiast

                  yeah ... that was my "wasted" comment -- troubleshooting a problem that wasn't really VM. I'm still not sure why it all the sudden "broke" though.  All of our other VMs have the "IPSec" service started and they don't have any issues.

                   

                  thanks for you help -

                  • 6. Re: Destination host unreachable; cannot pass traffic through interface.
                    mbeaudreault@foley.com Novice

                    Just wanted to post to say that I had the same problem. I also chased VM networking as I landed in this bind after a failed migration to a 3.0 cluster from a 2.5.2 server. Part of that disaster was having to clone the vmdk to a new server to get around a corrupted configuration file (different story). Anyway I also disabled ipsec services and the server is now pinging at will. Thanks for posting that you resolved this.