1 Reply Latest reply on Jun 14, 2012 8:13 AM by WWI

    [SOLVED] Starting Workflows via SOAP, there will be no result

    WWI Novice

      Hi together,

       

      we have the problem, that we are no longer able to start workflows via SOAP-Call.

      Last week, we've updated our vCO to 4.2.1 Build 555 - Everything is working fine.

      => Workflows via SOAP will be executed and results will be returend.

       

      Now we've updated our vCenter to 5.0 U1 - Now we have a problem.

      => Workflows via SOAP will be executed, finish correct, but will not return any Value or create Logs.

      => Running these workflows in the Orchestrator Client (32Bit), everything is fine and results are returned.

       

      When calling Workflows via SOAP, I can see Java-Errors in the vCO-Server Log (see attachement "vco-server.log")

       

      I'm wondering about Line 4: ...ERROR [VimSession] getOrCreateVimObject() --> Cannot createcom.vmware.vmo.plugin.vi4.model.VimVmFolder <group-v10>

       

      Shouldn't this be a "vi5" Plugin? In the vCO-Client I can see, that we are only using a 5.0.1 vCenter-Plugin.

       

      Does anyone else have problems, running SOAP-Requests against vCO 4.2.2 with vCenter 5.0 U1?

      (Our SOAP-Requests are done via PHP, using the build in SOAP-Class. Example: $soap = new SoapClient("<SOAP-HOST>");...)

       

      I've opened a SR too - But still no usable response... :O

       

      Thanks & Regards from Germany,

      Marc