4 Replies Latest reply on Apr 6, 2016 3:18 AM by Cordb

    VMware Tools on SLES 11 SP2

    robpou Novice

      Hi there,

       

      anyone using ESX 3.5 with SLES 11 SP2 yet/already?

       

      On ESXi5, I can install VMware Tools (8.6.0) without problems on a clean SP2 install or after an upgrade from SP1 to SP2.

       

      On 3.5 however, the kernel version change - SP2 got a shiny new 3.0.13 after SP1's 2.6.32 - distracts the installer. The problem is, that SUSE provided every kernel package with version 3.0.13 (kernel-default, kernel-default-base, kernel-source, kernel-syms - but the linux-kernel-headers package remains 2.6.32, to provide backward compatibility...

       

      What is the location of the directory of C header files that match your running
      kernel? [/usr/src/linux/include]

       

      The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does not match
      your running kernel (version 3.0.13-0.27-default).  Even if the module were to
      compile successfully, it would not load into the running kernel.

       

      What is the location of the directory of C header files that match your running
      kernel? [/usr/src/linux/include] /lib/modules/3.0.13-0.27-default/build/include

       

      The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does not match
      your running kernel (version 3.0.13-0.27-default).  Even if the module were to
      compile successfully, it would not load into the running kernel.

       

      as said, the Tools installer in ESXi5 does not have any problems like this. Unfortunately, our 3.5 hosts are not compatible with newer ESX(i) versions, hence must remain on 3.5.

       

      Any hints?