5 Replies Latest reply on Jun 18, 2020 11:12 AM by GregPerry2

    Cannot set Syslog.global.logHost either by GUI or PowerCLI

    cougar694u Enthusiast

      Every time I try, either in vCenter, vSphere Client connected directly to the host, or with PowerCLI, I get "A general system error occurred: Internal Error" when trying to set Syslog.global.logHost.

       

      vSphere Client to the host gets this error: Call "OptionManager.UpdateValues" for object "ha-adv-options" on ESXi "hostname" failed.

       

      vSphere Client to vCenter gets this error: Call "OptionManager.UpdateValues" for object "EsxHostAdvSettings-143545" on vCenter Server "vcenter" failed.

       

      For PowerCLI, I run this: set-VMHostAdvancedConfiguration -vmhost hostname -Name "Syslog.global.logHost" -Value "splunk"

      I've also tried:

      set-VMHostAdvancedConfiguration -vmhost hostname -Name Syslog.global.logHost -Value splunk

      set-VMHostAdvancedConfiguration -vmhost hostname -Name Syslog.global.logHost -Value udp://splunk:514

       

      all three give this:

       

      Set-VMHostAdvancedConfiguration : 3/2/2012 1:28:14 PM    Set-VMHostAdvancedConfiguration        A general system error occurred: Internal error
      At line:1 char:32
      + set-VMHostAdvancedConfiguration <<<<  -vmhost hostname -Name "Syslog.global.logHost" -Value "splunk"
          + CategoryInfo          : NotSpecified: (:) [Set-VMHostAdvancedConfiguration], SystemError
          + FullyQualifiedErrorId : Client20_SystemManagementServiceImpl_GetVmHostAdvancedConfiguration_ViError,VMware.VimAutomation.ViCore.Cmdlets.Commands.Host.SetVMHostAdvancedConfi
         guration

       

      Host summary tab shows the Config Issue of "System Logging is not configured on the host", which is why I was trying to ship the logs to my splunk server.  It works fine on our 4.0 & 4.1 ESXi hosts, just not 5.0.

       

      It was a fresh install that I configured.  When I got these errors, I reset the configuration, only configured the VLAN & IP, and still get these errors.

       

      Any ideas?

       

      **EDIT**
      I wanted to add that a get works just fine:

       

      PS P:\> get-VMHostAdvancedConfiguration -vmhost hostname -Name "Syslog.global.logHost"

       

      Name                           Value

      ----                           -----

      Syslog.global.logHost

       

      Message was edited by: cougar694u ~added content