3 Replies Latest reply on Apr 16, 2015 1:56 AM by ManoharEndla

    Agent permissions problem

    ds94103 Hot Shot
      I installed a server and agent on the same host, then shut down the agent and restarted the server a number of times (I have another agent running on another host).  I just tried to restart the agent, but get the following in the agent.log:

      2006-08-22 10:57:59,975 WARN  [ConfigPopulateThread] Unable to get entities for agent: Unable to invoke 'measurementGetConfigs':  Permission denied
      2006-08-22 10:57:59,975 WARN  [ConfigPopulateThread] Sleeping for 10 seconds to fetch entities
      2006-08-22 10:58:01,613 ERROR [AutoinventoryCommandsServer] Unable to send autoinventory platform data to server, sleeping for 15 secs before retrying.  Error: Unable to invoke 'aiSendReport':  Permission denied
      2006-08-22 10:58:16,633 ERROR [AutoinventoryCommandsServer] Unable to send autoinventory platform data to server, sleeping for 22 secs before retrying.  Error: Unable to invoke 'aiSendReport':  Permission denied

      Needless to say, the server is not discovering any resources from this agent.

      I checked all the subdirectories under the hyperic home directory, and all files are owned by hyperic:hyperic.  The agent and server are both running as hyperic.

      From all appearances, the agent is listening on port 7443 (the TCP port is open, I tried it).  When I try to add a platform for the agent running on the same host as the server, the drop-down menu for "Agent Connection" only lets me specify port 2144, which is clearly wrong.  I get the following in the server log at that point:

      2006-08-22 11:12:36,071 INFO  [org.hyperic.hq.autoinventory.server.session.AIScheduleManagerEJBImpl] Scheduling job for immediate execution: JobDetail 'autoinventory.aiScan-10052-1-config-15905173-1156270356071':  jobClass: 'org.hyperic.hq.autoinventory.server.session.AIScanJob isStateful: false isVolatile: true isDurable: false requestsRecovers: false
      2006-08-22 11:12:36,115 INFO  [org.hyperic.hq.autoinventory.agent.client.AICommandsClient] AICommandsClient.startScan for 10.1.0.123:2144
      2006-08-22 11:12:36,268 ERROR [org.hyperic.hq.autoinventory.server.session.AIJob] Unable to execute command: Agent error: Unauthorized
      2006-08-22 11:12:36,273 ERROR [org.hyperic.hq.autoinventory.server.session.AIScanJob] Agent error: Unauthorized
      org.hyperic.hq.autoinventory.AutoinventoryException: Agent error: Unauthorized
           at org.hyperic.hq.autoinventory.server.session.AIJob.doAgentScan(AIJob.java:151)
           at org.hyperic.hq.autoinventory.server.session.AIScanJob.execute(AIScanJob.java:81)
           at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
           at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)

      The server also can't autodiscover the client, apparently.  I get these messages in the server log at regular intervals:

      2006-08-22 11:18:20,225 WARN  [org.hyperic.hq.bizapp.server.session.LatherDispatcher] Unauthorized agent from 10.1.0.123 denied

      I'm a bit at a loss here.  Any idea what I'm doing wrong?

      Thanks.

      David
        • 1. Re: Agent permissions problem
          john_hyperic Expert
          Not sure what the problem is or how it was caused, but we can probably
          fix it by cleaning out the agent and starting fresh.

          First, your agent is not listening on 7443, that is your HQ Server
          (unless you specified the agent to listen on that port in the
          agent.properties - if you did this, pick another port, the server uses
          that one by default).

          To re-initialize the agent, first shut it down.  Next, remove the data
          directory in the agent install location.  Now start up the agent.  It
          will know nothing at this point, so you will have to answer the
          questions like you did the first time you installed it.  Once, it is
          configured and talking to the server again, everything should work.  If
          you still have problems, post the relevant log entries.

          • 2. Re: Agent permissions problem
            ds94103 Hot Shot
            Yup, that did the trick - you were right about the port #, I was looking at the wrong thing in agent.properties.

            HQ is behaving well now - if I manage to re-create the permissions issue I will be back.

            d
            • 3. Re: Agent permissions problem
              ManoharEndla Novice

              Same issue on 4.6.6 version . Agent and server are on same server .Deleted data folder and tried with a restart but it couldn't help

               

              Unable to invoke 'aiSendReport':  Permission denied