1 2 Previous Next 16 Replies Latest reply on Apr 27, 2012 5:20 PM by fmouse

    Linux Mint 12 installs in "fallback mode"

    mindenhallm Lurker

      Linux Mint 12 was released over the weekend (based on Ubuntu 11.10 "Oneiric").  The default desktop environment is Gnome 3 with MGSE (Mint Gnome Shell Extensions) -- a very nice alternative to Gnome 3 or Unity.  This requires 3D graphics acceleration to run, and if acceleration is not detected, the LM12 runs in "fallback mode", which is a Gnome 3 environment scaled back to resemble Gnome 2.


      LM12 runs in fallback mode in both Workstation 8.01 and Player 4.01, regardless of whether 3D acceleration is enabled for the virtual machine.  Several people are reporting this in the Linux Mint forums (here and here).  It seems that LM12 is somehow evaluating the detected graphics hardware at boot time, and something about the VMware environment fails the test.  It should be noted that this failure is specific to VMware right now -- a VirtualBox VM with 3D acceleration enabled boots into the full G3+MGSE on the same host machine.


      This issue can be easily duplicated by downloading the LM12 installation iso, and booting it within a newly created VM (with 3D acceleration enabled).  The installer will boot into an environment with "Applications" and "Places" menus on the upper left, which is indicative of fallback mode.  This can be confirmed by going to Applications->System Tools->System Settings->System Info->Graphics, where the graphics driver is listed as "Software Rasterizer", and the experience as "Fallback".


      Any suggestions on workarounds, or steps to take to pinpoint the problem would be much appreciated!

        • 1. Re: Linux Mint 12 installs in "fallback mode"
          mindenhallm Lurker

          I forgot to mention that my host is Windows 7 Pro 64-bit, and I'm running the Linux Mint 12 64-bit version as a Workstation 8.01 guest.

          • 2. Re: Linux Mint 12 installs in "fallback mode"
            mrlithium Lurker

            I can confirm this - Not working on VMWare 8.0.0, Windows 7 64-bit, Linux Mint 12 DVD 64- bit == No Chromium and Software Rasterizer / Fallback

            • 3. Re: Linux Mint 12 installs in "fallback mode"
              Naki Enthusiast

              Hmm, so do you mean Ubuntu's Unity works with all fancy 3D bells and whistles? I think it does not too.

              • 4. Re: Linux Mint 12 installs in "fallback mode"
                mindenhallm Lurker

                I also tested an Ubuntu 11.10 VM briefly.  Unity appeared to be fully working.  I think Ubuntu did some work to make sure that the full experience was supported in VM environments that support 3D acceleration.


                It seems the issue here is not limited to Linux Mint 12...there are reports (here and elsewhere) of other distros using Gnome 3 that are running only in fallback mode in VMware (e.g., Fedora 15).

                • 5. Re: Linux Mint 12 installs in "fallback mode"
                  mrlithium Lurker

                  Ubuntu 11.10 works in "Standard" mode - not fallback mode- it says "Graphics Driver: Unknown. Experience: Standard".


                  I am trying to figure out what makes Ubuntu work in Standard mode and what makes Linux Mint fallback - I am not a linux expert but I have checked the /var/log/Xorg.0.log file - In both Ubuntu 11.10 and Linux Mint 12 it says:

                  [    26.116] (II) LoadModule: "vmwgfx"
                  [    26.116] (WW) Warning, couldn't open module vmwgfx
                  [    26.116] (II) UnloadModule: "vmwgfx"
                  [    26.116] (II) Unloading vmwgfx
                  [    26.116] (EE) Failed to load module "vmwgfx" (module does not exist, 0)
                  [    26.116] (EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
                  [    26.116] (II) vmware: Using vmwlegacy driver everything is fine.
                  [    26.116] (II) LoadModule: "vmwlegacy"

                  and then later:

                  [    26.854] (II) AIGLX: Screen 0 is not DRI2 capable
                  [    26.854] (II) AIGLX: Screen 0 is not DRI capable
                  [    26.854] (II) AIGLX: Trying DRI driver /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
                  [    26.956] (II) AIGLX: Loaded and initialized swrast


                  glxinfo on both OS'es outputs the same stuff.


                  Wish we could find an expert to help us out.

                  • 6. Re: Linux Mint 12 installs in "fallback mode"
                    piggyz Enthusiast

                    No need for experts. Simply, Gnome 3 wont work in Normal Mode under any VMware Workstation becouse it needs OpenGL support and VMware products do not offert it. So no Gnome 3 under VMware Workstation and Player and any other VMware product until they will offer OpenGL support.


                    Other free virtualization software offer pretty decent OpenGL support and Gnome 3 is now completely supported.

                    • 7. Re: Linux Mint 12 installs in "fallback mode"
                      Dirald Novice

                      @piggyz that's not totally up to date. VMWare has an (experimental) OpenGL driver which is known to work for SuSE and Ubuntu meanwhile. Unfortunately it doesn't work for my Mint Installation when I follow the Ubuntu how to. Let's hope things change soon


                      And if anybody got it to work for Mint it would be nice if he could post it here of course.


                      Link to the VMWare statement regarding OpenGL: http://communities.vmware.com/thread/343121

                      Link to the how to article for Ubuntu: http://joostlek.nl/vmware-linux-guest-with-3d-accelerated-graphics

                      • 8. Re: Linux Mint 12 installs in "fallback mode"
                        thellstrom Novice
                        VMware Employees

                        I installed mint12 x86 today in an attempt to see what was going wrong, and after some tweaking I actually got both gnome-shell and cinnamon to

                        work with the new driver, so this is more of an installation issue than a driver issue.


                        First, when mesa is built according to the instructions, libGL.so.1.2 is installed in /usr/lib whereas the original mesa libGL.so.1.2 is installed in

                        /usr/lib/xxxxxxx/mesa. Any 3D app will pick up the original mesa, and it's not compatible with the vmwgfx_dri.so driver.


                        Second, it's not completely sure that the dri device /dev/dri/card0 is read / writeable for the user currently logged in, if the vmwgfx standalone kernel driver is used. To get the distro default behaviour one needs to install a 3.2.0 or later kernel with the kernel-shipped vmwgfx driver.


                        So anyway, to get a preview how it looks, after installing the driver


                        1) log in using gnome fallback mode.

                        2) Issue "sudo chmod a+rw /dev/dri/card0"

                        3) export LD_LIBRARY_PATH=<path_to_mesa>/lib

                        4) export LIBGL_DEBUG=verbose

                        5) ldd `which glxgears`  - The libGL.so.1.2 should point to the path of the local mesa library

                        6) glxgears - Should show that it picks up vmwgfx_dri.so and not that it's using indirect rendering.

                        7) gnome-shell --replace &  - Gnome-shell should start up

                        8) cinnamon --replace & - Cinnamon starts up.


                        Note that these settings are not persistent across a logout, so you can't choose gnome-shell or cinnamon in the login menu and expect it to work.

                        • 9. Re: Linux Mint 12 installs in "fallback mode"
                          fmouse Enthusiast

                          I'm havintg the same problem here, running Ubuntu 11.10 as a guest under VMware Fusion 4.1.1 (536016) on an iMac running Lion.  This problem seems to be common to several of the VMware virtual environments.  Trying to start gnome-shell results in the error:


                          failed to create drawable

                          (gnome-shell:3432): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to select the newly created GLX context
                          Window manager error: Unable to initialize Clutter.


                          I havr 3D Acceleration enabled in the VM environment.

                          • 10. Re: Linux Mint 12 installs in "fallback mode"
                            fmouse Enthusiast

                            I should add that starting Gnome falls back to Gnome Fallback also.

                            • 11. Re: Linux Mint 12 installs in "fallback mode"
                              fmouse Enthusiast

                              Come on, VMpeople!!  What do I need to do, or buy from VMware, to get OpenGL 3D acceleration support for Linux on my iMac under VMware Fusion?  Researching this, it seems that this question has been asked again and again, for years, over at least two major version upgrades of VMware Fusion?  Modern Linux desktops distributions running Gnome-3, Cinnamon, etc. as desktop environments increasingly require this capability.  VMware Fusion for the iMac supports it for Windows Vista, Windows XP and Windows 7.  Why not for Linux?  Do I have to upgrade to a (more expensive!) VMware product to get this capability?


                              Is there some political or marketing reason, or IP licensing reason, that this isn't done?  It can't be all that technically difficult.  Parallels has it, and I know that VMware has some of the best software developers in the business.


                              I've been a VMware fan for at least a decade, and the integration of VMware Fusion with the Mac-OS Lion desktop is nothing short of brilliant, but I'm being held back in my Linux VMs by the fact that VMware apparently chooses not to support OpenGL 3D acceleration for Linux guest OSes.  It's only a matter of time before I download a trial version of Parallels, since apparently Parallels does have this support!




                              ..... a long-time VMware fan and customer

                              • 13. Re: Linux Mint 12 installs in "fallback mode"
                                fmouse Enthusiast
                                • Linux 3D desktop experience, particularly Ubuntu 12.04 LTS and recent OpenSUSE releases, which should work out-of-the-box
                                • Linux 3D application graphics correctness and performance


                                YES!!  This looks promising.  Thanks

                                • 14. Re: Linux Mint 12 installs in "fallback mode"
                                  fmouse Enthusiast

                                  WoodyZ wrote:


                                  Have a look at: What's New in the VMware Fusion Technology Preview 2012

                                  WoodyZ, thanks, but no joy here   I installed the tech preview, upgraded my Linux Mint 12 VM, re-installed the VMware tools, made sure that 3D acceleration was turned on for the VM, restarted the whole shlamiel, and still get bumped back to fallback mode when trying to start Cinnamon or Gnome-3 with gnome-shell.  The usual error, e.g...


                                  $ cinnamon --replace
                                   failed to create drawable
                                  (cinnamon:3101): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to select the newly
                                   created GLX context
                                  Window manager error: Unable to initialize Clutter.


                                  I note that the VM Settings | Display dialog still doesn't list Linux as a supported OS for 3D acceleration.  Maybe this feature hasn't yet been implemented. I'll post to the tech preview blog and see if anyone there can help me.

                                  1 2 Previous Next