7 Replies Latest reply: Nov 3, 2011 8:51 AM by Walfordr RSS

    Network issues

    Phatsta Enthusiast

      Recently I discovered that I cannot connect to any ftp site from any client in my network. I've tried with 5+ computers and several different ftp clients such as CoreFTP, FileZilla and WinSCP. They all time out leaving an error message saying only "timeout error". To me this looks like a firewall issue, so I've made sure to turn off all software firewalls from the group policy. I also have a m0n0wall router with firewall running as a virtual machine on one of my ESXi4.1 hosts, and I've even tried adding rules in this to allow all traffic in both directions. No matter what I do, ftp will not work. All other protocols seems to work though, we have no connectivity issues towards the internet, it's only ftp that fails. To ensure the problem is in fact in my network, I now have my WinXP client on an external IP directly connected to the internet, and ftp works perfectly. So I know there's something wrong with my network setup, but I can't figure out where and I'm starting to suspect the ESXi network settings. This is my setup: WAN ---> vSwitch0 ---> m0n0wall VM ---> vSwitch1. vSwitch0 leads only to the m0n0wall VM (and it's WAN interface of course). vSwitch1 is the main network where all the clients and servers are connected. I've looked at the settings for the switches and both vSwitch0 and 1 have the same settings under vSwitch properties: Security Promiscuous Mode: Reject MAC Address Changes: Accept Forged Transmits: Accept Traffic Shaping Status: Disabled NIC Teaming Load Balancing: Route based in the originating virtual port ID Network Failover Detection: Link status only Notify Switches: Yes Failback: Yes Under Active adapters I've only got 1 NIC on each vSwitch. Anyone got any ideas where I should start to look?