4 Replies Latest reply on Oct 28, 2011 7:29 AM by nobleone

    Server reboot automatically (vSphere5)

    nocrack Novice

      Hi all,

       

      I'm trying to use autodeploy but I've got a problem at the point where the server I try to install ESXi5 on reboot automatically and all the time.

       

      Basically,

       

      I've got a new vSphere5 environment with 1 server in a cluster. vSphere 5 is the appliance that you can download on the vmware website. I've installed auto Deploy, I've installed the PowerShell on a windows machine, created a depot, and tried to boot my server (IBM x3850 [efi, not bios]).

      The server boot up, get an ip address, loads gpxe, fetch the tramp file, then reboot.

      It can definitelly get the tramp file located at https://<ip_address>:6502/vmw/rdb/tramp as if I change the one in the tftp directory, It gives me the error that it can't access the tamp file.

       

      Here is what's in the tramp file (in vSphere):

      #!gpxe
      
      set retry-delay 20
      post /vmw/rbd/host-register?bootmac=${mac}

      and attached is the vSphere config.

      Any help would be greatly apreciated!!!

       

      Many thanks,
      Arnaud

        • 1. Re: Server reboot automatically (vSphere5)
          nocrack Novice

          Is that an isolated problem ? No one came across a similar issue ?

          Someone can maybe point me to a direction to start with ?

           

          Thanks!

          • 2. Re: Server reboot automatically (vSphere5)
            RobertRuge Novice

            Arnaud, I think that EFI is your problem. From the release notes I read:

             

            "vSphere 5.0 supports  booting ESXi hosts from the Unified Extensible Firmware Interface  (UEFI). With UEFI you can boot systems from hard drives, CD-ROM drives,  or USB media. Network booting or provisioning with VMware Auto Deploy  requires the legacy BIOS firmware and is not available with UEFI."

             

            I am running into similar problems with Dell M610 blades in a M1000e chassis. The BIOS won't see the 10GbE mezzanine card as a PXE device but when I use UEFI to PXE boot off the mezzanine card I see it download the tftp boot file and then it fails. On the bleeding edge again. Doh.

             

            The good news is that Auto Deploy worked fine for me on another server that was just using BIOS booting.

             

            Regards

            Robert

            1 person found this helpful
            • 3. Re: Server reboot automatically (vSphere5)
              nocrack Novice

              Thank you, that's what I thought too.

              But it's quite enoying because the network card initialisation is after the efi pxe boot... so not sure how I can get round this. I'll look at the efi settings at some point.

              And if it doesn't work, why do they provide a uefi tftp boot file ? -_-'

               

              Anyway, thanks for the help!

              • 4. Re: Server reboot automatically (vSphere5)
                nobleone Novice

                I was actually having the same exact issue. Mine turned out being an MTU setting.

                 

                Turns out the virtual interfaces on our switch were set to 1500 MTU. When I was trying to route between gPXE on the host and the Auto Deploy server on a seperate subnet things would fail.

                 

                Turns out gPXE uses a frame size of 1518.

                 

                Maybe this helps.